Bug 52091 - wu-ftpd creates incorrect user
wu-ftpd creates incorrect user
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: setup (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-20 10:01 EDT by Chris Ricker
Modified: 2014-03-16 22:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-20 15:24:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2001-08-20 10:01:38 EDT
I just did a fresh install of RC1, and noticed that the ftp account is
being created with a home directory of /home/ftp.  This should be /var/ftp
to comply with the (brain-dead) standards about shovelling all that crap in
/var.

Furthermore, the home directory created doesn't even exist.  I presume it's
created by the anonftp package, which wasn't installed (should it have
been, as a dep?)

[kaboom@verdande evolution]$ rpm -qa | grep ftp
lftp-2.4.0-1
tftp-0.17-14
ncftp-3.0.3-6
ftp-0.17-12
wu-ftpd-2.6.1-18
[kaboom@verdande evolution]$ grep ftp /etc/passwd
ftp:x:14:50:FTP User:/home/ftp:/sbin/nologin
[kaboom@verdande evolution]$ ls /home/ftp
ls: /home/ftp: No such file or directory
[kaboom@verdande evolution]$
Comment 1 Bernhard Rosenkraenzer 2001-08-20 10:07:19 EDT
Actually the user isn't created at all - it's in the initial /etc/passwd file 
in the setup package.
Comment 2 Chris Ricker 2001-08-20 10:11:51 EDT
Okay, that would make a little more sense.

While you're fixing stuff with the password file, it also contains

gopher:x:13:30:gopher:/usr/lib/gopher-data:/sbin/nologin

The home for gopher should also be moved to /var to be standards-compliant (I'm
not sure if RH even ships a gopher server any more that might need changing as
well?)
Comment 3 Bill Nottingham 2001-08-20 14:19:00 EDT
anonftp %post changes the home dir, for use on upgrades, FWIW. So any
situation that needs it should be fixed.

(The problem is since passwd/group are all correctly %config(noreplace),
any changes to them must be done twice (once in setup, once in a %pre/%post
somewhere other than setup (putting the scripts on setup causes prereq loops.)))
Comment 4 Glen Foster 2001-08-20 15:24:44 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 5 Bill Nottingham 2001-08-20 16:39:55 EDT
Will be changed in 2.5.6-1.

Note You need to log in before you can comment on or make changes to this bug.