Bug 520966 - RFE: sending URLs to Chromium - patch included
Summary: RFE: sending URLs to Chromium - patch included
Keywords:
Status: CLOSED DUPLICATE of bug 316131
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 11
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Novotny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 23:23 UTC by Wolfgang Rupprecht
Modified: 2009-09-23 15:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-23 15:05:45 UTC


Attachments (Terms of Use)
patch to browse-url.el to allow emacs to use chromium (4.04 KB, patch)
2009-09-02 23:23 UTC, Wolfgang Rupprecht
no flags Details | Diff

Description Wolfgang Rupprecht 2009-09-02 23:23:24 UTC
Created attachment 359608 [details]
patch to browse-url.el to allow emacs to use chromium

Description of problem:

Now that there is an experimental port of Google Chromium to Fedora, it would be nice to be able to use Chromium as emacs's default browser too.  Here is the patch to do that.

Version-Release number of selected component (if applicable):

GNU Emacs 23.1.1 (x86_64-redhat-linux-gnu, GTK+ Version 2.16.5) of 2009-08-26 on xenbuilder4.fedora.phx.redhat.com


How reproducible:
always.

Steps to Reproduce:
1. start emacs
2. type a url into a buffer, or find a file with a url
3. position the cursor on the url and type 
4. M-x browse-url
  
Actual results:
Emacs starts some lame browser, probably firefox

Expected results:
Emacs starts a new shiny browser like Chromium. ;-)

Additional info:

the package emacs-vm could user some roto-tilling.  It predates browse-url.el and therefore tries to duplicate much of that functionality.  As a stopgap one can set this on one's emacs init file, but it is probably best to just do that in vm itself.

(setq vm-url-browser browse-url-browser-function)

Comment 1 Daniel Novotny 2009-09-23 15:05:45 UTC
can be configured on higher level: using xdg-open, everyone can select their preferred browser: see bug 316131

*** This bug has been marked as a duplicate of bug 316131 ***


Note You need to log in before you can comment on or make changes to this bug.