Bug 520977 - xemacs -q C-x 5 2 crashes with sig abort
Summary: xemacs -q C-x 5 2 crashes with sig abort
Keywords:
Status: CLOSED DUPLICATE of bug 480845
Alias: None
Product: Fedora
Classification: Fedora
Component: xemacs
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-03 01:40 UTC by Ram Bhamidipaty
Modified: 2009-09-03 14:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-03 14:02:21 UTC


Attachments (Terms of Use)

Description Ram Bhamidipaty 2009-09-03 01:40:21 UTC
Description of problem: xemacs -q then C-x 5 2 crashes (sigabort).

(gdb) run -q
Starting program: /usr/bin/xemacs-21.5-b28 -q
[Thread debugging using libthread_db enabled]
Warning: Missing charsets in String to FontSet conversion
Detaching after fork from child process 21416.
Detaching after fork from child process 21417.
Detaching after fork from child process 21418.
Detaching after fork from child process 21421.
Detaching after fork from child process 21422.

Fatal error: assertion failed, file menubar-x.c, line 579, ABORT()

Program received signal SIGABRT, Aborted.
0x00558424 in __kernel_vsyscall ()
Missing separate debuginfos, use: debuginfo-install e2fsprogs-libs-1.41.4-12.fc11.i586 libXcursor-1.1.9-4.fc11.i586 libXfixes-4.0.3-5.fc11.i586 libXrender-0.9.4-5.fc11.i586 libxcb-1.2-4.fc11.i586
(gdb) where
#0  0x00558424 in __kernel_vsyscall ()
#1  0x00a7d7c1 in *__GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#2  0x00a7f092 in *__GI_abort () at abort.c:88
#3  0x080c1e3b in really_abort () at emacs.c:4693
#4  0x080c2e23 in assert_failed (file=0x82422d1 "menubar-x.c", line=579, expr=0x8218378 "ABORT()") at emacs.c:3986
#5  0x081f7a07 in set_frame_menubar (f=0x8affc70, deep_p=<value optimized out>, first_time_p=<value optimized out>)
    at menubar-x.c:579
#6  0x081e2912 in x_create_widgets (f=0x8affc70, lisp_window_id=<value optimized out>, parent=<value optimized out>, 
    overridep=137124004) at frame-x.c:1948
#7  0x0811a6bb in Fmake_frame (props=137124004, device=137124004) at frame.c:562
#8  0x080c92dd in Ffuncall (nargs=1, args=0xbffff1a4) at eval.c:3915
#9  0x0809d247 in Fcall_interactively (function=137100724, record_flag=137124004, keys=137124004) at callint.c:994
#10 0x080ce124 in Fcommand_execute (cmd=137100724, record_flag=137124004, keys=137124004) at eval.c:3138
#11 0x080da547 in execute_command_event (command_builder=0x8912090, event=146012124) at event-stream.c:4288
#12 0x080dcaad in Fdispatch_event (event=146012124) at event-stream.c:4640
#13 0x080a46c1 in Fcommand_loop_1 () at cmdloop.c:600
#14 0x080a4799 in command_loop_1 (unused_dummy=137124004) at cmdloop.c:505
#15 0x080cae8a in condition_case_1 (handlers=137120500, bfun=0x80a4780 <command_loop_1>, barg=137124004, 
    hfun=0x80a4940 <cmd_error>, harg=137124004) at eval.c:1946
#16 0x080a48da in command_loop_3 () at cmdloop.c:262
#17 command_loop_2 () at cmdloop.c:275
#18 0x080c8be1 in internal_catch (tag=136874020, func=0x80a48a0 <command_loop_2>, arg=137124004, threw=0x0, 
    thrown_tag=0x0, backtrace_before_throw=0x0) at eval.c:1552
#19 0x080a4ba5 in initial_command_loop (load_me=137124004) at cmdloop.c:313
#20 0x080c4804 in xemacs_21_5_b28_i386_redhat_linux (argc=2, argv=0xbffff754, unused_envp=0x0, restart=0) at emacs.c:2667
#21 0x080c540c in main (argc=2, argv=0xbffff754, unused_envp=0xbffff760) at emacs.c:3111

Comment 1 Jerry James 2009-09-03 14:02:21 UTC

*** This bug has been marked as a duplicate of bug 480845 ***


Note You need to log in before you can comment on or make changes to this bug.