Bug 520989 - ibus-anthy icon enhancement
Summary: ibus-anthy icon enhancement
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-anthy
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-03 03:03 UTC by fujiwara
Modified: 2010-04-09 04:07 UTC (History)
6 users (show)

Fixed In Version: ibus-anthy-1.2.0.20100313-2.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-09 04:07:54 UTC


Attachments (Terms of Use)
Option1 ibus-off + "Anthy" SVG file (94.46 KB, application/octet-stream)
2009-10-01 03:55 UTC, fujiwara
no flags Details
Option2 Japanese flag + "Anthy" SVG file (3.27 KB, application/octet-stream)
2009-10-01 03:58 UTC, fujiwara
no flags Details
Option3 "a" + kbd + "Anthy" SVG file (77.24 KB, image/svg+xml)
2009-10-01 09:39 UTC, fujiwara
no flags Details
nihongo icon (2.72 KB, image/png)
2009-10-15 13:45 UTC, Máirín Duffy
no flags Details
kaku icon (3.19 KB, image/png)
2009-10-15 14:03 UTC, Máirín Duffy
no flags Details
one more idea... a gate (6.81 KB, image/png)
2009-10-15 14:22 UTC, Máirín Duffy
no flags Details
a ち key icon (6.87 KB, image/png)
2009-10-16 14:46 UTC, Máirín Duffy
no flags Details
a ち key icon with anthy caption (2.83 KB, image/png)
2009-11-25 04:11 UTC, fujiwara
no flags Details
f13 rawhide live screenshot (5.68 KB, image/png)
2009-12-01 06:55 UTC, Jens Petersen
no flags Details
icon comparison screenshot (37.63 KB, image/png)
2009-12-01 20:33 UTC, Máirín Duffy
no flags Details
icon test case (2.62 KB, image/png)
2009-12-02 01:10 UTC, fujiwara
no flags Details
icon test case#2 with the gtk-icon-theme dir. (4.09 KB, image/png)
2009-12-03 05:23 UTC, fujiwara
no flags Details
18x18 version of the icon (693 bytes, image/png)
2009-12-03 14:30 UTC, Máirín Duffy
no flags Details
icon test case with 18x18 icon (7.49 KB, image/png)
2009-12-07 07:30 UTC, fujiwara
no flags Details
New icon for ibus-anthy (4.39 KB, image/png)
2010-04-02 09:24 UTC, fujiwara
no flags Details

Description fujiwara 2009-09-03 03:03:56 UTC
Currently ibus-anthy icon is a crown pic.
It seems the icon was inherited from scim.

I'd like to consider if we can enhance the icon since I'm not fun of it.
I checked anthy web but there is no icon.

Possible Options:
 - Keep the current icon.
 - Japanese "a"
 - Slanting Handwriting "Anthy" with a red pen
 - /usr/share/icons/hicolor/48x48/status/ibus-off.png + Japanese "nihon"
 - /usr/share/pixmaps/ibus-engine.svg

Hmm..

Comment 1 fujiwara 2009-10-01 03:55:46 UTC
Created attachment 363277 [details]
Option1 ibus-off + "Anthy" SVG file

Added the option1 image file.

Comment 2 fujiwara 2009-10-01 03:58:10 UTC
Created attachment 363278 [details]
Option2 Japanese flag + "Anthy" SVG file

Added the option2 file.

The current ibus-anthy icon exists as "scim-anthy.png" on SCIM and I think it's not anthy specific.

Comment 3 Jens Petersen 2009-10-01 06:23:10 UTC
Some comments

- probably better to avoid flags in general
  (also language and country are different:)

- name "Anthy" doesn't really have much meaning


Suggestion:
How about some Japanese over ibus-off?
Something like: あ or あん or あんしー

What do you think?

Comment 4 fujiwara 2009-10-01 09:39:48 UTC
Created attachment 363301 [details]
Option3 "a" + kbd + "Anthy" SVG file

OK, I added the option3 icon after we discussed.

 icon shows:
  - which language is used
  - it's an icon of ibus-anthy
  - simple design since it could be shown with a small size

Comment 5 Jens Petersen 2009-10-02 10:14:05 UTC
Ok I think the concept is good: maybe we can get an artist
touch it up and polish.

Comment 6 fujiwara 2009-10-15 07:17:58 UTC
If you have any comments

Comment 7 Máirín Duffy 2009-10-15 13:44:56 UTC
Hi Fujiwara-san,

Well, I'm not sure if the icon is going to be the most appropriate, because the keyboard portion is the same as the new ibus icon (http://productdesign.usersys.redhat.com/w/images/c/ca/IBus4-48.png) and as a general practice it's bad to text that is many characters in an icon. (The text will be unreadable at small sizes, and like Jens pointed out, 'Anthy' doesn't mean much to first-time users.)

Do you think it would make sense to have an icon for Anthy that simply says 日本語? I gave it a shot, but it would never work at 16x16 px. Do you know what size the icon needs to work at? (see attached)

Comment 8 Máirín Duffy 2009-10-15 13:45:41 UTC
Created attachment 364913 [details]
nihongo icon

Comment 9 Máirín Duffy 2009-10-15 14:03:59 UTC
Created attachment 364915 [details]
kaku icon

another idea? works better than nihongo graphically i think (works at 16x16)

Comment 10 Máirín Duffy 2009-10-15 14:22:48 UTC
Created attachment 364919 [details]
one more idea... a gate

Comment 11 fujiwara 2009-10-16 05:21:07 UTC
(In reply to comment #7)
> Do you think it would make sense to have an icon for Anthy that simply says
> 日本語? I gave it a shot, but it would never work at 16x16 px. Do you know what
> size the icon needs to work at? (see attached)  

The problem is that Anthy itself doesn't have the official icon and I'd like to think another icon for ibus-anthy at present.
I agree the "Anthy" string is long for the icon size but I didn't mind the problem.

Now I would try to think other icons again.
The icon express:
  - which language is used
  - it's an icon of ibus-anthy
  - simple design since it could be shown with a small size

Unfortunately I think just "日本語" is too general to express it's for ibus-anthy because other Japanese input methods might be installed.
The kaku icon is one of the Kanji so I wonder if it might be confused with Chinese.

(In reply to comment #10)
> Created an attachment (id=364919) [details]
> one more idea... a gate  

Personally I like this idea but it might be a little weak to express an input method.

Now I think an icon which shows a key on Japanese keyboard 106/109.
http://ja.wikipedia.org/wiki/%E3%82%AD%E3%83%BC%E9%85%8D%E5%88%97

Comment 13 fujiwara 2009-10-16 05:35:54 UTC
I added a private link. I'm not sure if you can look at it.

How about the icon of "A ち" of the key on Japanese keyboard 106/106 ?
http://ja.wikipedia.org/wiki/%E3%82%AD%E3%83%BC%E9%85%8D%E5%88%97

The idea is, if the icon is completely original, it could be a simple design.

It seems 'Anthy' means a cartoon princess or queen so the crown icon would have the meaning. But I'd like to think a new one since Anthy doesn't have the official icon and the current icon is not directly linked to an ibus Japanese engine.

Comment 14 Máirín Duffy 2009-10-16 14:45:20 UTC
Hi Fujiwara-san,

I tried your "A ち" idea; check it out (will attach below)

Is Red Hat upstream for Anthy? If not do you think the maintainers would be open to an upstream icon design? If they took the gate design upstream, we could then use it. Another idea I had was to use an icon of a Chrysanthemum, but I don't know how widely that is used as a symbol of Japan - it seems it is on the passport http://en.wikipedia.org/wiki/Imperial_Seal_of_Japan I looked up Anthy the cartoon princess and it seems that flowers are also her symbol so maybe upstream would like it. I just don't know how well it broadcasts the idea of 'Japanese.'

Comment 15 Máirín Duffy 2009-10-16 14:46:47 UTC
Created attachment 365054 [details]
a ち key icon

Comment 16 Jens Petersen 2009-10-20 04:55:23 UTC
(In reply to comment #14)
> Is Red Hat upstream for Anthy?

No it is a separate project: Tagoh-san is the Fedora and Red Hat maintainer.

> If not do you think the maintainers would be
> open to an upstream icon design?

I think it would be a nice gesture to approach them and ask
of they are interested.  I think we can help put you in contact
with them if it helps. :)

> could then use it. Another idea I had was to use an icon of a Chrysanthemum,
> but I don't know how widely that is used as a symbol of Japan

I think that is an attractive idea.

I think "A ち" is ok though it still feels a little contrived
and not particularly anthy specific.


Having said all I should probably mention that my own
longer-term preference would still be to have ibus provide
a more textual-based status icon than relying just on static icons.
But I haven't started such work yet or managed to coerce^Wconvince
others to yet either... :)

Comment 17 Máirín Duffy 2009-10-20 05:14:28 UTC
Hi Jens,

I would be happy to talk to the Anthy upstream developers. Can you help me get in touch? I can talk to them about the Chrysanthemum idea and see what they think.

Maybe in the meantime you can use the "A ち" icon? I can splice that up into individual PNGs for you.

What do you mean by textual-based status icon vs static icons? (I'm familiar with SCIM but have not used ibus yet)

Comment 18 fujiwara 2009-10-20 07:32:30 UTC
(In reply to comment #15)
> Created an attachment (id=365054) [details]
> a ち key icon  

Thanks for your icons. I like the idea.
Probably I will need a svg image which includes the separated images; a key image and a "a ち" string image.

Comment 19 Máirín Duffy 2009-10-20 13:40:11 UTC
Hi Fujiwara-san, here's the typical way I provide icons - PNGs for 16x16, 24x24, 32x32, 48x48 and a scalable SVG that is 48x48:

http://duffy.fedorapeople.org/icons/Anthy/

Let me know if you need anything else for that icon.

Comment 20 Jens Petersen 2009-10-21 02:46:44 UTC
(In reply to comment #17)
> I would be happy to talk to the Anthy upstream developers. Can you help me get
> in touch? I can talk to them about the Chrysanthemum idea and see what they
> think.

Great

> What do you mean by textual-based status icon vs static icons? (I'm familiar
> with SCIM but have not used ibus yet)  

I mean not using icons at all (or at least only as a background) and
writing some representative character say on a canvas instead/on top.
The character/text might also relate to the input-method state/mode.

Comment 21 Jens Petersen 2009-10-21 02:48:02 UTC
An alternative might be something closer to pidgin's tray icon
with a sub-icon denoting status?

Comment 22 fujiwara 2009-11-16 05:55:04 UTC
(In reply to comment #19)
> Hi Fujiwara-san, here's the typical way I provide icons - PNGs for 16x16,
> 24x24, 32x32, 48x48 and a scalable SVG that is 48x48:
> 
> http://duffy.fedorapeople.org/icons/Anthy/
> 
> Let me know if you need anything else for that icon.  

Thanks much for your help.
Recently I noticed ibus also can show m17n-db anthy.
The following is the icon:
http://cvs.m17n.org/viewcvs/m17n/m17n-db/icons/ja-anthy.png?view=markup

I like your suggestion http://duffy.fedorapeople.org/icons/Anthy/ .
However could you also give another icon which shows "ANTHY" string below in your "A ち" icon likes m17n-db anthy icon?

Comment 23 Bug Zapper 2009-11-16 11:56:25 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 24 fujiwara 2009-11-25 04:11:21 UTC
Created attachment 373650 [details]
a ち key icon with anthy caption

I have done some tests.
It seems when I use GtkIconTheme, small svg and png looks ugly because ibus get 16x16 icon for the language bar at first and convert 16x16 to 18x18 then the small icon's string is not shown clearly.

Now I think to use one 48x48 icon only for ibus.
It looks better since the status icon, bar icon size is too small.

Currently I'm thinking to integrate the attached icon which has the "Anthy" caption.

Comment 25 fujiwara 2009-11-27 07:21:21 UTC
The icon will be upstreamed next year.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1833303

Comment 26 Jens Petersen 2009-12-01 06:49:59 UTC
The "A ち” looks too small at the default panel size to me.

Attaching screenshot from rawhide Live image.

Comment 27 Jens Petersen 2009-12-01 06:55:26 UTC
Created attachment 374976 [details]
f13 rawhide live screenshot

Mairin, is it possible to make the key label slightly bigger?

Comment 28 Máirín Duffy 2009-12-01 20:33:12 UTC
Created attachment 375185 [details]
icon comparison screenshot

Hi Jens,

The screenshot you showed me is not an issue with the icons I provided. Rather, there is an issue with how the icons were packaged.

I took a look at the ibus-anthy package in F13:
http://kojipkgs.fedoraproject.org/packages/ibus-anthy/1.2.0.20091127/1.fc13/x86_64/ibus-anthy-1.2.0.20091127-1.fc13.x86_64.rpm

There is only one icon packaged in this rpm. It's packaged to be deployed to /usr/share/ibus-anthy/icons/ibus-anthy.png. This icon is 48x48 pixels. This is not the size icon meant for display on the panel.

I am attaching a screenshot to show how a 48x48 icon is not suitable for the GNOME panel. In the screenshot, you can see the icon as packaged on the left -unreadable. You can see the 24x24 px icon I provided on the right - it is much more readable, the key label is larger, and the artwork is crisp because it was designed to snap properly within the pixel grid.

I am not sure why 'Anthy' text got added to the bottom of the 48x48 icon but it's not readable at 22x22 and should probably be removed from the 48x48 icon. I don't think adding 'Anthy' to the icon is a good idea because as a general principle text does not work well in icons. Look at the icons on your desktop right now - how many have words written in them? The pixels in text are too complex to work at the sizes icons are typically displayed at.

What I would advise doing is to package all the icons provided (http://duffy.fedorapeople.org/icons/Anthy/) into /usr/share/icons/hicolor rather than /usr/share/ibus-anthy. Here is where each icon provided should be deployed to:

http://duffy.fedorapeople.org/icons/Anthy/16x16/anthy.png should be deployed to 
/usr/share/icons/hicolor/16x16/anthy.png


http://duffy.fedorapeople.org/icons/Anthy/24x24/anthy.png should be deployed to 
/usr/share/icons/hicolor/24x24/anthy.png


http://duffy.fedorapeople.org/icons/Anthy/32x32/anthy.png should be deployed to 
/usr/share/icons/hicolor/32x32/anthy.png


http://duffy.fedorapeople.org/icons/Anthy/48x48/anthy.png should be deployed to 
/usr/share/icons/hicolor/48x48/anthy.png


http://duffy.fedorapeople.org/icons/Anthy/scalable/anthy.png should be deployed to 
/usr/share/icons/hicolor/scalable/anthy.png

This way, if the user has a larger panel, the panel can automatically determine the correct size icon to use.

Comment 29 Jens Petersen 2009-12-02 00:04:32 UTC
Thank you Máirín for your detailed response.

(In reply to comment #28)
> Created an attachment (id=375185) [details]
:
> I am attaching a screenshot to show how a 48x48 icon is not suitable for the
> GNOME panel. In the screenshot, you can see the icon as packaged on the left
> -unreadable. You can see the 24x24 px icon I provided on the right - it is much
> more readable, the key label is larger, and the artwork is crisp because it was
> designed to snap properly within the pixel grid.

Yes, right I see.

> I am not sure why 'Anthy' text got added to the bottom of the 48x48 icon but
> it's not readable at 22x22 and should probably be removed from the 48x48 icon.
> I don't think adding 'Anthy' to the icon is a good idea because as a general
> principle text does not work well in icons. Look at the icons on your desktop
> right now - how many have words written in them? The pixels in text are too
> complex to work at the sizes icons are typically displayed at.

I tend to agree: we only have one IME for Japanese really
and only one using the new icon so I think there is not much
ambiguity.

> What I would advise doing is to package all the icons provided
> (http://duffy.fedorapeople.org/icons/Anthy/) into /usr/share/icons/hicolor
> rather than /usr/share/ibus-anthy.

Fujiwara-san, I think we should try to do as Máirín suggests.

Comment 30 fujiwara 2009-12-02 01:10:14 UTC
Created attachment 375260 [details]
icon test case

Thanks for your comment.

(In reply to comment #28)
> Created an attachment (id=375185) [details]
> icon comparison screenshot
> 
> The screenshot you showed me is not an issue with the icons I provided. Rather,
> there is an issue with how the icons were packaged.

I think the your icon still shows a small string.
Yes, 48x48 would be a little small than using GtkIconTheme but currently I think it's not an essential issue because I know another problem.

> 
> I am attaching a screenshot to show how a 48x48 icon is not suitable for the
> GNOME panel. In the screenshot, you can see the icon as packaged on the left
> -unreadable. You can see the 24x24 px icon I provided on the right - it is much
> more readable, the key label is larger, and the artwork is crisp because it was
> designed to snap properly within the pixel grid.

Actually this is an expected result for me.

I'd like to ask you also try language bar with GtkIconTheme.
I'm attaching the screenshot.
If you use GtkIconTheme, it would show the more ugly strings than 48x48.

As I explained in comment #24, ibus converts your 16x16 to 18x18 and then the string is not shown clearly. So I thought 48x48 to 18x18 looks better than 16x16 to 18x18.
The scalable svg format also doesn't help this problem.

Unfortunately your icon doesn't shows the string "A ち" clearly in 16x16.
So I would think this request is to show larger string "A ち" in each size.

Comment 31 Máirín Duffy 2009-12-02 14:40:56 UTC
Hi Fujiwara-san,

Why is ibus using the 16x16 version? Can you show me a screenshot of where it appears? For display in the GNOME panel, it should use 24x24, not 16x16.

The screenshot you attached appears to be showing the 48x48 icon scaled down, not the 16x16 nor the 24x24 icon. I can tell because of the size ratio between the characters and keyboard key.

Comment 32 fujiwara 2009-12-03 05:23:11 UTC
Created attachment 375673 [details]
icon test case#2 with the gtk-icon-theme dir.

(In reply to comment #31)
> Why is ibus using the 16x16 version? Can you show me a screenshot of where it
> appears? For display in the GNOME panel, it should use 24x24, not 16x16.

Because I think 16x16 icon suits to the language bar size.
I attached your original icon. You could understand your 18x18 looks ugly.

I'm not sure why it should use 24x24. It depends on the size of the widget frame.

Currently I'm also about to show the icon on the title of GTK dialog box.
The title frame of GTK window or dialog is managed by metacity on GNOME and the icon size is also too small and the result is almost same.
When I use my 48x48 icon directly, it looks better shown.

I guess another idea might be prepare 18x18, 14x14 icons as I don't test it.

> 
> The screenshot you attached appears to be showing the 48x48 icon scaled down,
> not the 16x16 nor the 24x24 icon. I can tell because of the size ratio between
> the characters and keyboard key.  

Yes attachment #375260 [details] is scaled down but looks better shown than this attachment for me.

Comment 33 Máirín Duffy 2009-12-03 14:30:37 UTC
Created attachment 375791 [details]
18x18 version of the icon

Hi Fujiwara-san,

Can you try this 18x18 icon and see if it looks okay in the language bar?

Metacity / the titlebar in GNOME is going to need the 16x16 version though.

24x24 is the size required for the GNOME panel so that is why a 24x24 icon is needed. It seems the language bar icon is smaller than the icon needed for the GNOME panel.

Which size version of the icon are you using for metacity? Can I see a screenshot?

Why do you need a 14x14 icon? What would that be for?

Comment 34 fujiwara 2009-12-03 14:47:47 UTC
(In reply to comment #33)
> Created an attachment (id=375791) [details]

Great your icon. Please let me reply this next week.

Comment 35 fujiwara 2009-12-07 07:30:44 UTC
Created attachment 376598 [details]
icon test case with 18x18 icon

I tested 18x18 icon and the result is attached.

It seems your attachment #375185 [details] doesn't install scalable icon svg.

When I installed all png sizes and svg icons into GtkIconTheme dir, GtkStatusIcon uses the scalable icon.

Personally I think scaled 24x24 would be better than using GtkIconTheme dir.

> 24x24 is the size required for the GNOME panel so that is why a 24x24 icon is needed. It seems the language bar icon is smaller than the icon needed for the GNOME panel.

I guess you don't install the scalable icon.

> Which size version of the icon are you using for metacity? Can I see a
screenshot?

My test result is 16x16 and the quality is almost same with this attachment.

Then my suggestion is 24x24 only at present.
If you'd like to try, the "Anthy" string uses the font "Nimbus Sans L Italic" with RGB color 0x555555.

Comment 36 fujiwara 2009-12-11 07:23:42 UTC
(In reply to comment #33)
Comment #33 From  Máirín Duffy (duffy@redhat.com)  2009-12-03 09:30:37 EDT
> Created an attachment (id=375791) [details]

Can you provide a raw key image which doesn't print any chars so that other people try to edit the icons?

If there is no comment, I'd like to close this bug.

Comment 37 Bug Zapper 2010-03-15 12:48:21 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 38 fujiwara 2010-04-02 09:24:37 UTC
Created attachment 404162 [details]
New icon for ibus-anthy

Since I didn't get the original icon without the printed string, I created the new icon from scratch.

This can show the "A ち" string with bigger size.
I'll close this bug for rawhide.

Comment 40 Fedora Update System 2010-04-05 04:03:38 UTC
ibus-anthy-1.2.0.20100313-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ibus-anthy-1.2.0.20100313-2.fc13

Comment 41 Fedora Update System 2010-04-06 19:56:35 UTC
ibus-anthy-1.2.0.20100313-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-anthy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ibus-anthy-1.2.0.20100313-2.fc13

Comment 42 Jens Petersen 2010-04-07 15:41:56 UTC
Well the new icon looks clearer than the previous version:
though I still think it is a bit too complicated...

Comment 43 fujiwara 2010-04-07 15:51:49 UTC
OK, I'll integrate the icon in F13.

Comment 44 Máirín Duffy 2010-04-07 17:19:46 UTC
Hi Fujiwara-san, this still looks problematic to me. 

Regarding your request in comment 36, I had provided the SVG source for the icons I did that can be edited in Inkscape so you could have a blank key if you need it:

http://duffy.fedorapeople.org/icons/Anthy/scalable/

However, I'm pretty confused right now. I don't understand why 'Anthy' text has been added to the icon or where that came from. This defeats the point of having an icon, doesn't it? Generally it is a very bad practice to put words in icons because they are meant to be symbols. Text requires translation which can't be done for an icon graphic. That's why we came up with the 'A ち' symbology.

attachment 376598 [details] isn't using the 18x18 icon I provided. You can see the 18x18 icon I provided in comment 33, it is attachment 375791 [details]. Could we use the icons without the superimposed 'Anthy' text on top of them? It looks unprofessional and hard-to-read otherwise.

Cheers,
~m

Comment 45 fujiwara 2010-04-08 01:02:18 UTC
(In reply to comment #44)
> http://duffy.fedorapeople.org/icons/Anthy/scalable/

This doesn't help my problem.
I asked the icon which doesn't have the printed text 'A ち'.
Even though it's svg format, the icon is not a layered icon so I cannot delete the text in the icon.

> However, I'm pretty confused right now. I don't understand why 'Anthy' text has
> been added to the icon or where that came from. This defeats the point of
> having an icon, doesn't it? Generally it is a very bad practice to put words in

Because the icon Japanese input method is not Anthy only.

> icons because they are meant to be symbols. Text requires translation which
> can't be done for an icon graphic. That's why we came up with the 'A ち'
> symbology.

If you're talking about translation, I think it's not this case because I think 'Anthy' is a product name and it's better to keep the original English.
I expected 'A ち' is the symbol for a Japanese engine but not for 'Anthy'.
If the word is missed, I think users might not know which is the Anthy icon and I would like to push the icon which expresses the default engine for Japanese. My suggestion is, Ibus Anthy engine uses this icon and M17N Anthy uses 'あ' + 'Anthy' icon.
I'm interested if you have any concerns except for the translations.

Anyway it might be a little delayed reply.

Comment 46 fujiwara 2010-04-08 01:25:12 UTC
(In reply to comment #45)
> (In reply to comment #44)
> > http://duffy.fedorapeople.org/icons/Anthy/scalable/
> 
> This doesn't help my problem.
> I asked the icon which doesn't have the printed text 'A ち'.
> Even though it's svg format, the icon is not a layered icon so I cannot delete
> the text in the icon.

BTW, You don't have to provide the icon because I created the icon from the scratch which support the layers with gimp while I spent much time last week and this version can show the text with larger size.

Comment 47 Fedora Update System 2010-04-09 04:07:48 UTC
ibus-anthy-1.2.0.20100313-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.