Bug 521068 - GFS2 filesystem inconsistent after xfstests test suite run
Summary: GFS2 filesystem inconsistent after xfstests test suite run
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Robert Peterson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-03 12:48 UTC by Jaroslav Barton
Modified: 2009-10-14 20:30 UTC (History)
4 users (show)

Fixed In Version: cluster-3.0.3-1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-14 20:30:59 UTC


Attachments (Terms of Use)
Full test 070 output (8.72 KB, text/plain)
2009-09-03 12:49 UTC, Jaroslav Barton
no flags Details
Proposed patch (530 bytes, patch)
2009-09-03 19:52 UTC, Robert Peterson
no flags Details | Diff

Description Jaroslav Barton 2009-09-03 12:48:51 UTC
Description of problem:
GFS filesystem is inconsistent after xfstests test suite run, caused by test 070.

Version-Release number of selected component (if applicable):
- Linux version 2.6.31-0.32.rc7.fc11.x86_64 (jbarton@loki.usersys.redhat.com) (gcc version 4.4.1 20090725 (Red Hat 4.4.1-2) (GCC) ) #1 SMP Thu Aug 27 13:01:43 CEST 2009
- gfs2_mkfs 3.0.2 (built Aug 24 2009 08:27:19)
- GFS2 fsck 3.0.2 (built Aug 24 2009 08:27:15)
- xfstest git commit dfdb145fbc8ab6d276b67615617e3951be289258


Steps to Reproduce:
1. mkfs.gfs2 /dev/mapper/vg_loki-test2 -p lock_nolock
2. mount /dev/mapper/vg_loki-test2 /mnt/test2
3. ltp/fsstress \
     -d /mnt/test2/fsstress \
     -f allocsp=0 \
     -f freesp=0 \
     -f bulkstat=0 \
     -f bulkstat1=0 \
     -f resvsp=0 \
     -f unresvsp=0 \
     -f attr_set=100 \
     -f attr_remove=100 \
     -S -p 1 -n 1000
4. umount /mnt/test2
5. fsck.gfs2 /dev/mapper/vg_loki-test2
  
Actual results:
filesystem is inconsistent


Expected results:
filesystem is fully consistent

Comment 1 Jaroslav Barton 2009-09-03 12:49:34 UTC
Created attachment 359676 [details]
Full test 070 output

Comment 2 Robert Peterson 2009-09-03 19:50:51 UTC
I recreated this problem on recent code obtained from the git
repository.  It seems to be a problem with the extended attribute
block accounting in fsck.gfs2.  The problem was recently introduced
(sadly, by me) but was _not_ shipped with 5.4.  I'm testing a patch
now to fix the problem.

Comment 3 Robert Peterson 2009-09-03 19:52:11 UTC
Created attachment 359733 [details]
Proposed patch

This is the patch I'm testing.  Unfortunately, this affects a
delicate area of fsck.gfs2 so I'll have to run the patch through
my entire collection of gfs2 metadata before I can call it good.

Comment 4 Jaroslav Barton 2009-09-04 07:15:26 UTC
With this patch it seems work for me.

Comment 5 Robert Peterson 2009-09-04 21:13:17 UTC
I pushed the patch to the master branch of the gfs2-utils git
tree and the STABLE3 branch of the cluster git tree.  I also
crosswrote the fix to GFS and pushed that patch to the same
branches.  I still need to fix up the STABLE2 and RHEL55 branches.

Comment 6 Robert Peterson 2009-09-08 19:48:14 UTC
The patches for both GFS and GFS2 have been pushed to the
RHEL55 and STABLE2 branches in git.  We just need Fedora builds
now for GFS and GFS2 from STABLE3.

Comment 7 Robert Peterson 2009-10-14 20:30:59 UTC
This fix is now in cluster-3.0.3-1.fc11.  Thanks, Fabio.
Closing this UPSTREAM.


Note You need to log in before you can comment on or make changes to this bug.