Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 521090 - Use COMMAND_MD5SUM="md5sum" in /etc/nxserver/node.conf (openssl md5 changed the output)
Summary: Use COMMAND_MD5SUM="md5sum" in /etc/nxserver/node.conf (openssl md5 changed t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freenx-server
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 539308 541016 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-03 15:20 UTC by Dawid Zamirski
Modified: 2009-12-18 04:35 UTC (History)
10 users (show)

Fixed In Version: 0.7.3-17.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 18:12:46 UTC
Type: ---


Attachments (Terms of Use)
nxserver.log (2.96 KB, text/plain)
2009-09-16 14:49 UTC, Dawid Zamirski
no flags Details
session.log (2.43 KB, text/plain)
2009-09-16 14:53 UTC, Dawid Zamirski
no flags Details

Description Dawid Zamirski 2009-09-03 15:20:30 UTC
Description of problem:
After yum updating my Rawhide Fedora on 09/1/09 the remote nx stopped working. The yum updated the nx package and after that I can no longer use remote desktop via nx.

Version-Release number of selected component (if applicable):
nx-3.3.0-38.fc12.x86_64 (I just took the latest one from koji in hope fix is already there - the one yum pulled from repo was -37)

How reproducible:
Always

Steps to Reproduce:
1. yum update to latest rawhide
2. Try to login using latest NoMachine client.
3.
  
Actual results:
NX> 203 NXSSH running with pid: 3084
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: xxx.xxx.xxx.xxx (censored :-)) on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 3.2.0-74-SVN OS (GPL, using backend: 3.3.0)
NX> 105 hello NXCLIENT - Version 3.2.0
NX> 134 Accepted protocol: 3.2.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: maners
NX> 102 Password: 
NX> 103 Welcome to: phenom.localdomain user: maners
NX> 105 listsession --user="maners" --status="suspended,running" --geometry="1680x1050x32+render+fullscreen" --type="unix-gnome"
NX> 127 Sessions list of user 'maners' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: maners
NX> 105 startsession  --link="wan" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="Fedora" --type="unix-gnome" --geometry="1680x1020" --fullscreen="1" --client="winnt" --keyboard="pc102/en_US" --screeninfo="1680x1050x32+render+fullscreen" 

cat: /var/lib/nxserver/db/running/sessionId{(STDIN)}: No such file or directory
NX> 280 Exiting on signal: 15


Additional info:
The nx was working find before yum update on 9/1/2009. I can't downgrade to earlier version to see if this nx package is an issue as it fails on libcrypto.so.8 dependency - the new nx package change log stated that it was rebuild against new openssl:

nx-3.3.0-37.fc12
----------------
* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.3.0-37
- rebuilt with new openssl

* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.0-36
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

Comment 1 Axel Thimm 2009-09-11 11:14:34 UTC
You can find old builds under

http://koji.fedoraproject.org/koji/packageinfo?packageID=2661

but since openssl changed probably only >= 3.3.0-37 will install at all.

Comment 2 Dawid Zamirski 2009-09-16 14:49:59 UTC
Created attachment 361291 [details]
nxserver.log

This is the nxserver log generated after setting the log level to 6 in /etc/nxxserver/node.conf

Comment 3 Dawid Zamirski 2009-09-16 14:53:06 UTC
Created attachment 361295 [details]
session.log

This is the contents of the session log generated on the server-side in my /home/maners/.nx direcrtory on the server.

Comment 4 Dawid Zamirski 2009-09-16 14:55:05 UTC
Hi Axel

Since I can't downgrade to an earlier version due to dependency issues, I have made some more tests with logging enabled and the files are attached above. Also I have set SELinux in permissive mode to make sure it's not causing the issue.

Comment 5 Manny 2009-10-18 07:26:41 UTC
I have the exact same problem. After a lot of debugging it seems that the problem arises from the md5sum command used by NX. In NX the default command for md5sum calculation is "openssl md5". Due to the switch of the openssl library used between fedora 11 and fedora 12, there was consequently a switch in the output of md5 hashes that are piped into openssl.

In Fedora 11:
$ echo 304565358 | openssl md5
c9ec5100d138ed2e8a039507150b5fb7

In Fedora 12:
echo 304565358 | openssl md5
(stdin)= c9ec5100d138ed2e8a039507150b5fb7

This output gets parsed incorrectly in NX and causes the session to never start.

As a work around to this, in the /etc/nxserver/node.conf file one can add the following line to the end of the file: 

COMMAND_MD5SUM="md5sum"

This will override the default COMMAND_MD5SUM="openssl md5" and it allowed the session to start normally.

Comment 6 Dawid Zamirski 2009-10-23 18:48:56 UTC
Setting COMMAND_MD5SUM="md5sum" in /etc/nxserver/node.conf solved the problem for me as well. Thanks Manny for the tip.

Comment 7 Rahul Sundaram 2009-11-07 20:57:14 UTC
Axel,

Can you add the workaround or shall I do it for you?

Comment 8 Bug Zapper 2009-11-16 11:57:35 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 9 Axel Thimm 2009-11-23 11:48:58 UTC
*** Bug 539308 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2009-11-23 12:12:16 UTC
freenx-server-0.7.3-17.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/freenx-server-0.7.3-17.fc12

Comment 11 Fedora Update System 2009-11-23 12:12:39 UTC
freenx-server-0.7.3-17.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/freenx-server-0.7.3-17.fc11

Comment 12 Fedora Update System 2009-11-23 12:13:01 UTC
freenx-server-0.7.3-17.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/freenx-server-0.7.3-17.fc10

Comment 13 Fedora Update System 2009-11-25 14:54:53 UTC
freenx-server-0.7.3-17.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12032

Comment 14 Fedora Update System 2009-11-25 14:59:46 UTC
freenx-server-0.7.3-17.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-12041

Comment 15 Fedora Update System 2009-11-25 15:17:49 UTC
freenx-server-0.7.3-17.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12123

Comment 16 Dawid Zamirski 2009-11-25 15:29:23 UTC
It is fixed in freenx-server-0.7.3-17.fc12 for me.

Comment 17 Mark Flitter 2009-11-30 16:54:40 UTC
+1 confirm fixed for me with freenx-server-0.7.3-17.fc12

Comment 18 kirill 2009-11-30 17:50:49 UTC
+1 confirm fixed for me with freenx-server-0.7.3-17.fc12  

and need updated /etc/nxserver/node.conf

# The tool to generate md5sums with
#COMMAND_MD5SUM="openssl md5

:-)

Comment 19 Dawid Zamirski 2009-12-01 18:12:46 UTC
Since it's confirmed as fixed, I think it's ok to close with CURRENTRELEASE.

Comment 20 Axel Thimm 2009-12-14 20:38:14 UTC
*** Bug 541016 has been marked as a duplicate of this bug. ***

Comment 21 Matt Castelein 2009-12-14 21:07:08 UTC
OK, so I missed this possibly being a duplicate, sorry.. But after installing this package from updates-testing and making the md5sum change to node.conf, I also needed to delete my user from NX and re-create it.  Now I can log in.

Comment 22 Reilly Hall 2009-12-15 15:00:32 UTC
I gave it a thumbs up after testing on a clean box this morning, +1 here too :)

Comment 23 Fedora Update System 2009-12-18 04:20:14 UTC
freenx-server-0.7.3-17.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2009-12-18 04:34:42 UTC
freenx-server-0.7.3-17.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.