Bug 521095 - initscripts for samba daemons are not LSB compliant (service status when program is dead and /var/lock lock file exists)
Summary: initscripts for samba daemons are not LSB compliant (service status when prog...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 12
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Simo Sorce
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: InitScriptsProject 584676 584678
TreeView+ depends on / blocked
 
Reported: 2009-09-03 15:37 UTC by Ales Zelinka
Modified: 2010-07-06 17:19 UTC (History)
3 users (show)

Fixed In Version: samba-3.4.8-59.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 530954 584676 584678 (view as bug list)
Environment:
Last Closed: 2010-07-06 17:19:03 UTC


Attachments (Terms of Use)

Description Ales Zelinka 2009-09-03 15:37:47 UTC
Description of problem:
According to https://fedoraproject.org/wiki/FCNewInit/Initscripts "service XYZ status" should return 2 when program is dead and /var/lock lock file exists.

Samba services ruturn 3 (which indicate stopped program with lock/pid cleaned up)

Version-Release number of selected component (if applicable):
samba-3.4.0-0.43.fc12.1.x86_64
samba-winbind-3.4.0-0.43.fc12.1.x86_64


How reproducible:
always

Steps to Reproduce:
1.service smb start
2.killall smbd
3.service smb status ; echo $?
  
Actual results:
smbd is stopped
3


Expected results:
smbd dead but subsys locked
2

Additional info:
The correct exit code + error messages should be returned by "status" function from /etc/init.d/functions. But it is not used, probably because of the inconsistency between process names (smbd) and service name (smb) that the "status" function can't handle.

Comment 1 Ales Zelinka 2009-10-26 09:40:45 UTC
Correction -  this is the right initscript guideline page: https://fedoraproject.org/wiki/Packaging/SysVInitScript. The bug is there according to this page too (and in the other samba's services initscripts too).

Comment 2 Bug Zapper 2009-11-16 11:57:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Fedora Update System 2010-05-12 21:50:48 UTC
samba-3.4.8-59.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/samba-3.4.8-59.fc12

Comment 5 Fedora Update System 2010-05-13 19:24:16 UTC
samba-3.4.8-59.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update samba'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/samba-3.4.8-59.fc12

Comment 6 Fedora Update System 2010-07-06 17:18:58 UTC
samba-3.4.8-59.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.