Bug 521101 - SHA256: Taskomatic support for multiple checksums per package
Summary: SHA256: Taskomatic support for multiple checksums per package
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other
Version: RHN Stable
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Sebastian Skracic
QA Contact: Red Hat Network Quality Assurance
URL:
Whiteboard: US55
: 477064 (view as bug list)
Depends On:
Blocks: 477043 428922 519193 rhn-sprint30
TreeView+ depends on / blocked
 
Reported: 2009-09-03 16:27 UTC by Sebastian Skracic
Modified: 2013-01-10 10:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-18 12:49:38 UTC


Attachments (Terms of Use)

Description Sebastian Skracic 2009-09-03 16:27:35 UTC
Taskomatic repo metadata generation task must deal properly with multiple checksums per package.  In case a single package has more than one checksum available, select appropriate checksum according to the channel preference.

Comment 1 Sebastian Skracic 2009-09-03 16:29:42 UTC
Initial support implemented in 5f4cf67966cea7d6232549fabe05741eecf921bf.

Comment 2 Sebastian Skracic 2009-09-07 14:33:16 UTC
The code is on DEV.

Comment 3 James Bowes 2009-09-10 16:31:21 UTC
*** Bug 477064 has been marked as a duplicate of this bug. ***

Comment 4 James Bowes 2009-09-14 19:13:55 UTC
Verified for existing channels with md5


Note You need to log in before you can comment on or make changes to this bug.