Bug 521106 - change to df behavior in 5.4 breaks running df on a device mapper object for non-root
Summary: change to df behavior in 5.4 breaks running df on a device mapper object for ...
Keywords:
Status: CLOSED DUPLICATE of bug 520630
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: coreutils
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-03 17:06 UTC by Tim Mooney
Modified: 2009-09-03 18:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-03 18:47:09 UTC


Attachments (Terms of Use)

Description Tim Mooney 2009-09-03 17:06:22 UTC
Description of problem:

The fix for this problem:

    https://bugzilla.redhat.com/show_bug.cgi?id=497830

introduced a new problem: it's now not possible for a non-root user to use df on a device mapper object.

Version-Release number of selected component (if applicable):

df (GNU coreutils) 5.97

How reproducible:

Always.

Steps to Reproduce:
1. On a RHEL 5.4 box with this version of coreutils installed and at least one
   fs managed by the device mapper, execute:

   df -k /dev/mapper/your-dm-object-here

  
Actual results:

$df -k /dev/mapper/localvg1-home
df: `/dev/mapper/localvg1-home': Permission denied


Expected results:

Here's what happens on a RHEL 4.8 box with the older coreutils:

$df -k /dev/mapper/localvg1-home
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/localvg1-home
                       1015496    391291    582262  41% /home


Additional info:

Comment 1 Ondrej Vasik 2009-09-03 18:47:09 UTC
Thanks for report, however duplicate of #520630... closing...

*** This bug has been marked as a duplicate of bug 520630 ***


Note You need to log in before you can comment on or make changes to this bug.