Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 521115 - system-config-services dies
Summary: system-config-services dies
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-services
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-03 18:05 UTC by Joachim Backes
Modified: 2009-12-01 18:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 18:22:02 UTC
Type: ---


Attachments (Terms of Use)

Description Joachim Backes 2009-09-03 18:05:51 UTC
Description of problem:
/usr/bin/system-config-services dies:

Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 951, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 909, in __init__
    serviceherders = self.serviceherders)
  File "/usr/bin/system-config-services", line 765, in __init__
    self.servicesList = GUIServicesList (xml = self.xml, serviceherders = serviceherders)
  File "/usr/bin/system-config-services", line 467, in __init__
    if herder.ready:
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 64, in ready
    return self.herder_interface.is_ready ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.


Version-Release number of selected component (if applicable):
system-config-services-0.99.38-1.fc12.noarch

How reproducible:
Each time when started

Steps to Reproduce:
1.sudo /usr/bin/system-config-services
2.
3.
  
Actual results:
see above

Expected results:
the services are configured

Additional info:All updates are applied!

Comment 1 Joachim Backes 2009-09-05 07:48:42 UTC
Still persists with system-config-services-0.99.39-1.fc12.noarch:

sudo system-config-services
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 950, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 908, in __init__
    serviceherders = self.serviceherders)
  File "/usr/bin/system-config-services", line 764, in __init__
    self.servicesList = GUIServicesList (xml = self.xml, serviceherders = serviceherders)
  File "/usr/bin/system-config-services", line 466, in __init__
    if herder.ready:
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 64, in ready
    return self.herder_interface.is_ready ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Comment 2 Joachim Backes 2009-09-16 08:50:46 UTC
Same appearance with system-config-services-0.99.40-1.fc12.noarch

Comment 3 Antal KICSI 2009-11-09 17:12:14 UTC
Same appearance with system-config-services-0.99.41-1.fc12

Smolt profile : 
http://www.smolts.org/client/show/pub_50c9b678-9c49-4072-b7a6-c5eb9a36c342  

Tested with desktop-i386-20091107.20.iso from

http://alt.fedoraproject.org/pub/alt/nightly-composes/

Comment 4 Antal KICSI 2009-11-14 21:07:53 UTC
With F12 RC4 running from LiveCD the system-config-services dies, but after I installed on the harddisk the problem disappeard and the program runs fine!

The installed version is system-config-services-0.99.41-1.fc12

Comment 5 Bug Zapper 2009-11-16 11:58:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Joachim Backes 2009-12-01 18:22:02 UTC
Seems to be solved: Cannot reproduce this bug in the F12 release
(with system-config-services-0.99.41-1.fc12.noarch)


Note You need to log in before you can comment on or make changes to this bug.