Bug 52112 - flash plugin and xmms fight for resources
flash plugin and xmms fight for resources
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-20 13:09 EDT by Florin Andrei
Modified: 2014-03-16 22:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-21 14:59:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2001-08-20 13:09:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19 i686; en-US; rv:0.9.1)
Gecko/20010608

Description of problem:
This problem stands for both Netscape4 and Mozilla.
If i have XMMS playing a song, and Netscape/Mozilla has the Flash plugin
installed, if i try to start my browser, it doesn't start, it just hangs (i
have to kill the process).
If XMMS is running but not playing anything, there's no problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Flash plugin
2.Start XMMS and make it play a song
3.Start Netscape/Mozilla
	

Actual Results:  The browser process is started, but no window appeared on
my desktop. 'ps ax' reveals the browser running.

Expected Results:  The browser should start normally

Additional info:

Looks like this problem happens no matter what sound architecture you're
using. I use ALSA (and an i815 embedded soundcard), but i've heard other
people having this problem too.
I also use Ximian Gnome 1.4 (maybe this info is useful).
Someone told me this workaround: start Netscape with "esddsp
--server=localhost netscape" but i didn't try it.
Comment 1 Bill Nottingham 2001-08-20 14:20:56 EDT
Which output plugin are you using?
Comment 2 Florin Andrei 2001-08-21 14:59:53 EDT
Heh, looks like you knew something... :-)
I was using the OSS plugin, which comes by default with my XMMS (i'm using
Ximian Gnome, if that makes a difference).
If i switch to esound plugin, the problem goes away.
Comment 3 Bill Nottingham 2002-01-24 01:38:48 EST
This is not something we can really solve, in that we can't fix how the flash
plugin plays sounds.

Note You need to log in before you can comment on or make changes to this bug.