Bug 521133 - firstboot miss the item "Add User" on rawhide
firstboot miss the item "Add User" on rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-09-03 15:19 EDT by Niels Haase
Modified: 2009-09-04 09:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 09:11:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output from firstboot (1.27 MB, text/plain)
2009-09-03 15:19 EDT, Niels Haase
no flags Details
loader.patch (1.01 KB, text/plain)
2009-09-03 15:50 EDT, James Laska
no flags Details

  None (edit)
Description Niels Haase 2009-09-03 15:19:33 EDT
Created attachment 359729 [details]
strace output from firstboot

Description of problem:
After install of rawhide (20090901) after the first reboot, firstboot show up but has only 3 steps to configure. Welcome, Licence and Smolt, but "Add User" is missing. Also boot with selinux=0 show the same error. There are now error messages on the tty related to the problem.

Version-Release number of selected component (if applicable):
firstboot-1.108-1.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install rawhide
2. start firstboot
3. see missing add user
  
Actual results:
Add User is missing

Expected results:
Add User should appear

Additional info:
"firstboot -d" output

firstboot DEBUG: X is already running, not using any frontend
firstboot DEBUG: Using GTK interface
firstboot DEBUG: Successfully loaded module smolt, adding
firstboot DEBUG: Successfully loaded module eula, adding
firstboot INFO: skipping module keyboard because it should not run in this mode
firstboot ERROR: Module language does not contain a class named moduleClass; skipping.
firstboot DEBUG: Successfully loaded module welcome, adding
Loading /lib/kbd/keymaps/i386/qwertz/de-latin1-nodeadkeys.map.gz
Comment 1 Chris Lumens 2009-09-03 15:41:03 EDT
This is a bug in system-config-users:

$ ipython
In [2]: sys.path.append("/usr/share/system-config-users")

In [3]: import userGroupCheck
ERROR: An unexpected error occurred while tokenizing input
The following traceback may be corrupted or invalid
The error message is: ('EOF in multi-line statement', (71, 0))

---------------------------------------------------------------------------
NameError                                 Traceback (most recent call last)

/home/clumens/src/firstboot/<ipython console> in <module>()

/usr/share/system-config-users/userGroupCheck.pyc in <module>()
     23 import string
     24 import libuser
---> 25 import messageDialog
     26 import gtk
     27 

/usr/share/system-config-users/messageDialog.pyc in <module>()
     24 
     25 import gtk
---> 26 import mainWindow
     27 
     28 def show_message_dialog(text):

/usr/share/system-config-users/mainWindow.pyc in <module>()
     96 
     97 
---> 98 gtk.glade.bindtextdomain(domain)
     99 if os.access("system-config-users.glade", os.F_OK):
    100     xml = gtk.glade.XML ("./system-config-users.glade", domain=domain)

NameError: name 'domain' is not defined
Comment 2 James Laska 2009-09-03 15:50:41 EDT
Created attachment 359732 [details]
loader.patch

The attached patch makes it so the failure to load the 'create_user' module is displayed to logging.error().  This yields the following output:

firstboot DEBUG: X is already running, not using any frontend
firstboot DEBUG: Using GTK interface
firstboot DEBUG: Successfully loaded module welcome, adding
firstboot DEBUG: Successfully loaded module smolt, adding
firstboot DEBUG: Successfully loaded module eula, adding
firstboot ERROR: Generic Error loading module create_user:
name 'domain' is not defined
firstboot DEBUG: Successfully loaded module date, adding
firstboot INFO: skipping module keyboard because it should not run in this mode
Loading /lib/kbd/keymaps/i386/qwerty/us.map.gz
firstboot WARNING: Unable to load pixmap /usr/share/firstboot/themes/default//system-config-date.png for module Date and Time.
Comment 3 James Laska 2009-09-03 16:00:51 EDT
Seems like the domain variable is uninitialized maybe?

# rpm -ql system-config-users | xargs grep "domain"
Binary file /usr/bin/system-config-users matches
/usr/share/system-config-users/mainWindow.py:gtk.glade.bindtextdomain(domain)
/usr/share/system-config-users/mainWindow.py:    xml = gtk.glade.XML ("./system-config-users.glade", domain=domain)
/usr/share/system-config-users/mainWindow.py:    xml = gtk.glade.XML ("/usr/share/system-config-users/system-config-users.glade", domain=domain)
Comment 4 Nils Philippsen 2009-09-04 06:21:53 EDT
please try system-config-users-1.2.90
Comment 5 James Laska 2009-09-04 07:58:09 EDT
Thanks Nils ... that solved the problem for me.  I now see user configuration on the firstboot menu.

Note You need to log in before you can comment on or make changes to this bug.