Bug 521156 - libgadu-1.9.0 is available
libgadu-1.9.0 is available
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libgadu (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2009-09-03 18:56 EDT by Upstream Release Monitoring
Modified: 2010-01-25 15:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-25 15:38:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2009-09-03 18:56:16 EDT
Latest upstream release: 1.9.0
Current version in Fedora Rawhide: 1.8.2
URL: http://toxygen.net/libgadu/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 1 Dominik 'Rathann' Mierzejewski 2009-09-13 15:50:38 EDT
Updated to 1.9.0-rc1 in rawhide.
Comment 2 Julian Sikorski 2009-11-19 20:16:39 EST
rc2 was released 3 days ago. While we're at it, is linking to openssl really necessary? Pidgin can't link to system libgadu as a result since this would cause GPL violation.
Since 0.6.5.2, kadu uses qca for encryption, so this is a non-issue here. I'm not sure about the other two deps, ekg2 and gg2. Both claim to be GPL, so this can be problematic as well. Adding FE-Legal.
Comment 3 Tom "spot" Callaway 2009-11-30 18:28:02 EST
Well, pidgin could add a link exception for SSL:

 * In addition, as a special exception, the copyright holders give
 * permission to link the code of portions of this program with the
 * OpenSSL library under certain conditions as described in each
 * individual source file, and distribute linked combinations
 * including the two.
 * You must obey the GNU General Public License in all respects
 * for all of the code used other than OpenSSL.  If you modify
 * file(s) with this exception, you may extend this exception to your
 * version of the file(s), but you are not obligated to do so.  If you
 * do not wish to do so, delete this exception statement from your
 * version.  If you delete this exception statement from all source
 * files in the program, then also delete it here.

Alternately, libgadu could use gnutls instead of openssl.
Comment 4 Dominik 'Rathann' Mierzejewski 2009-12-05 20:08:51 EST
Updated to 1.9.0-rc2 in rawhide, sent question about openssl upstream.
Comment 5 Dominik 'Rathann' Mierzejewski 2009-12-06 07:04:01 EST
Upstream says using gnutls is on TODO list, but that SSL isn't used in practice yet, so I just disabled it. This should fix any licence trouble.
Comment 6 Tom "spot" Callaway 2010-01-25 15:38:32 EST
Closing this one out, please be aware of the licensing issue if/when you decide to renable SSL support.

Note You need to log in before you can comment on or make changes to this bug.