This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 521170 - pcmanfm - okular interaction problem
pcmanfm - okular interaction problem
Status: CLOSED DUPLICATE of bug 519008
Product: Fedora
Classification: Fedora
Component: pcmanfm (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On: 519008
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-03 21:31 EDT by A. Mani
Modified: 2009-11-28 05:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-28 05:19:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen shot (86.17 KB, image/jpeg)
2009-09-05 21:11 EDT, A. Mani
no flags Details

  None (edit)
Description A. Mani 2009-09-03 21:31:05 EDT
Description of problem:

pdf files cannot be opened with okular in pcmanfm with mouse, but file opens in document viewer. Otherwise okular has no problem with the file. 


Version-Release number of selected component (if applicable):

pcmanfm 0.5.1

Fedora 11 x86-64 (updated)

How reproducible:
Try to open via context menu (right click)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 A. Mani 2009-09-03 21:45:05 EDT
gdb trace
_______________________________

Tried to open a pdf file in okular (got an error) and then in document viewer (ok).
Otherwise file opens in okular via konqueror
____________________________  

(gdb) bt                                                                                
#0  0x0000003d148d50b3 in *__GI___poll (fds=<value optimized out>,                      
    nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87     
#1  0x0000003d1703b05c in g_main_context_poll (n_fds=<value optimized out>,             
    fds=<value optimized out>, priority=<value optimized out>,                          
    timeout=<value optimized out>, context=<value optimized out>) at gmain.c:2768       
#2  g_main_context_iterate (n_fds=<value optimized out>, fds=<value optimized out>,     
    priority=<value optimized out>, timeout=<value optimized out>,
    context=<value optimized out>) at gmain.c:2450
#3  0x0000003d1703b6d5 in IA__g_main_loop_run (loop=0x957470) at gmain.c:2663
#4  0x0000003638b27d17 in IA__gtk_main () at gtkmain.c:1205
#5  0x000000000044ac95 in main (argc=1, argv=0x7fffffffdf98) at main.c:708
______________________________________
Comment 2 Mamoru TASAKA 2009-09-04 01:48:22 EDT
Well, I don't know what okular is.

- Would you tell me the procedure to reproduce the issue your are seeing
  in detail? (including what desktop environment you are using)
- Please write the component and EVR (Epoch-version-release) of the rpms
  which you think are related to this issue.
Comment 3 Mamoru TASAKA 2009-09-04 01:51:19 EDT
Also, your gdb backtrace does not seem to show where the crash
is occuring. Would you also try the following?
(gdb) where
and
(gdb) thread apply all bt
Comment 4 A. Mani 2009-09-04 20:43:30 EDT
I am using KDE

Okular is the document viewer in KDE

run pcmanfm from kde menu,

then try to open a pdf file by rightclicking on the file and selecting a viewer.

It seems there is a problem when trying to open with okular.


Version: pcmanfm-0.5.1-1.fc11.x86_64
Comment 5 Mamoru TASAKA 2009-09-05 15:21:28 EDT
Still I need more detailed information.

After you
- launch pcmanfm from KDE menu
- push right click on one pdf file in one directory, click it by right mouse
  button, (perhaps) choose "Open with...", then select "okular", then

* Would you see what issue you are seeing in detail?
  - What name of pdf file are you trying to open?
  - When you are trying to open the pdf file with okular from pcmanfn, 
    is pcmanfm or okular crashing (i.e. pcmanfm or okular exit
    abnormally)?
  - Or okular launches normally, pcmanfm does not crash. However okular
    cannot open the selected pdf file?
    In that case, do okular or pcmanfm show any messages?
  - If you see some messages on a popup window, or in a text file or
    so, would you tell me what exact message you are seeing?
   (If a popup window appears, taking a screenshot is useful)
  - Would you tell me the procedure how you got the gdb output
    you posted on comment 1? (and when you got that gdb output,
    was some application crashing?)
Comment 6 A. Mani 2009-09-05 21:11:18 EDT
Created attachment 359893 [details]
screen shot

The problem is due to the way pcmanfm communicates the filenames.

The file name of the file in the picture is "a guide to latex and electronic publishing.pdf". It opens perfectly in okular from konqueror or dolphin.

But when I rename the file to 'latexguidepublishing.pdf'... it opens correctly from pcmanfm.  

I checked it with .chm and .djvu files too
Comment 7 A. Mani 2009-09-05 21:26:18 EDT
No application crashed. The screen shot should be self-explanatory.

GDB part

#gdb pcmanfm
#run

(after trying to open a file unsuccessfully in okular and then successfully in document viewer)

ctrl-c

#bt

If I close the application directly, then I get no stack
Comment 8 Mamoru TASAKA 2009-09-06 00:04:16 EDT
Okay. Now I can reproduce what you see.

I think I can fix this issue on pcmanfm side, however anyway
okular (in kdegraphics) does a wrong behavior, which is the
same as bug 519008. For now I want to hear first how KDE people
think of this.
Comment 9 Mamoru TASAKA 2009-11-28 05:19:30 EST
Closing as it seems that this was fixed in kdebindings side.

*** This bug has been marked as a duplicate of bug 519008 ***

Note You need to log in before you can comment on or make changes to this bug.