Bug 521173 - xfsprogs is missing in RHEL-5.4
xfsprogs is missing in RHEL-5.4
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xfsprogs (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Eric Sandeen
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-04 00:01 EDT by Kirby Zhou
Modified: 2010-06-09 14:32 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 13:12:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kirby Zhou 2009-09-04 00:01:06 EDT
Description of problem:

From RHEL-5.4 release notes, I can see that below:

Support for the XFS file system has also been added to the kernel as a Technology Preview (BZ#470845).
Users of GFS2 that do not need high availability clustering are encouraged to look at migrating to other file systems like the ext3 or xfs offerings. 

But how can I do mkfs.xfs?

xfsprogs is missing in RHEL-5.4, xfsprogs-devel and xfsdump are missing too.
Comment 2 Subhendu Ghosh 2009-09-04 00:37:19 EDT
Sorry - the Release notes are being updated with correct status.

Full XFS support is not included in RHEL. We have done some kernel enablement but not complete support in the operating system. If you need XFS support, please contact your account team for future product support.
Comment 3 Kirby Zhou 2009-09-08 22:46:50 EDT
But, without mkfs.xfs from xfsprogs, how can I test the kernel xfs feature?
Comment 4 Ray Van Dolson 2009-09-09 17:58:32 EDT
My understanding from what was said during the Summit was that the XFS userspace tools are available from a special channel in RHN upon request (perhaps for extra $$?)
Comment 5 Kirby Zhou 2009-09-13 23:04:09 EDT
Anyone knows which channel contains the package?
Comment 6 Ric Wheeler 2009-09-14 07:36:50 EDT
Please refer to https://bugzilla.redhat.com/show_bug.cgi?id=521173#c2

XFS is supported as a layered product, so you need to contact your account team to get information about where that channel is and how to get access.
Comment 7 Brett Morrow 2009-09-17 14:50:51 EDT
Please considering including this in the base release for 32bit and 64bit.
Thank you.   (only thing keeping me having to use SUSE)
Comment 8 Mark D. Foster 2009-11-04 12:54:21 EST
To whom it may concern. You forgot to include xfsprogs and xfsdump packages which means XFS support in 5.4 is basically crippled, useless.

Put xfsprogs and xfsdump in the repository already.

Support XFS for real!

Signed, a paying customer.
Comment 9 Eric Sandeen 2009-11-04 12:58:17 EST
XFS is supported as a layered product, so you need to contact your support/ account team to get information about where that channel is and how to get access, for now.

Thanks,
-Eric
Comment 10 Brett Morrow 2009-11-04 13:09:10 EST
But I get different answers from different people.  I am told it is a layered product, but no one seems to be able to tell me that the product or channel is.  I was told by one that it is only available with the Advanced Server products and if I have that, the package will be there, but it is now.  I am still waiting on a correct response through here or through the ticket I opened through the support site some weeks ago.
Comment 11 Ray Van Dolson 2009-11-04 14:06:51 EST
You probably need to work through your Sales Rep for access to the channel (this is where support pointed us).

I haven't gone down this road yet so I don't know what your odds of success are.  My impression is they'll want a better use case than "just testing", and it might even help if you're an ISV.

Pure speculation on my part however.
Comment 12 Darin May 2009-11-13 04:02:10 EST
Uh...

I can yum install these components so why were these eliminated from the install media to prevent me from formatting the / partition as XFS?

Are you guys actively undermining the functionality to push people to other distributions?
Comment 13 Kirby Zhou 2009-12-21 09:19:04 EST
Maybe switch to CentOS-5 is a good choice for us who need XFS support.
Red Hat should rethink the strategy of 'the hidden channel of hidden packages'.

Nobody knows how to get the xfsprogs, noone knows which services contains the package.
Comment 14 Darin May 2009-12-21 13:45:33 EST
These aren't the packages you're looking for. Move along.

This is why we've already started migrating our RHEL licenses to Centos as they expire.

RHEL, another product destroyed by lack of vision.
Comment 15 Ric Wheeler 2009-12-21 13:57:57 EST
We have commented multiple times on how to get the xfs user space programs (https://bugzilla.redhat.com/show_bug.cgi?id=521173#c2, https://bugzilla.redhat.com/show_bug.cgi?id=521173#c9, etc).

Note that Red Hat employs several key XFS developers who did the work to enable XFS in the kernel and udpated the user space utilities. We certainly want to make this work for our users.

We do recognize how frustrating this process has been and are working to resolve this going forward. In the meantime, if you are a paying RHEL customer, talk to your account team for a supported version of the tools.
Comment 16 Brett Morrow 2009-12-21 14:30:34 EST
I wanted to add that for me this was a really frustrating issues and has been for some time.  I did post here about the need to include it, I tried contacting my account rep, tried opening a redhat support case when the above seem to get me nowhere, but I persisted as it was get this working or move more servers to another distribution (it has to be a supported distribution because of job and security concerns).  My case got escalated to people in the know and I got a phone call very quickly when it got in their hands.  We spent an hour on the phone about this and other issues.  I was able to get the files I needed then, a description of what was going on and how it took so long to get a response, and I am still getting followups of things will happen.  I went from VERY frustrated, upset, etc... to understanding and pleased with how they are progressing on things.  My main reason for writing this is to let you know that contacting you account team and working it will get results, that the problem is really being worked on and information is being disseminated to the support people, and that you should not have that hard of a time now getting the info.
Comment 17 Darin May 2009-12-21 16:57:36 EST
I'm glad you were able to move forward but the fact you had to is what's telling.

Customer's should not be the ones to ump through hoops to get basic functionality supported -- especially given the admission that XFS is a core feature.  

The issue is that this "core" feature fell off the table and RH didn't notice until customers had to waste their time.  That's the whole point of paying RH -- to avoid expending internal resources for OS support.  This obviates the support model: Might as well go with Centos.

So if this has been "addressed" when will we see XFS support in the installation media so that we can deploy XFS root partitions without having to bastardize the install process?
Comment 18 Ray Van Dolson 2009-12-21 17:16:51 EST
If you're referring to XFS as "core" technology in a general sense, then yes, maybe there is some basis for complaining as it has taken a long time for it to reach RHEL.

However, from a support standpoint, as I understand it, xfs is still a "Tech Preview" and thus not supported.  It's a little misleading to refer to something unsupported as a "core" feature...

Really folks, if you need this badly enough you can get access to the userspace utilities via your support channels.  If you don't, well, I bet you can easily wait until 5.5 for "official" support.
Comment 19 Eric Sandeen 2009-12-21 17:23:53 EST
Darin, as mentioned in comment #9, XFS is not at this time "basic functionality" for RHEL5.4.  It is currently a layered product, and you'll need to talk to your support folks about how to get access to that.

The feature did not fall off the table; there are currently some intentional restrictions (for lack of a better word) in place for xfs support, the most obvious of which is the fact that it is a layered product and not in the base OS.  As such, there is no installation support at this time.  If xfs root is important to you, let your support folks know so that it can be considered for future releases.  As a customer, you have the opportunity to let us know your needs and usecases.  While of course I cannot make promises about future products, it is this sort of feedback that helps guide product decisions.

Thanks,
-Eric
Comment 20 Darin May 2009-12-21 20:10:43 EST
The problem is that the simple perception of XFS support can be installed with a "yum install" post deployment from the RHEL servers is a de facto support of XFS on 5.4.

If you're going to make them available on the yum-mirrors post-install then place them on the install media.  By not doing so you're just wasting your customer's time and goodwill.

If they aren't supported then don't make them generally available.
Comment 21 Ric Wheeler 2009-12-22 07:57:13 EST
Hi Darin,

As we stated earlier in this BZ, XFS is fully supported in RHEL5.4 but only as a limited availability, layered product. The utilities are not on the install  media or on the normal 5.4 update channel. This is not a bug or an accidental omission (which is why this BZ got closed months back).

The kernel modules are built into 5.4, the supported user space from us can be obtained by talking to your account team and getting the layered product. As a new offering from red hat, we hope to do a limited roll out of supported xfs in 5.4 but will be revisiting how this is done going forward.

Development (us) and our product management team are always open to feedback about use cases. If you are a red hat customer, please pass your feedback (positive or negative) about xfs and how it is distributed to your account team.

Sorry for the confusion.
Comment 22 Mark D. Foster 2009-12-22 12:19:51 EST
(In reply to comment #21)
> The kernel modules are built into 5.4, the supported user space from us can be
> obtained by talking to your account team and getting the layered product. As a
> new offering from red hat, we hope to do a limited roll out of supported xfs in
> 5.4 but will be revisiting how this is done going forward.
You mean 5.5?
Comment 23 Kirby Zhou 2010-05-24 13:09:48 EDT
Will it be supported as 'core feature' in RHEL-5.6?
Comment 24 Ric Wheeler 2010-05-24 13:12:14 EDT
It is a layered product in RHEL5.6 as well.
Comment 25 Peter W Duffy 2010-06-09 12:30:38 EDT
Could someone please explain what is meant by "layered product" in the context of this discussion?
Comment 26 Ric Wheeler 2010-06-09 14:32:40 EDT
Layered products are things not included by default in the base RHEL package.

GFS2 support for example or RHEL cluster support are both examples...

Hope this helps,

Ric

Note You need to log in before you can comment on or make changes to this bug.