Bug 521233 - /sbin/service provides wrong information as non-root user
Summary: /sbin/service provides wrong information as non-root user
Keywords:
Status: CLOSED DUPLICATE of bug 495780
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 11
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-04 13:11 UTC by G.Wolfe Woodbury
Modified: 2009-09-08 19:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-07 12:52:33 UTC


Attachments (Terms of Use)

Description G.Wolfe Woodbury 2009-09-04 13:11:14 UTC
Description of problem:
 using /sbin/service as non-root user (e.g. service httpd status) reports
"subsystem locked but httpd dead" when, in fact, the sub-system is alive and well.


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install F11, make users, etc.
2. configure and start httpd
3. as non-root user type "/sbin/service httpd status"
  
Actual results:
"Subsystem locked but httpd dead."

Expected results:
report of httpd status that is correct (or that you don't have permission to read the pid files.)

Additional info:
There has been some discussion on the fedora-test-list about this.

Comment 1 Bill Nottingham 2009-09-04 16:48:31 UTC
/sbin/service has no control over the output; it's entirely dependent on what /etc/init.d/httpd does.

Comment 2 Joe Orton 2009-09-07 12:52:33 UTC

*** This bug has been marked as a duplicate of bug 495780 ***


Note You need to log in before you can comment on or make changes to this bug.