Bug 521251 - Can't add software to F12 Alpha
Can't add software to F12 Alpha
Status: CLOSED DUPLICATE of bug 520232
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-04 10:16 EDT by Russell Doty
Modified: 2014-01-21 18:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 10:29:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russell Doty 2009-09-04 10:16:36 EDT
Description of problem:

Attempting to add new fails with "an internal system error has occurred".


Version-Release number of selected component (if applicable): F12 X86-64 Alpha


How reproducible:

Every time

Steps to Reproduce:
1. Select "Add/Remove Software"
2. Search for a package or list all packages
3.
  
Actual results:

Error - "an internal system error has occurred"

Expected results:

Allow selection and installation of packages.

Additional info:

Same or similar error occurs when attempting to update the system.


Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 358, in _do_search
    for (pkg, inst) in res:
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1903, in searchGenerator
    for sack in self.pkgSack.sacks.values():
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 702, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 538, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 277, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 164, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 222, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1220, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1384, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1376, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1366, in _loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1349, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1195, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 976, in _getFileRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 754, in _getFile
    result = self.mediafunc(local = local, checkfunc = checkfunc, relative = relative, text = text, copy_local = copy_local, url = url, mediaid = self.mediaid, name = self.name, discnum = discnum, range = (start, end))
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2863, in MediaGrabber
    manager = MediaManager()
  File "/usr/share/PackageKit/helpers/yum/yumMediaManager.py", line 101, in __init__
    raise NotImplemented
TypeError: exceptions must be classes or instances, not NotImplementedType
Comment 1 seth vidal 2009-09-04 10:29:38 EDT

*** This bug has been marked as a duplicate of bug 520232 ***

Note You need to log in before you can comment on or make changes to this bug.