Bug 521324 - cil.mli is missing from ocaml-cil-devel
Summary: cil.mli is missing from ocaml-cil-devel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ocaml-cil
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-04 19:03 UTC by Jerry James
Modified: 2009-10-23 15:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-23 08:28:59 UTC


Attachments (Terms of Use)

Description Jerry James 2009-09-04 19:03:50 UTC
Description of problem:
The files cil.ml and cil.mli should be in the ocaml-cil-devel package, but are not.

Version-Release number of selected component (if applicable):
ocaml-cil-devel-1.3.7-2.fc12.x86_64

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.
  
Actual results:
N/A

Expected results:
N/A

Additional info:

Comment 1 Jerry James 2009-10-22 22:03:47 UTC
I took another look at this today, because I finally got my CIL-consuming app working on F-12 and it would be nice to have it buildable on F-11.  I noticed that a number of files are byte-compiled only; there is no native version.  Invoking:

  make RELEASE=1

fixes that.  But that didn't solve the problem of the missing cil.mli.  It turns out that NONE of the *.mli files in src are copied over to obj/$archos by the build rules.  It should be sufficient to change the ocamlfind invocation in %install to this:

  ocamlfind install cil META obj/$archos/*.{ml,mli,cmi,cmo,cmx,cma,cmxa,o,a} src/*.mli

Comment 2 Richard W.M. Jones 2009-10-23 08:19:26 UTC
For some reason I didn't see this bug before now.  I'll
try the fixes you suggest now.

Comment 3 Richard W.M. Jones 2009-10-23 08:28:59 UTC
I made the suggested changes in the new F13 build here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1764205

Comment 4 Jerry James 2009-10-23 15:27:01 UTC
I seem to be suffering from some kind of version hysteria.  I see that I reported this bug against Rawhide and listed an f12 RPM in the version (before the F-13 split), but I'm not actually seeing the problem on F-12 currently.  I AM seeing it on F-11, hence the remark about F-11 in comment 1.

I also see that the version of CIL in F-11 is 1.3.6, so maybe upstream did something to address this issue in 1.3.7.


Note You need to log in before you can comment on or make changes to this bug.