Bug 521347 - rhn-ssl-cert-check is failing on 5.2 and earlier Satellites.
Summary: rhn-ssl-cert-check is failing on 5.2 and earlier Satellites.
Keywords:
Status: CLOSED DUPLICATE of bug 524053
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 530
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-04 22:33 UTC by Brandon Perkins
Modified: 2010-01-30 03:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-29 03:17:52 UTC


Attachments (Terms of Use)

Description Brandon Perkins 2009-09-04 22:33:01 UTC
Description of problem:
rhn-ssl-cert-check is failing on 5.2 and earlier Satellites.

Version-Release number of selected component (if applicable):
spacewalk-ssl-cert-check-1.7-1.el4sat

How reproducible:
Always.

Steps to Reproduce:
0. Install 5.2 Satellite.
1. Subscribe Satellite system to rhn-tools channel.
2. # grep traceback_mail  /etc/rhn/rhn.conf and make sure its something valid like: traceback_mail = bperkins@redhat.com
3. # /etc/cron.daily/rhn-ssl-cert-check (should return nothing)
4. up2date or yum spacewalk-ssl-cert-check
5. # /etc/cron.daily/rhn-ssl-cert-check 
  
Actual results:
Unable to read the admin e-mail address in /etc/rhn/rhn.conf

To disable monitoring, add CHECK=no in /etc/sysconfig/rhn/rhn-ssl-cert-check
Otherwise, you will have to add a valid email address to receive
expiration notifications, either in /etc/rhn/rhn.conf (traceback_mail)
or set ADMIN in /etc/sysconfig/rhn/rhn-ssl-cert-check


Expected results:
Should continue to check but return nothing as traceback_mail is in fact set in /etc/rhn/rhn.conf

Additional info:
I don't *believe* we have a rule against being subscribed to the rhn-tools channel.  If we do have that documented somewhere, then please add that pointer here if the bug is closed as notabug.  However, all my Satellites get subscribed to the rhn-tools channel when I install them, and all my old ones started having this error.

Comment 1 Clifford Perry 2009-10-29 03:17:52 UTC

*** This bug has been marked as a duplicate of bug 524053 ***


Note You need to log in before you can comment on or make changes to this bug.