Bug 521350 - X11 crashes with intel driver after update to 5.4
Summary: X11 crashes with intel driver after update to 5.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810
Version: 5.4
Hardware: All
OS: Linux
high
urgent
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
: 524242 (view as bug list)
Depends On:
Blocks: 567535
TreeView+ depends on / blocked
 
Reported: 2009-09-04 23:51 UTC by Steve Cleveland
Modified: 2018-10-27 16:03 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, there was an issue in the CRT detect code in the driver. Consequently, after updating the xorg-x11-drv-i810 package, the X server may have failed to boot, returning the error message: Caught signal 11. Server aborting With this update, this issue has been resolved.
Clone Of:
Environment:
Last Closed: 2010-03-30 08:35:04 UTC


Attachments (Terms of Use)
Xorg log file (19.82 KB, text/plain)
2009-09-04 23:51 UTC, Steve Cleveland
no flags Details
xorg.conf file (567 bytes, text/plain)
2009-09-05 00:03 UTC, Steve Cleveland
no flags Details
Proposed patch (932 bytes, patch)
2009-09-16 16:41 UTC, Olivier Fourdan
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0262 normal SHIPPED_LIVE xorg-x11-drv-i810 bug fix and enhancement update 2010-03-29 12:52:57 UTC

Description Steve Cleveland 2009-09-04 23:51:11 UTC
Created attachment 359851 [details]
Xorg log file

Description of problem:

The X11 server crashes after updating to rhel 5.4.  The Xorg.0.log shows a Signal 11 error and has a backtrace.

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-1.6.5-9.25.el5
xorg-x11-server-Xorg-1.1.1-48.67.el5

How reproducible:

On two out of two machines with intel video cards it happens

Steps to Reproduce:
1. Update xorg-x11-drv-i810 to the latest version
2. restart X server
  
Actual results:

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x81) [0x80cedc1]
1: [0x6dc420]
2: /usr/lib/xorg/modules/libi2c.so(xf86I2CFindDev+0x29) [0x7f33b9]
3: /usr/lib/xorg/modules/libddc.so [0xe3ee75]
4: /usr/lib/xorg/modules/libddc.so(xf86DoEEDID+0x102) [0xe3f122]
5: /usr/bin/Xorg(xf86OutputGetEDID+0x40) [0x80f6230]
6: /usr/lib/xorg/modules/drivers/intel_drv.so(i830_ddc_get_modes+0x2c) [0xd6ba1c]
7: /usr/bin/Xorg(xf86ProbeOutputModes+0x28e) [0x80f71de]
8: /usr/bin/Xorg(xf86InitialConfiguration+0x14a) [0x80f89fa]
9: /usr/lib/xorg/modules/drivers/intel_drv.so [0xd61bc0]
10: /usr/bin/Xorg(InitOutput+0x9c5) [0x80a3eb5]
11: /usr/bin/Xorg(main+0x276) [0x8070546]
12: /lib/libc.so.6(__libc_start_main+0xdc) [0x8b6e9c]
13: /usr/bin/Xorg(FontFileCompleteXLFD+0x1fd) [0x806fa51]

Fatal server error:
Caught signal 11.  Server aborting


Expected results:

The X11 server starts

Additional info:

If I downgrade the xorg-x11-drv-i810 package to xorg-x11-drv-i810-1.6.5-9.21.el5 it works.

Comment 1 Steve Cleveland 2009-09-05 00:03:00 UTC
Created attachment 359852 [details]
xorg.conf file

I've also included the xorg.conf used.  This is the default file that was generated during install.  I saw the Xorg.0.log file mentioned no Monitor section being defined.  But even if I do specify one, the Backtrace still occurs.

Comment 5 Olivier Fourdan 2009-09-16 16:41:31 UTC
Created attachment 361323 [details]
Proposed patch

This patch seems to fix the issue.

Comment 7 Doug Kelly 2009-09-18 14:05:42 UTC
I've also noticed this issue, and attached my logs on bug 524242 -- I didn't see this one while searching before.

I'll try the proposed patch and see how it goes.

Comment 8 Olivier Fourdan 2009-09-18 14:10:33 UTC
(In reply to comment #7)
> I've also noticed this issue, and attached my logs on bug 524242 -- I didn't
> see this one while searching before.

Yes, bug 524242 should be marked as a dup of this one indeed, it is the same chipset/symptoms/backtrace.

Comment 9 Steve Cleveland 2009-09-18 19:29:05 UTC
Can you make a package with this patch?  Or I can wait for Doug to test it first.  Thanks.

Comment 10 Doug Kelly 2009-09-18 19:58:05 UTC
I've actually gone ahead and tested already--works just fine.  I did build up an RPM in the process for our use internally, but I'd probably be more apt to let the Red Hat engineers provide a package.

Comment 12 Matthew Miller 2009-10-28 19:01:44 UTC
I came across this issue today as well. Will try to test the patch.

Comment 13 Matthew Miller 2009-10-29 20:53:44 UTC
I built an RPM with the patch, and can confirm that it corrects the problem. Thanks.

Comment 15 Dave Airlie 2009-12-15 22:36:12 UTC
Yeah it looks like we got half a backport from upstream,

the code to add/remove i2c buses around the crt detect, but not the new crt edid get function from upstream.

Either this patch or backporting the rest of the CRT detct code should fix the issue.

Comment 20 Adam Jackson 2010-02-22 21:28:28 UTC
2275063 build (dist-5E-qu-candidate, /cvs/dist:rpms/xorg-x11-drv-i810/RHEL-5:xorg-x11-drv-i810-1_6_5-9_33_el5) completed successfully

MODIFIED

Comment 25 Ryan Lerch 2010-03-26 01:04:12 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Previously, there was an issue in the CRT detect code in the driver. Consequently, after updating the xorg-x11-drv-i810 package, the X server may have failed to boot, returning the error message: 

Caught signal 11.  Server aborting

With this update, this issue has been resolved.

Comment 26 errata-xmlrpc 2010-03-30 08:35:04 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0262.html

Comment 31 Matěj Cepl 2010-07-23 16:54:37 UTC
*** Bug 524242 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.