Bug 521358 - /etc/yum.repos.d/Fedora-install-media.repo prevents from installing gcc
Summary: /etc/yum.repos.d/Fedora-install-media.repo prevents from installing gcc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 520790 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 04:16 UTC by Joachim Backes
Modified: 2009-10-13 13:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-09 14:23:30 UTC


Attachments (Terms of Use)

Description Joachim Backes 2009-09-05 04:16:33 UTC
Description of problem:

After a clean F12 alpha install (without devel packages), I tried to
install gcc, but getting some repo issues:

Error Downloading Packages:
   ppl-0.10.2-5.fc12.i686: failure: Packages/ppl-0.10.2-5.fc12.i686.rpm 
from InstallMedia: (256, 'No more mirrors to try.')
   binutils-2.19.51.0.14-31.fc12.i686: failure: 
Packages/binutils-2.19.51.0.14-31.fc12.i686.rpm from InstallMedia: (256, 
'No more mirrors to try.')

binutils-2.19.51.0.14-31.fc12.i686: failure: 
Packages/binutils-2.19.51.0.14-31.fc12.i686.rpm from InstallMedia: (256, 
'No more mirrors to try.')

I could solve the problem: I found in /etc/yum.repos.d a file called
Fedora-install-media.repo with the following lines:()

[InstallMedia]
name=Fedora 12-Alpha
mediaid=1250548413.424676
metadata_expire=-1
gpgcheck=0
cost=500
()
It seems this file had been added by anaconda 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install f12 alpha without gcc
2.Try to install gcc after f12 installation with yum
3.
  
Actual results:
yum fails

Expected results:
gcc is installed

Additional info:
see https://bugzilla.redhat.com/show_bug.cgi?id=520790

Comment 1 Chris Lumens 2009-09-09 14:23:30 UTC
This should be fixed in the next build of anaconda.

Comment 2 Chris Lumens 2009-10-13 13:27:59 UTC
*** Bug 520790 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.