Bug 521370 - Banshee 1.6 Beta 2 crashes with Mass Storage Device attached
Summary: Banshee 1.6 Beta 2 crashes with Mass Storage Device attached
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: banshee
Version: 12
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Christian Krause
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 537323
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 09:16 UTC by Christopher Grebs
Modified: 2009-12-03 05:05 UTC (History)
4 users (show)

Fixed In Version: 0.8.5-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-03 05:05:06 UTC
Type: ---


Attachments (Terms of Use)

Description Christopher Grebs 2009-09-05 09:16:16 UTC
Description of problem:

I just attached my Nokia N97 device as a mass storage device, started sync my music library and it goes well.  After some time it crashes and till that point it crashes over and over again right after starting Banshee.

Version-Release number of selected component (if applicable):

Banshee 1.6 Beta 2 (1.5.1)
RPM-Version: 1.5.1-0.2.git20090831.fc12

How reproducible:

If I clean up the music database on my N97 Banshee starts just as expected but after playing some stuff to my n97 it crashes over and over again.  It only happens if I push stuff with Banshee to my N97.  If I sync my music library with Rhythmbox and start Banshee after that, it does not crash.

Steps to Reproduce:
1. Clean up the music library on the mass storage device
2. open up banshee and sync the device
3. wait until it crashes
  
Actual results:

Banshee crashes

Expected results:

The sync get's done after some while and I can hear the music on my phone.

Additional info:

Banshee in debug mode: http://paste.pocoo.org/show/sKDpg8C6qQxMeFreKA5v/

If you need some more informations, just tell me how I can give you those; as this is one of my first tickets, help me to help you to get that stuff fixed :)

Comment 1 Christopher Grebs 2009-09-05 09:19:39 UTC
Maybe it gets some more informations:

I have a file .is_audio_player on the root of my N97 device with that content:

audio_folders=Music/
output_formats=audio/mp3

Comment 2 Michel Alexandre Salim 2009-09-13 20:19:33 UTC
Thanks for the report. We'd probably need some more information to help pinpoint the source, at which point we might know better whether it's a problem at our end or with upstream's code.

* Does this bug occur with any MTP device? e.g. does this occur with a USB stick?
* What file format is in your library? Are they MP3, or some other formats that get transcoded for transfer?
* If the second, does the bug occur if, going back to the USB stick test, you declare it to support all the formats currently in your library? i.e. whether the bug is related to transcoding or not

Comment 3 Christopher Grebs 2009-09-15 18:55:39 UTC
Thanks for the reply, Alexandre!

Well, for point one: I tried with all my MTP-Devices I have (unfortunately only two) and it happens with both.

Second point: My library mostly consists of FLAC files and some MP3 files while my MTP devices support a wide range of codecs (ogg, mp3, wav and others...). For now I tried transferring only MP3 and only FLAC and both times it crashed.

And the third point is not reproducable. Since one or two days the bug only occurs on some crazy intervals where I'm not able to get a clue of what happened.

But what I noticed is that if I build the current trunk of Banshee it seems to work properly (then i get other crashes, but these are not related to the MTP-part). Well, the problem is that I did not find any commits that could be responsible for the problems I have. But I'm neither familiar with the Banshee-magic nor the code - so I probably may missing something.

Would be cool if someone can push the latest trunk to the repository.

Regards,
Christopher.

Comment 4 Michel Alexandre Salim 2009-09-20 01:21:20 UTC
The updated 0.3 build should be in Rawhide now -- is the problem still occuring? Let me know either way.

Thanks,

-- 
Michel

Comment 5 Christopher Grebs 2009-09-20 10:22:03 UTC
Thanks for the update but it seems that now banshee does not like either zeroconf or avahi or it's broken.

http://paste.pocoo.org/show/140629/

It happens now also without a MTP device attached.

If I --disable-dbus then everything works well, but then MTP devices are not recognized.

If I look at the stacktraces it seems that the problem is still the same.

Regards,
Christopher

Comment 6 Michel Alexandre Salim 2009-09-20 21:26:59 UTC
The bizarre thing is that the Zeroconf and Avahi problem really has nothing to do with MTP.. ugh. This is really motivation for me to now work on fixing MonoDevelop, to finally get a decent debugger for Mono apps :P

Could you provide me with the configure flags you used to build your copy of Banshee? Also, if you can, install rpmdevtools and then use rpmdev-rmdevelrpms *before* you start the build, and then install the BuildRequires mentioned here:

http://cvs.fedoraproject.org/viewvc/devel/banshee/banshee.spec?revision=1.81

before doing the configure and build. If you get a working Banshee then it's either different compiler settings and/or different configure flags.

Thanks again, hopefully we can fix this before the beta.

Comment 7 Christopher Grebs 2009-09-22 20:28:10 UTC
Okay, I just updated my rawhide-installation to the latest packages and compiled the current banshee-trunk again.

Log: http://paste.pocoo.org/show/lFS1LXyM9tAyGP6btgpw/

It seems that it works just fine (detailed tests are scheduled tomorrow); Before I build the latest trunk I tested some scenarios and those where it broke seems to be fixed (but don't ask be how...)

But what I get now is a warning that no DAAP client could be started: http://paste.pocoo.org/show/yNpAKIlywcOs8JknK8jY/

Is that relevant to the bug? If you need more informations, just tell me how I can give you them.  It looks that the git build is just fine but the fedora-package seems to be broken somehow.  I'd like to try to compare the current fedora-package with the used git-revision to take a look if it's really the fedora-package.

Regards,
Christopher.

Comment 8 Christopher Grebs 2009-11-04 05:30:44 UTC
Okay, I now tested the latest git checkout about two weeks with great response.  It seems that everything is working fine, no crash, no problems (except those known in the banshee-community such as last.fm support etc.).

So please update the package to the latest Banshee-Version, it fixes a lot of things and introduces quite a lot more enjoying features!

Thanks!

Regards, Christopher.

Comment 9 Bug Zapper 2009-11-16 11:59:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Christian Krause 2009-11-18 20:41:55 UTC
I've updated banshee to the most recent git version in rawhide and F12. The update should hit updates-testing in the next days. Please test whether the reported problem is solved. Thanks!

Comment 11 Fedora Update System 2009-11-18 21:29:31 UTC
banshee-1.5.2-0.1.20091118git.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/banshee-1.5.2-0.1.20091118git.fc12

Comment 12 Fedora Update System 2009-11-20 05:26:56 UTC
banshee-1.5.2-0.1.20091118git.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update banshee'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11794

Comment 13 Fedora Update System 2009-11-25 15:00:28 UTC
ipod-sharp-0.8.5-1.fc12, banshee-1.5.2-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ipod-sharp banshee'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11623

Comment 14 Fedora Update System 2009-12-03 05:04:54 UTC
ipod-sharp-0.8.5-1.fc12, banshee-1.5.2-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.