Bug 521378 - setroubleshoot: SELinux is preventing prelink "remove_name" access on slashem.#prelink#.GCMsB0.
Summary: setroubleshoot: SELinux is preventing prelink "remove_name" access on sl...
Keywords:
Status: CLOSED DUPLICATE of bug 521375
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:fef6369841f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 10:16 UTC by Sebastiano M. Cossu
Modified: 2009-09-08 22:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 22:03:46 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-05 10:16:40 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing prelink "remove_name" access on slashem.#prelink#.GCMsB0.

Descrizione dettagliata:

[prelink has a permissive type (prelink_t). This access was not denied.]

SELinux denied access requested by prelink. It is not expected that this access
is required by prelink and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       system_u:system_r:prelink_t:s0-s0:c0.c1023
Contesto target               system_u:object_r:games_exec_t:s0
Oggetti target                slashem.#prelink#.GCMsB0 [ dir ]
Sorgente                      prelink
Percorso della sorgente       /usr/sbin/prelink
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        prelink-0.4.2-2.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.28-8.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.180.rc7.git4.fc12.i686 #1 SMP
                              Wed Aug 26 16:30:44 EDT 2009 i686 i686
Conteggio avvisi              1
Primo visto                   mer 02 set 2009 20:44:38 CEST
Ultimo visto                  mer 02 set 2009 20:44:38 CEST
ID locale                     e522baae-64c8-4ec1-897b-4e38be1a2f13
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1251917078.684:20475): avc:  denied  { remove_name } for  pid=10374 comm="prelink" name="slashem.#prelink#.GCMsB0" dev=dm-0 ino=56491 scontext=system_u:system_r:prelink_t:s0-s0:c0.c1023 tcontext=system_u:object_r:games_exec_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1251917078.684:20475): arch=40000003 syscall=38 success=yes exit=0 a0=bff49920 a1=bff49960 a2=871e5c0 a3=bff49960 items=0 ppid=10365 pid=10374 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2 comm="prelink" exe="/usr/sbin/prelink" subj=system_u:system_r:prelink_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= prelink_t ==============
allow prelink_t games_exec_t:dir remove_name;

Comment 1 Daniel Walsh 2009-09-08 22:03:46 UTC

*** This bug has been marked as a duplicate of bug 521375 ***


Note You need to log in before you can comment on or make changes to this bug.