Bug 521384 - Provide kicad-library for projects utilzing it
Summary: Provide kicad-library for projects utilzing it
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kicad
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chitlesh GOORAH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 11:55 UTC by Juha Tuomala
Modified: 2009-09-24 15:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 15:12:44 UTC


Attachments (Terms of Use)

Description Juha Tuomala 2009-09-05 11:55:21 UTC
Description of problem:
http://wiki.openmoko.org/wiki/Gta02-core project uses Kicad as primary tool, but also requires, that kicad-library is installed, otherwise the Getting Started steps fail.

Version-Release number of selected component (if applicable):
All current fedora releases.

How reproducible:
Always.

Steps to Reproduce:
1. read http://wiki.openmoko.org/wiki/Gta02-core#Getting_started
2. start kicad
3. try to open schema editor
  
Actual results:
Kicad complains about missing gta02-core.lib file, those library symbols do not exist in gta02-core project.

Expected results:
Opening schema editor successfully without errors.

Additional info:
Related patch to docs how to manually install library from svn snapshot.
http://iki.fi/lindi/openmoko/gta02-core-document-kicad-library1.patch

Comment 1 Juha Tuomala 2009-09-05 11:57:17 UTC
I also think that this package should be maintained by the same people owning the actual program, they're more aware of its changes and thus the maintenance requires less work.

Comment 2 Juha Tuomala 2009-09-05 12:57:03 UTC
More information from #gta02-core:

[15:52] <wpwrak> we're just using a few symbols from the stock library. all the rest is our own, including all the footprints.
[15:52] <wpwrak> that way, we can at least document the origin of those things
[15:52] <Tuju> so that last release is enough?
[15:53] <wpwrak> we're using svn since some important features are quite new. e.g., 2009-02 would have a different (and much inferior) font system
[15:53] <Tuju> ah, so trunk shall it be then.
[15:53] <wpwrak> yep :)

so svn trunk snapshot from:
http://kicad.svn.sourceforge.net/svnroot/kicad/trunk/kicad-library

Also, at #kicad I was told that library doesn't have any other documentation or web pages other than svn repository contains.

Comment 3 Juha Tuomala 2009-09-05 14:26:20 UTC
...Checking for unpackaged file(s): /usr/lib/rpm/check-files /home/tuju/PKGS/BUILDROOT/kicad-library-0-1.20090904svn1954.fc10.x86_64
Wrote: /home/tuju/PKGS/SRPMS/kicad-library-0-1.20090904svn1954.fc10.src.rpm
Wrote: /home/tuju/PKGS/RPMS/x86_64/kicad-library-0-1.20090904svn1954.fc10.x86_64.rpm
Wrote: /home/tuju/PKGS/RPMS/x86_64/kicad-library-debuginfo-0-1.20090904svn1954.fc10.x86_64.rpm

% rpmlint -v /home/tuju/PKGS/SRPMS/kicad-library-0-1.20090904svn1954.fc10.src.rpm
kicad-library.src: I: checking
kicad-library.src: W: invalid-license ?
kicad-library.src:11: W: non-break-space line 11
1 packages and 0 specfiles checked; 0 errors, 2 warnings.

spec: http://tuju.fi/fedora/11/kicad-library.spec
src: http://tuju.fi/fedora/11/kicad-library-0-1.20090904svn1954.fc10.src.rpm

License remains unclear to me still.

Comment 4 Juha Tuomala 2009-09-05 15:15:56 UTC
doh, it appears that gta02-core project 
a) ...libs are already included into main package.
b) ...needs more recent version of kicad --> fedora release cannot be used.
b) ...needs trunk version of kicad-libs --> fedora release cannot be used.

Comment 5 Chitlesh GOORAH 2009-09-07 10:26:32 UTC
Juha, 

which fedora release cannot be used  ?

rpm -q kicad


We are currently shipping kicad-2009.07.07-3.rev1863.fc11 for Fedora 11.

Is kicad-2009.07.07-3.rev1863.fc11 not recent enough ?

I would be happy to improve Fedora kicad package in that perspective.

Comment 6 Juha Tuomala 2009-09-07 11:13:16 UTC
Note that this was the first time I heard kicad, from this Gta02-core project.

I've f10 here, but in #gta02-core developers said that all of them are using trunk version and apparently they haven't worked with the kicad project team to organize releases to match their requirements.

The end result is that everyone is required to build their own tool-chain to participate and thus stepping in to that project becomes harder.

They also said, that the library is from trunk, as they're using some recent changes. IMO you should split that into own package or sub package as it's more likely to change more frequently. Should you follow trunk or releases, hard to say. In that project those fedora packages turned out to be useless and just consumed time and frustrated compared to manual compilation/self packaging.

Sad but it's not your fault. I would blame the lack of communication of those two groups and not working together to have common ready toolchain in every distribution.

Comment 7 Chitlesh GOORAH 2009-09-07 11:37:58 UTC
Actually the previous fedora kicad maintainer abandoned kicad because of the lack of communication with upstream. Hence John and I stepped in to maintain kicad instead.

I'll update fedora kicad and I'll see what I can do to support Gta02's development.

Comment 8 Juha Tuomala 2009-09-07 11:55:21 UTC
Well at least you have a right attitude for the job.

In my experience, both communities (irc channels actually) were responsive when talked to them in freenode. Apart from that communication with me, they should communicate between each other and actually do something for this situation (releases). In case that does not happen, your only option is to follow trunk.

Perhaps this situation would get better if properly addressed and everyone would be invited to tackle it. I'm not aware of their background has there been any meetings between all affected parties.

Comment 9 Chitlesh GOORAH 2009-09-24 15:12:44 UTC
Well I've opened a ticket against FEL so we can focus on supporting openmoko development needs.

One of the Fedora Electronic Lab goals is also to support opensource hardware development.

I'm closing this bug and welcome you to follow the progress on
https://fedorahosted.org/fedora-electronic-lab/ticket/54


Note You need to log in before you can comment on or make changes to this bug.