Bug 521419 - nfs network install fails - trying to access a directory(?) not in the ISO
Summary: nfs network install fails - trying to access a directory(?) not in the ISO
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 17:06 UTC by John Dubery
Modified: 2009-09-05 20:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-05 20:34:00 UTC


Attachments (Terms of Use)

Description John Dubery 2009-09-05 17:06:57 UTC
Description of problem:
Trying to perform a network install of F11; the target machine was booted using a F11 network install CD, added parameters "linux askmethod". Note that the server is not exporting the DVD ISO image directly, but the ISO is loop mounted because the direct mount doesn't work (see my report - Bug 521418)

I get to the "Starting install process. This may take several minutes..." dialog, this fills its progress bar then everything stops.

The server log has "can't stat exported dir /mnt/Fedora-11-i386-DVD/RHupdates: No such file or directory".

It seems the installer is trying to access a folder that does not exist in the DVD image. When this fails the installer stops dead.

Version-Release number of selected component (if applicable):
- anaconda - as current download ISO images
- F11 DVD ISO image (exported by the server) - current download
- target is running a CD with the F11 network install image - current download

How reproducible:
100%

Steps to Reproduce:
1. as above
2.
3.
  
Actual results:
F11 install fails

Expected results:
F11 install OK

Additional info:
not sure exactly what to assign this to (may actually be an installation guide problem); used anaconda as an "install problem catcher" and likely suspect

Comment 1 Chris Lumens 2009-09-05 20:34:00 UTC
During installation, anaconda looks in a variety of places to get updated python files that are used to patch anaconda itself.  Passing updates= as a parameter is one way that users can control this process.  anaconda additionally tries to grab updates automatically based on the method used to install.  The directory you see is one of those attempts.  Errors here are not fatal.  They just mean you won't get any updates loaded from that directory.

Whatever real failure you're seeing is not caused by this.


Note You need to log in before you can comment on or make changes to this bug.