Bug 52142 - can't continue when i have to mount / (root)
can't continue when i have to mount / (root)
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-08-20 21:10 EDT by Hansen
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-09-06 15:21:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Hansen 2001-08-20 21:10:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
i have 30 gigs hard drive which i partition to :
15 GB primary 
15 GB extended dos , which include 12 GB logical drive and 3 GB 
Right now i'm trying to install RHL 7.1 and i had this error. 
when i try to mount the / installer give me this error : " /boot > 1024 
cylinder " and i can't continue. 
This is weord because last time when i installed the RHL 7.0 it didn't 
give me this error. I was using the same exact partition table.
I know some issues that LILO can't read beyond 024 cylinder but why it 
doesn't happen to me when i installed rhl 7.0

for your info : Last time when i installed rhl 7.0 I put LILO in the first 
sector of the partition , so i use boot disk if i want to boot to linux.
so how should i do now ???

thanks in advance 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.when i try to mount the /

Additional info:
Comment 1 Matt Wilson 2001-08-20 23:51:55 EDT
boot with "linux edd"
Comment 2 Hansen 2001-08-21 00:54:43 EDT
still can't mount the / 
installer still says boot partition > 1024 cylinder
Comment 3 Matt Wilson 2001-08-21 12:18:59 EDT
If you booted with "linux edd" this should just be a warning message.  What is
the full text of the message dialog you are getting?
Comment 4 Hansen 2001-08-21 15:10:19 EDT
the error windows says like this
" There are currently unallocated partition(s) present in the list of requested 
partitions. The unallocated partititon(s) are shon below, along with the reason 
they were not allocated"

/    Boot partition > 1024 Cylinder  

if i click ok, the / will printed in red on the partition table and the next 
button to continue is illuminated, so i can't process on.

PLease help.
Comment 5 Riccardo 2001-08-24 06:51:18 EDT
Please help because I got the exactly the same problem!!!
Comment 6 Hansen 2001-08-24 16:52:00 EDT
can you install rhl 7.0 though cyblues ? becauuse i don't have this problem 
with rhl 7.0. 
Ijust want to make it clear here..
btw, is this problem already assigned ??? please respond , thanks 
Comment 7 Riccardo 2001-08-27 06:51:08 EDT
hi hansenc

rhl 7.0 installs fine, the problem remains still the same with rhl 7.1.
My hard drive contains already winnt server but it shouldn't be a problem (it 
isn't with rhl 7.0....). I don't think this problem has alreaady been assigned.
keep posted and let me know if you sort out something.

Comment 8 Michael Fulbright 2001-08-29 12:56:56 EDT
I would recommend setting up a /boot partition (around 50MB) using the fdisk
program. Then go into the disk druid interface and select this partition to be
/boot.  Create the rest of your partitions with disk druid and things should be
Comment 9 Hansen 2001-08-29 20:28:46 EDT
it doesn't allow me to do that , the result will be the same as when i mount 
root, which is got written on red text and said unallocated.
any other clue ??? should i destroy my partition and start all over again ? 
because i want to have linux in my system. If that would be necessary what 
should i do this time to partition my hard dive. 
But above all i really prefer that i don;t have to partitioned my harddrive all 
over again.

thanks once more.
Comment 10 Michael Fulbright 2001-08-31 11:07:52 EDT
Could you please attach a listing of your current partition table? You can get
this using the linux fdisk program.  Boot the installer and go through it until
you see the 'Red Hat Linux 7.1' splash screen.  Switch to VC2 (cntl-alt-f2) and

mknod /tmp/<diskdevice>
fdisk -l /tmp/<diskdevice> -> the output from this command is what I would like.

where <diskdevice> is the device for your hard drive. Usually its something like
hda. You can find this out by going to the Disk Druid screen and seeing which
disk(s) it displays.

Comment 11 Hansen 2001-09-01 03:12:14 EDT
ok here's what i got with those commands :

Disk  /tmp/hda: 255 heads, 63 sectors, 3736 cylinders
Units=cylinders of 16065 * 512 bytes
Device     Boot  Start  End        Block     Id     System
/tmp/hda1   *        1  1868   15004678+     c      Win95Fat32(LBA)
/tmp/hda2         1868  3736   15004710      f      Win95Ext`d(LBA)
/tmp/hda5         1869  3353   11928231      b      Win95Fat32

ok, that's all hope you can help me through this problem 
Comment 12 Matt Wilson 2001-09-05 22:21:18 EDT
I've replicated the problem.
Comment 13 Matt Wilson 2001-09-05 22:36:03 EDT
I have a (somewhat kludgy) workaround for this.  Create a / partition and a
/boot partition.  Make a swap partition.  The /boot request will still be
unfilled, but you will be able to hit Next and continue the installation anyway.
 The system will install as though you didn't ask for a /boot partition at all.

The other workaround for this is to use the fdisk tool to create the partitions
past the 1024 cyl boundary.  Disk Druid will then allow you to assign the
existing partitions you just created in the fdisk too to the /boot partition
without any problems at all.

All of this code has been replaced in the next release and it works much better
now.  These workaround are the solution for 7.1.
Comment 14 Hansen 2001-09-06 03:56:55 EDT
thanks msw. it worked, i just installed rhl 7.1 in my system.
but right now i'm left with one question. why during the installation it 
doesn't ask me where i want to put lilo. ask i remember lasttime when i do 
installation for rhl 7.0 it ask whether i want lilo to be in the mbr or in the 
first sector of the boot partition. In my case i want it to be in the first 
sector of the boot partition, not in the mbr. ( i came to the conclusion that 
lilo is installed in the mbr because lilo boot itself without the boot disk )
My question is how can i remove lilo from the mbr and put it in the first 
sector of the boot partition ??? is it safe to do that ? 

ok , once again thanks. 
sorry if this post is inappropriate for the thread topic 
Comment 15 Matt Wilson 2001-09-06 08:04:02 EDT
if you select 'workstation install' it puts LILO on the MBR.

This is different in the next release, I believe.

you can put in in the first sector of your boot partition as long as there is a
valid DOS-style mbr installed.  you can do this by running fdisk /mbr from dos. 
From there the partition that has lilo installed must be active in order to
Comment 16 Hansen 2001-09-06 12:23:25 EDT
ok , can you give me more detail steps ?
after i do fdisk /mbr, will my whole boot system be erased (win98 and lilo) ?
if so how will i be able to boot win 98 ? is it just a simple sys c: ? from a 
floppy that has system files in it ? 
and how about moving lilo to the first sector of the linux partition ??? 
ps : i make a linux bootdisk during yesterday installation.

thanks once again , you were really helpfull.
Comment 17 Matt Wilson 2001-09-06 12:57:07 EDT
it is probaby better just to install lilo to the mbr and use it to chainload any
other operating systems you have installed.
Comment 18 Hansen 2001-09-06 14:36:23 EDT
can you please help ? i'm sorry if i keep bugging you around. 
thanks once again.
Comment 19 Jeremy Katz 2001-09-06 15:06:02 EDT
After using fdisk /mbr, your system will be fine and just the boot record will
be replaced with a DOS boot record.  No other changes will be made to the system.

To change LILO so that it installs to the partition, edit the /etc/lilo.conf
file and look for the line boot=/dev/foo, where foo is probably hda in your
case.  If you change this to be your root partition and run /sbin/lilo, then
LILO will be installed to the root partition instead of the MBR.
Comment 20 Hansen 2001-09-06 15:17:35 EDT
so which one should be done first ??? the "fdisk /mbr" or "edit 
the /etc/lilo.conf and run /sbin/lilo "

and how do i determine what is my root partition in linux. i know that master 
harddrive is hda but i think linux label it with hda1, hda2 , and else for the 
partititon right ? 

thanks for the answer.
Comment 21 Matt Wilson 2001-09-06 15:19:10 EDT
1) fdisk /mbr
2) edit lilo.conf
3) re-run lilo
Comment 22 Hansen 2001-09-06 15:20:12 EDT
so which one should be done first ??? the "fdisk /mbr" or "edit 
the /etc/lilo.conf and run /sbin/lilo "

and how do i determine what is my root partition in linux. i know that master 
harddrive is hda but i think linux label it with hda1, hda2 , and else for the 
partititon right ? 

thanks for the answer.
Comment 23 Hansen 2001-09-06 15:21:39 EDT
ups, repost...
so after i do fdisk /mbr i will boot to linux with the disk right ???
how about identifying the root partition ???
Comment 24 Matt Wilson 2001-09-06 15:29:59 EDT
yes, contact support for any further problems.

Note You need to log in before you can comment on or make changes to this bug.