Bug 521423 - Regression: Fedora 12 hangs often when booting
Summary: Regression: Fedora 12 hangs often when booting
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 12
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 17:57 UTC by Stefan Krause
Modified: 2010-12-05 06:28 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-05 06:28:56 UTC


Attachments (Terms of Use)
screenshot when hanging (408.37 KB, image/jpeg)
2009-09-05 17:57 UTC, Stefan Krause
no flags Details
dmesg (53.90 KB, text/plain)
2009-09-05 18:07 UTC, Stefan Krause
no flags Details
dmidecode (7.53 KB, text/plain)
2009-09-05 18:07 UTC, Stefan Krause
no flags Details
/proc/interrupts (1.67 KB, application/octet-stream)
2009-09-05 18:07 UTC, Stefan Krause
no flags Details
lspci -vvnn (36.77 KB, text/plain)
2009-09-05 18:08 UTC, Stefan Krause
no flags Details
/proc/acpi (34.10 KB, application/x-bzip)
2009-09-05 18:09 UTC, Stefan Krause
no flags Details
Sceenshot for 2.6.31-0.204.rc9.fc12.x86_64 (402.23 KB, image/jpeg)
2009-09-07 18:59 UTC, Stefan Krause
no flags Details
dmesg with acpi=noirq (64.52 KB, text/plain)
2009-09-08 17:52 UTC, Stefan Krause
no flags Details
output of lshw for this machine (17.74 KB, text/plain)
2009-10-23 23:08 UTC, Wolfgang Rupprecht
no flags Details
Dmesg (46.03 KB, text/plain)
2009-12-23 09:12 UTC, Jens Falsmar Oechsler
no flags Details
lspci -vv (30.83 KB, text/plain)
2009-12-23 09:13 UTC, Jens Falsmar Oechsler
no flags Details
boot local drive with nomodeset (53.37 KB, image/pjpeg)
2010-05-16 23:56 UTC, Johnny
no flags Details
lspci -vv (9.03 KB, text/plain)
2010-05-17 00:27 UTC, Johnny
no flags Details
dmidecode (13.09 KB, text/plain)
2010-05-17 00:28 UTC, Johnny
no flags Details
/proc/interrupts (1.20 KB, text/plain)
2010-05-17 00:28 UTC, Johnny
no flags Details
/var/log/dmesg (22.87 KB, text/plain)
2010-05-17 00:29 UTC, Johnny
no flags Details
/var/log/boot.log (2.77 KB, application/octet-stream)
2010-05-17 00:30 UTC, Johnny
no flags Details


Links
System ID Priority Status Summary Last Updated
Linux Kernel 14244 None None None Never

Description Stefan Krause 2009-09-05 17:57:23 UTC
Created attachment 359869 [details]
screenshot when hanging

Description of problem:
Fedora 12 hangs often when booting. This is a regression since Fedora 11 works fine on my laptop.

On my laptop (a hp hdx 9300) fedora 12 locks up hard very early when booting most of the time (something like 50-75%), crtl + alt +del is ignored and only powering off helps to shutdown the laptop.
Booting with acpi=off or acpi=noirq resolves the problem.

Version-Release number of selected component (if applicable):
Fedora 12 Alpha:

How reproducible:
50-75% of the time

Steps to Reproduce:
Just boot Fedora 12, wait less than 1 second and it'll either boot or hang.
  
Actual results:
Fedora boots sometime sucessfully and sometime it hangs (I thind I said that already...)

Expected results:
Fedora 12 boots ;-)

Additional info:
I'll attach an screenshot (fedora 12 booting without splash and quiet) when fedora 12 hang on boot.
I also tried two other 2.6.31 distros with mixed results.
I have the same issue on Ubuntu 9.10 Alpha and it even seems to happen slightly more often there.
OpenSuse 11.2 Alpha on the other hand boots as expected. 

I'll soon add an lspci -vvnn and dmesg output.

Comment 1 Stefan Krause 2009-09-05 18:07:07 UTC
Created attachment 359870 [details]
dmesg

Comment 2 Stefan Krause 2009-09-05 18:07:34 UTC
Created attachment 359871 [details]
dmidecode

Comment 3 Stefan Krause 2009-09-05 18:07:56 UTC
Created attachment 359872 [details]
/proc/interrupts

Comment 4 Stefan Krause 2009-09-05 18:08:22 UTC
Created attachment 359873 [details]
lspci -vvnn

Comment 5 Stefan Krause 2009-09-05 18:09:21 UTC
Created attachment 359874 [details]
/proc/acpi

Comment 6 Chuck Ebbert 2009-09-07 03:57:18 UTC
Please try kernel-2.6.31-0.204.rc9.fc12 and see if that fixes it...

Comment 7 Stefan Krause 2009-09-07 18:56:40 UTC
I updated to 2.6.31-0.204.rc9.fc12.x86_64 (I enable rawhide-testing or so) and I'm sorry to say it locked up two times (didn't try more often). A screenshot without "quite rhgb" is attached.
Booting with pci=routeirq or pci=noacpi worked fine (two attempts each).

I'd really like to help track this issue down - just let me know how I can help.

Comment 8 Stefan Krause 2009-09-07 18:59:17 UTC
Created attachment 360012 [details]
Sceenshot for 2.6.31-0.204.rc9.fc12.x86_64

Comment 9 Chuck Ebbert 2009-09-07 22:37:07 UTC
Can you attach the dmesg from booting with acpi=noirq?

Comment 10 Stefan Krause 2009-09-08 17:52:03 UTC
Created attachment 360113 [details]
dmesg with acpi=noirq

Comment 11 Chuck Ebbert 2009-10-11 19:38:47 UTC
Does it boot with the option "pci=nomsi"?

Comment 12 Stefan Krause 2009-10-13 18:59:47 UTC
I had to deinstall my Fedora 12 Alpha version and could only try with Ubuntu 9.10 Beta (and won't have time to install F12 the next weeks), which hangs with pci=nomsi on 64 bit as well.
I've reported the bug on the kernel bug tracker too.
http://bugzilla.kernel.org/show_bug.cgi?id=14244&action=View

The current state is:
*x64_64 hangs on Fedora 12 Alpha and Ubuntu 9.10 beta; custom build kernels hang as well. The probability of a successful boot is maybe 20%.
* x64 (32 bit) version of Ubuntu 9.10 boots without problems since a few days.
* I'm a bit unsure about OpenSuse 11.2. It worked almost perfect on 64 bit, but two times it hang (but I haven't captured the output).

Comment 13 Sanne Grinovero 2009-10-22 09:28:34 UTC
Confirming this on Fedora 12 Beta.
Both from live-cd (gnome) and after installation with downloaded updates it hangs quite often.
For some reason (I think unrelated) it doesn't wait at the grup console, so I need to reinstall/use live to change the boot kernel parameters.

Last message before hanging
"Starting atd: [OK]"

Using interactive mode the last service asked for permission to start was "local", (I answered "yes" and it crashed).

I'm glad to provide any additional information which might be useful.

Comment 14 Wolfgang Rupprecht 2009-10-23 23:08:30 UTC
Created attachment 365911 [details]
output of lshw for this machine

this is the lshw output for the failing HP laptop

Comment 15 Wolfgang Rupprecht 2009-10-23 23:08:50 UTC
This bug also exists on Hewlett-Packard Presario V5000 (ES188AV) F.54 with 2.6.31.1-56.fc12.x86_64 .  The laptop usually makes it through bootup (but not always), but will almost always hang with the orange "caps lock" led flashing.  
booting with "nomodeset" and "pcie_aspm=off" doesn't help.  I'll attach the output of lshw to show what is in this laptop.

Comment 16 oren.almog 2009-11-12 21:12:05 UTC
I am running fedora 12 with kernel 2.6.31.5-115 (32 bit) in Virtual Box and have the same problem. Just like http://bugzilla.redhat.com/show_bug.cgi?id=521423#c13 mentioned it also hangs just after "Starting atd: [OK]"

Comment 17 Bug Zapper 2009-11-16 11:59:25 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 18 José Manuel 2009-11-24 05:35:46 UTC
I had the same problem since Fedora 11, then I decided to upgrade with preupgrade to Fedora 12, but the problem persisted, acpi=noirq solves the problem.

Comment 19 Carsten Poulsen 2009-11-25 08:30:51 UTC
I had problems after upgrading my system to F12. It was hanging at boot-up saying "starting atd=OK". Tried removing atd service "chkconfig atd off", then it was hanging when starting my samba server. Found out it was related to the display drivers used by Xserver (I have nVidia graphics). Tried running system-config-display, to get a new xorg.conf, but no success. Added parameter "nomodeset" to kernel in grub.conf, rebooted and Xserver started. Changed display driver to nouveau, logged out (then xorg.conf is rewritten) and everything was working then.

Comment 20 Stefan Krause 2009-11-25 18:58:59 UTC
I'm the original poster of this bug. I'd like to suggest splitting this bug report. I wish I had the "starting atd=OK" issue. My system hangs way earlier during boot (but only on x86_64 with acpi enabled). I don't believe the "starting atd=OK" issue has anything in common with the x86_64 + acpi hanging issue.

Comment 21 Carsten Poulsen 2009-11-25 20:45:33 UTC
There can be many reasons that a system is not booting. The point in my post is not that it hangs at "starting atd=OK", since when I removed the service when starting up. Instead it hangs at another place, all because of a display-driver issue. But I understand that your system hangs earlier during the boot.

Comment 22 Jens Falsmar Oechsler 2009-12-23 09:10:39 UTC
I have laptop with same early boot hanging as original reporter here and in http://bugzilla.kernel.org/show_bug.cgi?id=14244&action=View

One difference is that it's on every bootup and that boot will continue past kernel init after approx. 8 mins. Disabling acpi makes hanging go away.

Comment 23 Jens Falsmar Oechsler 2009-12-23 09:12:40 UTC
Created attachment 379995 [details]
Dmesg

D

Comment 24 Jens Falsmar Oechsler 2009-12-23 09:13:45 UTC
Created attachment 379996 [details]
lspci -vv

Comment 25 Johnny 2010-05-16 23:56:42 UTC
Created attachment 414428 [details]
boot local drive with nomodeset

kernel:2.6.32.11-99.fc12.i686

Comment 26 Johnny 2010-05-17 00:15:09 UTC
(In reply to comment #25)
> Created an attachment (id=414428) [details]
> boot local drive with nomodeset
> kernel:2.6.32.11-99.fc12.i686    

I'm faced the same question
my computer is HP dx2000 mt
chipset: Intel® 865GV chipset 
the specification:
grapic:intel 82865G
http://h18000.www1.hp.com/products/quickspecs/11851_na/11851_na.HTML
use the kernel:2.6.32.11-99.fc12.i686 

with the option acpi=noirq and pci=noacpi
doesn't work

I've tried option acpi=off and it works but with kdump failed
the following attachment is 
1. lspci -vv 
2. dmesg

Comment 27 Johnny 2010-05-17 00:27:30 UTC
Created attachment 414430 [details]
lspci -vv

lspci -vv 
kernel:2.6.32.11-99.fc12.i686 
withoption acpi=off nomodeset

Comment 28 Johnny 2010-05-17 00:28:15 UTC
Created attachment 414431 [details]
dmidecode

kernel:2.6.32.11-99.fc12.i686 
withoption acpi=off nomodeset

Comment 29 Johnny 2010-05-17 00:28:55 UTC
Created attachment 414432 [details]
/proc/interrupts

kernel:2.6.32.11-99.fc12.i686 
withoption acpi=off nomodeset

Comment 30 Johnny 2010-05-17 00:29:30 UTC
Created attachment 414433 [details]
/var/log/dmesg

kernel:2.6.32.11-99.fc12.i686 
withoption acpi=off nomodeset

Comment 31 Johnny 2010-05-17 00:30:11 UTC
Created attachment 414434 [details]
/var/log/boot.log

kernel:2.6.32.11-99.fc12.i686 
withoption acpi=off nomodeset

Comment 32 Bug Zapper 2010-11-04 10:12:08 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 33 Bug Zapper 2010-12-05 06:28:56 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.