Bug 521432 - nouveau driver limits display to 800x600, when 1280x1024 used to work
Summary: nouveau driver limits display to 800x600, when 1280x1024 used to work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 21:48 UTC by Bruno Wolff III
Modified: 2018-04-11 08:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-05 17:07:24 UTC


Attachments (Terms of Use)
Xorg.0.log (15.02 KB, text/plain)
2009-09-05 21:48 UTC, Bruno Wolff III
no flags Details
/var/log/messages (148.28 KB, text/plain)
2009-09-06 22:31 UTC, Bruno Wolff III
no flags Details
More recent Xorg.0.log (27.87 KB, application/octet-stream)
2009-09-19 18:20 UTC, Bruno Wolff III
no flags Details
More recent /var/log/messages (1.25 MB, application/octet-stream)
2009-09-19 18:21 UTC, Bruno Wolff III
no flags Details
xorg.conf that works for me (963 bytes, text/plain)
2009-09-26 18:43 UTC, Bruno Wolff III
no flags Details

Description Bruno Wolff III 2009-09-05 21:48:00 UTC
Created attachment 359884 [details]
Xorg.0.log

Description of problem:
A week or two ago a rawhide update resulted in my display being limited to 800x600 instead of 1280x1024. I am not sure what package update broke things.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.15-7.20090904git2b5ec6a.fc12.i686
kernel-PAE-2.6.31-0.203.rc8.git2.fc12.i686
xorg-x11-server-common-1.6.99-45.20090903.fc12.i686

How reproducible:
100%
I tried custom xorg.conf but the problem persists.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ben Skeggs 2009-09-06 22:23:39 UTC
Can you post your /var/log/messages too please?

Comment 2 Bruno Wolff III 2009-09-06 22:31:02 UTC
Created attachment 359932 [details]
/var/log/messages

Comment 3 Bruno Wolff III 2009-09-16 14:53:35 UTC
This is still happening with:
kernel-PAE-2.6.31-17.fc12.i686
xorg-x11-drv-nouveau-0.0.15-10.20090914git1b72020.fc12.i686
xorg-x11-server-common-1.6.99.901-2.fc12.i686

I'll probably go fill out a nouveau test day entry for this machine. I just haven't made time to do it yet.

Comment 4 Bruno Wolff III 2009-09-19 18:20:14 UTC
Created attachment 361777 [details]
More recent Xorg.0.log

Comment 5 Bruno Wolff III 2009-09-19 18:21:17 UTC
Created attachment 361778 [details]
More recent /var/log/messages

Comment 7 Bruno Wolff III 2009-09-26 18:23:55 UTC
I played with this some more today (as trying to actually use a 800x600 display is annoying).
I switched the port used by the monitor from dvi 1 to dvi 0. This did not appear to have any affect on how things were displayed.
I tried configuring the monitor in system-config-display and that still wouldn't use any mode lines other than what were probed when X started.
I was able to issue a series of xrandr commands to create a new modeline, add it to dvi 0 and then switch to it. This allowed me to get 1280x1024 at 70 Hz. (See xrandr output below.) I don't know how to get this override to apply when X starts up using xrandr. I'll eventually try xorg.conf again, but at least the way I did overrides with it in the past isn't working any more. But maybe I missed something.

[bruno@games1 ~]$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 4096 x 4096
DVI-I-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   800x600        85.1     72.2     75.0     60.3     56.2  
   640x480        85.0     75.0     72.8     59.9  
   720x400        85.0  
   640x400        85.1  
   640x350        85.1  
   1280x1024_70.00   69.8* 
DVI-I-1 disconnected (normal left inverted right x axis y axis)

Comment 8 Bruno Wolff III 2009-09-26 18:43:24 UTC
Created attachment 362773 [details]
xorg.conf that works for me

I found out what was different. In the past when the display use an undesired resolution there was an available modeline to use. In this case there wasn't one, so I needed to add an appropriate modeline to use.
I have attached a working xorg.conf file, that makes the machine a lot more pleasant to use.

Comment 9 Matěj Cepl 2009-11-05 17:14:50 UTC
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Comment 10 Bug Zapper 2009-11-16 11:59:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Chris Campbell 2009-12-05 16:33:47 UTC
Bruno, in Comment #8 you seem to indicate that this bug is no longer an issue, would you please verify?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 12 Bruno Wolff III 2009-12-05 16:48:21 UTC
It looks like the difference is the video driver being more cautious than in the past and mode lines that used to be generated aren't any more. The monitor doesn't do EDID properly (apparently, as I am not an expert in that) and the video driver doesn't know that 1280x1024 modes are safe. In the past the default was tp start X using a lower resolution, but still create some standard mode lines for higher resolutions. So I was able to just specify a resolution I believed to be safe in my xorg.conf file. Now I also have to define the mode line I want to use as well. I was able to do this with cvt. The resulting xorg.conf that is suitable for me was attached above. However, other people with monitors that don't do EDID properly should not blindly copy it. You need to look at the limits of the monitor (and video card) so as not to try to drive it out of spec.
It'd be nice if there was a more user friendly way to handle this, but if you are asking if the bug can be closed, from my point of view it can be. (In that case it would probably be closed NOTABUG as I was just caught be surprise in the change in behavior.)

Comment 13 Chris Campbell 2009-12-05 17:07:24 UTC
Bruno, thank you for your (speedy) response. While I am minor-ly conflicted about making this into a 'futurefeature' marked bug to see if this could be handled better, for now I think we'll close it as you say. Ben's got other issues to handle. If we get more occurrences, however, we'll do that. If you decide it is important, enough to warrant further review, please reopen accordingly.

Again, thank you very much for your time and efforts in finding, reporting, and assisting in resolving this (non?) issue. :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.