Bug 521445 - setroubleshoot: SELinux is preventing the kdm from using potentially mislabeled files (.Xauthority-n).
Summary: setroubleshoot: SELinux is preventing the kdm from using potentially mis...
Keywords:
Status: CLOSED DUPLICATE of bug 521449
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:fbd0a9a6dd7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 22:03 UTC by STEVEN WARD
Modified: 2009-09-06 19:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-06 19:40:15 UTC


Attachments (Terms of Use)

Description STEVEN WARD 2009-09-05 22:03:39 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing the kdm from using potentially mislabeled files
(.Xauthority-n).

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux has denied kdm access to potentially mislabeled file(s) (.Xauthority-n).
This means that SELinux will not allow kdm to use these files. It is common for
users to edit files in their home directory or tmp directories and then move
(mv) them to system directories. The problem is that the files end up with the
wrong file context which confined applications are not allowed to access.

Allowing Access:

If you want kdm to access this files, you need to relabel them using restorecon
-v '.Xauthority-n'. You might want to relabel the entire directory using
restorecon -R -v ''.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .Xauthority-n [ file ]
Source                        kdm
Source Path                   /usr/bin/kdm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdm-4.3.1-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.30-2.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   home_tmp_bad_labels
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-0.199.rc8.git2.fc12.i686 #1
                              SMP Wed Sep 2 21:10:11 EDT 2009 i686 athlon
Alert Count                   5
First Seen                    Sun 30 Aug 2009 08:57:06 AM BST
Last Seen                     Sat 05 Sep 2009 12:44:27 PM BST
Local ID                      7284f3a1-2b36-483f-9598-d09fc217e4e6
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252151067.254:27): avc:  denied  { unlink } for  pid=1296 comm="kdm" name=".Xauthority-n" dev=dm-0 ino=8673 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252151067.254:27): arch=40000003 syscall=10 success=yes exit=0 a0=bfdb594a a1=bfdb5d4c a2=bfdb5d4c a3=bfdb594a items=0 ppid=1260 pid=1296 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:file unlink;

Comment 1 Daniel Walsh 2009-09-06 19:40:15 UTC

*** This bug has been marked as a duplicate of bug 521449 ***


Note You need to log in before you can comment on or make changes to this bug.