Bug 521491 - After update, killbots crashes on start
Summary: After update, killbots crashes on start
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdegames
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 13:22 UTC by Jesse
Modified: 2009-09-06 20:27 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-06 13:26:30 UTC


Attachments (Terms of Use)

Description Jesse 2009-09-06 13:22:39 UTC
Description of problem:
When Fedora 11 was first installed on this machine, the KDE game killbots worked. Since the latest update, killbots crashes. When running from the console, the output from killbots is:

killbots(2581)/libkdegames KGameTheme::load: Attempting to load .desktop at "/usr/share/kde4/apps/killbots/themes/default.desktop"
killbots: symbol lookup error: killbots: undefined symbol: _ZN7KAction11setHelpTextERK7QString




Version-Release number of selected component (if applicable):

# rpm -q kdegames
kdegames-4.3.0-2.fc11.i586

# killbots --version
Qt: 4.5.2
KDE: 4.2.2 (KDE 4.2.2)
Killbots: 1.1.0



How reproducible:
This crash happens every time the game is launched since the latest kdegames upgrade.


Steps to Reproduce:
1. Apply all Fedora updates
2. Run killbots

  
Actual results:
Game crashed with error message.


Expected results:
Game should display playing grid.


Additional info:

Comment 1 Kevin Kofler 2009-09-06 13:26:30 UTC
You can't use kdegames 4.3.0 with kdelibs 4.2.2. You clearly haven't applied ALL Fedora updates. You have to upgrade your kdelibs too.

Comment 2 Jesse 2009-09-06 20:27:53 UTC
You are correct. I had run all updates yesterday. I did it again today from the command line. It turns out that yum refuses to update kdelibs and kdebase-runtime due to file conflicts. I'm not sure why all my other KDE programs continue to function properly, but at least I know now where the error lies.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.