Bug 521500 - RFE:NG Missing Category/Repository and all package view
Summary: RFE:NG Missing Category/Repository and all package view
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 15:00 UTC by Sergei LITVINENKO
Modified: 2009-09-23 08:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-23 04:47:11 UTC
Type: ---


Attachments (Terms of Use)

Description Sergei LITVINENKO 2009-09-06 15:00:00 UTC
Description of problem:
it is not possible to choice ALL packages for view
it is not possible to choice individual repository for browsing (category/repository)

Version-Release number of selected component (if applicable):
yumex-2.9.0-1.fc12.noarch

How reproducible:
100%

Steps to Reproduce:
1. run yumex
2. try to choice all packages (available and installed together)
3. try to choice individual repository to view
  
Actual results:
it is not possible to see what is installed and what is possible to install yet
it is not possible to work with individual repository (rpmfusion)

Expected results:
functionality better or equal yumex-2.0.5

Additional info:

Comment 1 Tim Lauridsen 2009-09-07 06:49:33 UTC
Yumex has been redesigned from scratch and not all the things in yumex-2.0.x has been reimplemented.
I is up to users like user like you to shout up, if i have left out something useful. :)

I can see that category/repository (And some of the other categories) is useful, and will be added.

But I'm not sure about the usefulness of showing all the packages at once, but if you have some good user cases, i might be convinced to add it.

Comment 2 Sergei LITVINENKO 2009-09-07 17:30:02 UTC
>>
>> But I'm not sure about the usefulness of showing all the packages at once
>>

It is useful for tuning the package set of installation.

If package "A" is installed and there is package "A-somethink" (it will be near package "A", because list is sorted), I will check if this extra package can be usefull, because there is a lot of optional packages that are not necessary, but can bring a lot of advantages.

Yes, of cource, I can realize the same by `yum list all | less` in first terminal, `yum info <package-name>` in second terminal and `yum install <package1> <package2> <...>` in third terminal..., but it is much easier to use yumex for this

Comment 3 Tim Lauridsen 2009-09-08 12:49:37 UTC
if you search for something like 'yum' you will see all kind of packages (installed, Available etc)

But i see your point.

Comment 4 Charlie Moschel 2009-09-22 01:06:25 UTC
Once I saw that a search will return packages from all categories, I don't need an 'all' category.  But a casual user may miss it, or not realize he does not need it any longer.

One thing I *do* miss is the 'Add All' button, at least when viewing updates.  Now it's quite tedious to update rawhide each night, ticking each update.  (Unless I missed something, quite probable).

Comment 5 Tim Lauridsen 2009-09-22 09:21:15 UTC
The 'All' and 'Category By Repo' is added to yumex-2.9.1 

http://www.yum-extender.org/blog/2009/09/yum-extender-2-9-1-released/

I is an error that the 'SelectAll' button not is shown, it is fixed upstream now, and will be in 2.9.2.

Comment 6 Charlie Moschel 2009-09-23 02:02:33 UTC
Thanks, I will test it.

But tonight I found another, more serious bug, I believe: installing a new 'group' will *remove* packages from that group that are *already* installed.  Can you confirm it?

For example, on a laptop I "installed to disk" from the KDE snap 3 live CD.  Then, I installed a few gnome programs, such as evince.  Next day I select "gnome desktop" group to install, and I see evince (and many others) marked for deletion (red Xs...) in yumex.  The marked packages were all in the 'gnome desktop' group.

Seems packages in groups have install state logically inverted, when the logic should be 'install if not already installed'.  

I did not follow through with the yumex group install to confirm packages would be removed, but invoking yum directly ('yum install GNOME\ Desktop\*') installed packages without removing anything (like evince).

Sorry, this should probably be a new bug, since you've already fixed the original RFE.

Comment 7 Tim Lauridsen 2009-09-23 04:47:11 UTC
I have confirmed the group selection bug, there was a bug in the package already installed check, it is fixed upstream.

Thanks for testing and reporting bugs, even if you should have created a new one :)

Comment 8 Sergei LITVINENKO 2009-09-23 08:45:07 UTC
Fixed version (yumex-2.9.1-1.fc12.noarch) is OK for me.
Thanks.


Note You need to log in before you can comment on or make changes to this bug.