Bug 521508 - initrd-generic uses drm/ttm to enlarge text display, system latter fails to start X
Summary: initrd-generic uses drm/ttm to enlarge text display, system latter fails to s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 15:35 UTC by matti aarnio
Modified: 2009-09-20 09:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-20 09:28:26 UTC


Attachments (Terms of Use)
Xorg.0.log (15.27 KB, text/plain)
2009-09-06 15:35 UTC, matti aarnio
no flags Details

Description matti aarnio 2009-09-06 15:35:27 UTC
Created attachment 359919 [details]
Xorg.0.log

This is possibly a kernel DRM/RADEON/KMS bug, but it manifests itself only,
when plymouth does something new.  How to disable what the phymouth is doing?

Description of problem:
  Booting to lattest kernel packages has altered my display to a very large
  text console (I am semi thankful of idea), but then latter the X will not
  start telling only that it opened DRM successfully, but nothing more seems
  to happen.  (SysReq keys work, so I can do controlled reboot.)

  Recent kernel package which does not enlarge the display is able to boot
  with absolutely lattest xorg server.

Version-Release number of selected component (if applicable):
  Failing one: initrd-generic-2.6.31-0.203.rc8.git2.fc12.x86_64.img
  Correct function: initrd-generic-2.6.31-0.125.4.2.rc5.git2.fc12.x86_64.img

  It did begin to fail soon after 0.125, but I don't remember when.
  To use X on my workstation, I have to stick on 0.125 kernel.

How reproducible:
  Always.

Steps to Reproduce:
1. Boot to text console at first (I have never trusted those fools that
   want to boot directly to X...  I do understand it, but never trust.)
2. Have a large graphics panel and ATI Radeon HD 2600 XT card (+AMD x86_64)
   (II) RADEON(0): Monitor name: BenQ 241W Z
   (II) RADEON(0): Panel infos found from DDC detailed: 1920x1200
3. Start the X manually from your non-root account:  startx &
4. Non-functioning system appears to clean the text screen, and leaves
   the text mode on, never turning on the graphical mode.
  
Actual results:
 Non-functional X

Expected results:
 functional X

Additional info:
  Xorg.0.log sows following at its end.  Full log file is at the attachment.

(II) Primary Device is: PCI 01@00:00:0
(II) [KMS] Kernel modesetting enabled.
(**) RADEON(0): Depth 24, (--) framebuffer bpp 32
(II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
(==) RADEON(0): Default visual is TrueColor
(**) RADEON(0): Option "accel" "on"
(**) RADEON(0): Option "AccelMethod" "shadowfb"
(**) RADEON(0): Option "DRI" "off"
(==) RADEON(0): RGB weight 888
(II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
(--) RADEON(0): Chipset: "ATI Radeon HD 2600 XT" (ChipID = 0x9588)
(II) RADEON(0): PCIE card detected
(II) RADEON(0): KMS Color Tiling: disabled
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 11, (OK)

Comment 1 matti aarnio 2009-09-16 18:22:04 UTC
Looks like recent kernel (2.6.31-12.fc12.x86_64) and Xorg server are able to start X server from large text console, and upon X server shutdown also to return to large text display.

Comment 2 matti aarnio 2009-09-20 09:28:26 UTC
Something has been done either in initrd, or in X.  Now X can start.


Note You need to log in before you can comment on or make changes to this bug.