Bug 521509 - kdeinit4 crashes at login (on X/Nouveau)
Summary: kdeinit4 crashes at login (on X/Nouveau)
Keywords:
Status: CLOSED DUPLICATE of bug 519226
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: rawhide
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 15:39 UTC by Mikko Huhtala
Modified: 2009-09-07 10:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-07 10:24:19 UTC


Attachments (Terms of Use)
Xorg.0.log (28.50 KB, text/plain)
2009-09-06 15:39 UTC, Mikko Huhtala
no flags Details

Description Mikko Huhtala 2009-09-06 15:39:45 UTC
Created attachment 359920 [details]
Xorg.0.log

Description of problem:

kdeinit4 crashes immediately when KDE launch is attempted.


Version-Release number of selected component (if applicable):

kdelibs-4.3.1-3.fc12.i686
xorg-x11-drv-nouveau-0.0.15-7.20090904git2b5ec6a.fc12.i686
xorg-x11-server-Xorg-1.6.99-45.20090903.fc12.i686
kernel-PAE-2.6.31-0.204.rc9.fc12.i686
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)


How reproducible:

Always


Steps to Reproduce:
1. Update to current rawhide on a Nvidia Geforce box
2. No xorg.conf file
3. Set DESKTOP="KDE" and DISPLAYMANAGER="KDE" in /etc/sysconfig/desktop
4. Log in from KDM
  

Actual results:

kdeinit4 crashes and the Xclients script displays the error message "kdeinit4 could not be started. Check your installation. [okay]"


Expected results:

Launch of KDE 4.


Additional info:

I get this in /var/log/messages:

Sep  6 11:11:18 urquell kernel: nouveau 0000:01:00.0: Allocating FIFO number 2
Sep  6 11:11:18 urquell kernel: nouveau 0000:01:00.0: nouveau_channel_alloc: initialised FIFO 2
Sep  6 11:11:19 urquell kernel: nouveau 0000:01:00.0: Unhandled PFIFO_INTR - 0x00000010
Sep  6 11:11:19 urquell kernel: nouveau 0000:01:00.0: Unhandled PFIFO_INTR - 0x00000010
Sep  6 11:11:19 urquell kernel: nouveau 0000:01:00.0: Unhandled PFIFO_INTR - 0x00000010
Sep  6 11:11:19 urquell kernel: nouveau 0000:01:00.0: Unhandled PFIFO_INTR - 0x00000010
Sep  6 11:11:19 urquell kernel: nouveau 0000:01:00.0: Unhandled PFIFO_INTR - 0x00000010
Sep  6 11:11:19 urquell kernel: nouveau 0000:01:00.0: Unhandled PFIFO_INTR - 0x00000010
Sep  6 11:11:19 urquell kernel: nouveau 0000:01:00.0: Unhandled PFIFO_INTR - 0x00000010
Sep  6 11:11:32 urquell kernel: kdeinit4[1470]: segfault at 80810 ip 00080810 sp bf94602c error 14 in libQtNetwork.so.4.5.2[110000+111000]
Sep  6 11:11:36 urquell kernel: nouveau 0000:01:00.0: nouveau_channel_free: freeing fifo 2
Sep  6 11:11:36 urquell kernel: nouveau 0000:01:00.0: Allocating FIFO number 2
Sep  6 11:11:36 urquell kernel: nouveau 0000:01:00.0: nouveau_channel_alloc: initialised FIFO 2

Comment 1 Kevin Kofler 2009-09-06 15:56:17 UTC
Yet another kdeinit4 crash on Rawhide. Now which one is this a duplicate of? :-(

(I don't think Nouveau has anything to do with this, it's a crash in libQtNetwork.)

Comment 2 Ngo Than 2009-09-07 10:24:19 UTC

*** This bug has been marked as a duplicate of bug 519226 ***


Note You need to log in before you can comment on or make changes to this bug.