Bug 521514 - mkinitrd needs to load virtio_pci for KVM
Summary: mkinitrd needs to load virtio_pci for KVM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd
Version: 5.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Peter Jones
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 16:30 UTC by Rik van Riel
Modified: 2013-01-09 11:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-12 13:24:36 UTC


Attachments (Terms of Use)

Description Rik van Riel 2009-09-06 16:30:37 UTC
Description of problem:

If a KVM guest is booted from a virtio disk, specified with "scsi_controller virtio_blk" in /etc/modprobe.conf, then mkinitrd should make sure virtio_pci is also loaded.

The kernel module virtio_blk cannot depend on virtio_pci because it can also work with the alternatives virtio_s390 (for s390 kvm) or virtio_lguest (for lguest).  However, RHEL only supports KVM on x86-64, so it would be nice to make it work by default.

Steps to Reproduce:
1. install a KVM guest
2. configure the guest to use virtio, both on the host side and with "scsi_controller virtio_blk" in the guest
3. watch the guest fail to boot
  
Expected results:

It would be really nice if it just worked.

Additional information:

mkinitrd by default does not let the initrd rescan the block devices for the LVM VGs, so changing the block device from emulated IDE to virtio will also break a RHEL 5 guest in other ways.  I'm filing another bug on that now :)

Comment 1 RHEL Product and Program Management 2010-07-02 03:09:19 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Alexander Todorov 2010-07-12 12:32:33 UTC
Rik,
can you be more verbose?

With RHEL5.5 and default install on RHEL6 KVM host the guesat is configured to use virtio by default. The modprobe.conf looks like:
alias scsi_hostadapter ata_piix
alias scsi_hostadapter1 virtio_blk

and the system boots successfully.

Comment 3 Rik van Riel 2010-07-12 12:51:31 UTC
OK, then I guess we fixed the bug between then and now.


Note You need to log in before you can comment on or make changes to this bug.