Bug 52152 - encrypted usernames contain invalid characters
encrypted usernames contain invalid characters
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pidentd (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 00:29 EDT by Peter Bowen
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-21 00:29:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bowen 2001-08-21 00:29:43 EDT
I'm guessing at the bug.  The problem is that with the new pindentd that
returns encrypted usernames, it sometimes returns names that IRC servers
will not accept.

Servers that complain:
irc.gnome.org
irc.openprojects.net
LinuxNet (ask around the office; someone will know the server)

Steps to reproduce:
Try to open IRC sessions to one of the listed servers and wait. The servers
may reject you because of a bad username from ident.  If not, close and try
again.
Comment 1 Trond Eivind Glomsrxd 2001-08-22 18:47:52 EDT
It's an error of the server to make assumptions on the nature of the reply. You
can turn the encryption of in /etc/identd.conf if you wish.

Note You need to log in before you can comment on or make changes to this bug.