Bug 521527 - MacBook Aluminum Install: Anaconda does not grub-install?
MacBook Aluminum Install: Anaconda does not grub-install?
Status: CLOSED DUPLICATE of bug 503149
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-06 14:50 EDT by W. Michael Petullo
Modified: 2009-09-09 10:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 10:49:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/program.log (37.64 KB, text/plain)
2009-09-08 19:34 EDT, W. Michael Petullo
no flags Details

  None (edit)
Description W. Michael Petullo 2009-09-06 14:50:30 EDT
Description of problem:
I just installed Fedora 11 on a Apple MacBook Aluminum. After installing, the system would not boot. 

Version-Release number of selected component (if applicable):
Fedora 11 Network Install Disk

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora 11 on a MacBook Aluminum
2. Reboot
  
Actual results:
The laptop does not boot off its hard disk

Expected results:
The laptop should boot off its hard disk when restarted

Additional info:
I had to boot the network install disc and choose the local disk boot option. After booting from the disk using this method, I executed "grub-install /dev/sda." I am now able to boot from the laptop's hard disk.
Comment 1 Chris Lumens 2009-09-08 15:33:03 EDT
Can you attach /var/log/program.log to this bug report?  Does this machine use EFI?
Comment 2 W. Michael Petullo 2009-09-08 19:34:09 EDT
Created attachment 360145 [details]
/var/log/program.log

I installed Fedora 11 on the MacBook after choosing Anaconda's "use entire hard drive" option. That is, I completely wiped the hard drive, created an MS-DOS-style partition table and installed Fedora using the default partition layout.
Comment 3 Chris Lumens 2009-09-09 10:49:07 EDT

*** This bug has been marked as a duplicate of bug 503149 ***

Note You need to log in before you can comment on or make changes to this bug.