Bug 521528 - MacBook Aluminum Install: Local boot option fails with default value
Summary: MacBook Aluminum Install: Local boot option fails with default value
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 523589 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 18:57 UTC by W. Michael Petullo
Modified: 2009-09-16 13:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 19:29:34 UTC


Attachments (Terms of Use)

Description W. Michael Petullo 2009-09-06 18:57:51 UTC
Description of problem:
After installing Fedora 11, I tried to boot off the local disk using the Fedora 11 network boot CD. To do this, I selected the local boot option from the initial network install CD menu. I found that the system failed to boot when I selected this option.

Version-Release number of selected component (if applicable):
Fedora 11 Network Install CD

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora 11 on an Apple MacBook Aluminium
2. Restart the system and boot using the Fedora 11 Network Install CD
3. Try to boot using the local boot option
  
Actual results:
The system fails to boot.

Expected results:
The system should boot off the local hard disk.

Additional info:
I was able to get this to work by pressing tab and changing the local boot options from ".localboot 0xffffffff" to ".localboot 0x80." I'm not sure why "0xffffffff" is the default.

Comment 1 Chris Lumens 2009-09-08 19:29:34 UTC
0xffff says to attempt a boot from the next device in the boot order, which we hope is a hard drive.  Of course, 0x80 only works when the first disk is the one we want to boot from.  What if there are multiple hard drives installed in the system?

Comment 2 W. Michael Petullo 2009-09-08 23:28:54 UTC
(In reply to comment #1)
> 0xffff says to attempt a boot from the next device in the boot order, which we
> hope is a hard drive.  Of course, 0x80 only works when the first disk is the
> one we want to boot from.  What if there are multiple hard drives installed in
> the system?  

I did not know the significance of 0xffff. However, my MacBook would not boot when using this value. So, to answer your question, in the case where there are multiple hard drives the MacBook would not boot, as long as 0xffff were used. I do not have a firm grasp on my MacBook's firmware yet (this may be due to a difference in how the MacBook boots).

Can we reopen this bug and consider it a low priority request for enhancement?

Comment 3 Chris Lumens 2009-09-16 13:32:41 UTC
*** Bug 523589 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.