Bug 52157 - XFree86 test option doesn't work
XFree86 test option doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 03:08 EDT by Chris Ricker
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 22:48:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2001-08-21 03:08:29 EDT
I did a clean install of RC1 on a Compaq 12XL125 laptop (Trident Cyberblade
chipset) using the TUI.

It detected the correct chipset and memory, but did not detect the correct
LCD.  I selected "Generic 1024x768 LCD" (which should work -- I use that
laptop at 1024x768 with a custom XFree86 config file).

At that point, no combination of color depths and resolutions would work
when I tried the test button.  All simply wrote a partially obscured
message to the screen about failing to connect.

I'm not sure if the problem is that the test feature simply doesn't work at
all, or if it didn't work for me because Anaconda doesn't generate working
XFree86 configs for my particular video card.

See also 49840, detailing the woes involved with X and this chipset.
Comment 1 Michael Fulbright 2001-08-22 13:58:15 EDT
When you try to test and it fails, look on VC2 and see if the XF86Config it
tried is still in /tmp.  Also there should be a log file there. Take a look at
these and see if there is anything obviously wrong with them.
Comment 2 Chris Ricker 2001-08-24 12:07:56 EDT
Both the test and X after boot-up fail with the same problem, "could not open
default font 'fixed'".

The test has the additional error message "failed to sent default font path
'/u/X/l/X/f/misc:unscaled,/u/X/l/X/f/Type1/,/u/X/l/X/f/Speedo/,/u/X/l/X/f/75dpi:unscaled,/u/X/l/X/f/100dpi/'

where /u/X/l/X/f/ is /usr/X11R6/lib/X11/font/

After boot-up, xfs seems to be running okay.  I can't see off-hand any reason
why it's failing.
Comment 3 Michael Fulbright 2001-08-24 15:30:36 EDT
This error - "could not open default font 'fixed'" is probably due to a bug in
the xfs server - what is /etc/X11/X a symlink to on the installed system?



Comment 4 Chris Ricker 2001-08-24 15:34:00 EDT
XFree86_SVGA
Comment 5 Michael Fulbright 2001-08-24 16:25:09 EDT
Ok so the problem once you reboot is due to a bug related to running an XFree
3.x.x server with the XFree86 4.x.x xfs.  This is corrected internally (might be
in rawhide by now, or available via the RHN beta updates).

I will try testing a video card (during the install) that uses XFree86 3.
Comment 6 Chris Ricker 2001-08-24 22:47:09 EDT
Okay, I tried that.  With the ddcprobe source in
anaconda-7.1.94-0.200108231932.src.rpm compiled without any optimization, I get:

[kaboom@verdande ddcprobe]$ sudo ./ddcprobe 
VESA 2.0 detected.
OEM Name: Matrox Graphics Inc.
Memory installed = 512 * 64k blocks = 32768kb
Supported standard modes:
        640x400x256
        640x480x256
        800x600x16
        800x600x256
        640x480x32k
        640x480x64k
        640x480x16m
        800x600x32k
        800x600x64k
        800x600x16m
        132x43 (text)
EDID ver. 1 rev. 1.
Manufacturer: AOC
ID: a785
EISA ID: AOCa785
Serial number: 0508b716.
Manufactured in week 44 of 1998.
Input signal type: analog signal.
Screen size max 32 cm horizontal, 24 cm vertical.
Gamma: 1.500000.
DPMS flags: RGB, active off, suspend, standby.
Established timings:
        640x480 @ 60 Hz (VGA)
        640x480 @ 75 Hz (VESA)
        800x600 @ 60 Hz (VESA)
        800x600 @ 72 Hz (VESA)
        800x600 @ 75 Hz (VESA)
[kaboom@verdande ddcprobe]$ sudo ./ddcprobe 
VESA 2.0 detected.
OEM Name: Matrox Graphics Inc.
Memory installed = 512 * 64k blocks = 32768kb
Supported standard modes:
        640x400x256
        640x480x256
        800x600x16
        800x600x256
        640x480x32k
        640x480x64k
        640x480x16m
        800x600x32k
        800x600x64k
        800x600x16m
        132x43 (text)
EDID ver. 1 rev. 1.
Manufacturer: AOC
ID: a785
EISA ID: AOCa785
Serial number: 0508b716.
Manufactured in week 44 of 1998.Input signal type: analog signal.
Screen size max 32 cm horizontal, 24 cm vertical.
Gamma: 1.500000.
DPMS flags: RGB, active off, suspend, standby.
Established timings:
        640x480 @ 60 Hz (VGA)
        640x480 @ 75 Hz (VESA)
        800x600 @ 60 Hz (VESA)
        800x600 @ 72 Hz (VESA)
        800x600 @ 75 Hz (VESA)
        1024x768 @ 75 Hz (VESA)
Standard timing 0: 85 Hz, 640x480
Standard timing 1: 85 Hz, 800x600
Standard timing 2: 85 Hz, 1024x768
Standard timing 3: 60 Hz, 1600x1200
Detailed timing 0:
        Pixel clock: 36000000
        Horizontal active time (pixel width): 128
        Horizontal blank time (pixel width): 704
        Vertical active time (pixel height): 224
        Vertical blank time (pixel height): 285
        Horizontal sync offset: 56
        Horizontal sync pulse width: 56
        Vertical sync offset: 3
        Vertical sync pulse width: 1
        Dimensions: 54x496
Detailed timing 1:
        Pixel clock: 56250000
        Horizontal active time (pixel width): 32
        Horizontal blank time (pixel width): 1016

        Vertical active time (pixel height): 88
        Vertical blank time (pixel height): 543
        Horizontal sync offset: 32
        Horizontal sync pulse width: 64
        Vertical sync offset: 3
        Vertical sync pulse width: 1
        Dimensions: 54x496
Detailed timing 2:
        Pixel clock: 56250000
        Horizontal active time (pixel width): 32
        Horizontal blank time (pixel width): 1016
     Vertical active time (pixel height): 88
        Vertical blank time (pixel height): 543
        Horizontal sync offset: 32
        Horizontal sync pulse width: 64
        Vertical sync offset: 3
        Vertical sync pulse width: 1
        Dimensions: 54x496
Detailed timing 3:
        Pixel clock: 78750000
        Horizontal active time (pixel width): 256
        Horizontal blank time (pixel width): 1056
        Vertical active time (pixel height): 0
        Vertical blank time (pixel height): 800
        Horizontal sync offset: 16
        Horizontal sync pulse width: 96
        Vertical sync offset: 3
        Vertical sync pulse width: 1
        Dimensions: 54x496

so it looks like it works.

With -O it works (and I get the same results as w/o any optimization)

With -O2 it works (and I get the same results as w/o any optimization)

Ditto for -O3.  If it's a timing issue, it's fixed either by that drop of
anaconda or by 7.2RC1 tool chain.

gcc used was gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-96)
Comment 7 Chris Ricker 2001-08-24 22:48:21 EDT
Oops, sorry about the weirdness cutting and pasting.  I think you got the
picture, though
Comment 8 Jeremy Katz 2001-08-27 23:36:56 EDT
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.