Bug 521577 - Laptop hangs when booting using 2.6.30.5-43.fc11.i686.PAE
Summary: Laptop hangs when booting using 2.6.30.5-43.fc11.i686.PAE
Keywords:
Status: CLOSED DUPLICATE of bug 521574
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-07 04:48 UTC by lionghostshop
Modified: 2009-09-25 15:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-25 15:50:41 UTC


Attachments (Terms of Use)

Description lionghostshop 2009-09-07 04:48:05 UTC
Description of problem:


Kernel version is 2.6.30.5-43.fc11.i686.PAE 


How reproducible:

Just Boot system

Actual results:

The system hangs when the blue screen with "F" in the middle.

Expected results:

Show login dialog soon

Additional info:

When I click the power button, the system will shutdown normally. It seems that the problem is about X driver. Both my thinkpad and hp laptops use Intel 4500 video card and have the same symptom.

Comment 1 Denis Auroux 2009-09-07 22:00:57 UTC
The bug also affects me. To give more details:

* system = Lenovo X200T with 4 GB RAM (with the 32-bit PAE kernel)
* the X11 driver is "intel" (Mobile Intel GM45 Express Chipset)

(so I also have an Intel 4500 video card).

When pressing Esc to see the startup sequence, the hangup occurs just after starting Avahi (which is the last item in /etc/rc.d/rc5.d/, excluding S99local which does nothing on my system) -- but starting Avahi manually from single-user mode doesn't hang, so presumably the hangup occurs when the X server is about to start and show the login manager.

I'm enclosing the last few lines of the Xorg.0.log, which seems to be complaining about a memory allocation issue or a mode setting issue, not sure.


II) intel(0): Using sloppy heuristic for initial modes
(II) intel(0): Output LVDS1 using initial mode 1280x800
(II) intel(0): Output DVI1 using initial mode 1024x768
(II) intel(0): Output DVI2 using initial mode 1024x768
(==) intel(0): video overlay key set to 0x101fe
(==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
(==) intel(0): DPI set to (96, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.6.1.901, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.4
(==) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
        [0] -1  0       0xffffffff - 0xffffffff (0x1) MX[B]
        [1] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]
        [2] -1  0       0x000c0000 - 0x000effff (0x30000) MX[B]
        [3] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [4] 0   0       0x000a0000 - 0x000affff (0x10000) MS[B]
        [5] 0   0       0x000b0000 - 0x000b7fff (0x8000) MS[B]
        [6] 0   0       0x000b8000 - 0x000bffff (0x8000) MS[B]
        [7] -1  0       0x0000ffff - 0x0000ffff (0x1) IX[B]
        [8] -1  0       0x00000000 - 0x00000000 (0x1) IX[B]
        [9] 0   0       0x000003b0 - 0x000003bb (0xc) IS[B]
        [10] 0  0       0x000003c0 - 0x000003df (0x20) IS[B]
(II) intel(0): [DRI2] Setup complete
(**) intel(0): Kernel mode setting active, disabling FBC.
(**) intel(0): Framebuffer compression disabled
(**) intel(0): Tiling enabled
(==) intel(0): VideoRam: 4194303 KB
(II) intel(0): Attempting memory allocation with tiled buffers.
(EE) intel(0): max_gtt_map_size: 48103kb.
(II) intel(0): Tiled allocation successful.
(II) UXA(0): Driver registered support for the following operations:
(II)         solid
(II)         copy
(II)         composite (RENDER acceleration)
(==) intel(0): Backing store disabled
(==) intel(0): Silken mouse enabled
(II) intel(0): Initializing HW Cursor
(EE) intel(0): max_gtt_map_size: 48103kb.
(II) intel(0): Fixed memory allocation layout:
(II) intel(0): 0x00000000-0xffffffff: DRI memory manager (0 kB)
(II) intel(0): 0x00000000:            end of aperture
(II) intel(0): BO memory allocation layout:
(II) intel(0): 0x00000000:            start of memory manager
(II) intel(0): 0x02418000-0x0425dfff: front buffer (31000 kB) X tiled
(II) intel(0): 0x02408000-0x02411fff: HW cursors (40 kB)
(II) intel(0): 0x00000000:            end of memory manager
(EE) intel(0): failed to set mode: Operation not permitted(EE) intel(0): max_gtt_map_size: 48103kb.

The log file for successful X startup with 2.6.29.6-217.2.16.fc11.i686.PAE starts exactly the same way, except the max_gtt_map_size is 48104kb (so just 1 kb more), and instead of stopping with "failed to set mode" it goes on to load all sorts of X server extensions.

The diff file between the two log files starts as follows:

~ > diff Xorg.0.log.old Xorg.0.log
6,7c6,7
< Current Operating System: Linux auroux-X200T.mxk.edu 2.6.30.5-43.fc11.i686.PAE #1 SMP Thu Aug 27 21:34:36 EDT 2009 i686
< Kernel command line: ro root=LABEL=/ rhgb single
---
> Current Operating System: Linux auroux-X200T.mxk.edu 2.6.29.6-217.2.16.fc11.i686.PAE #1 SMP Mon Aug 24 17:16:21 EDT 2009 i686
> Kernel command line: ro root=LABEL=/ rhgb quiet
15c15
< (==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep  7 14:45:13 2009
---
> (==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep  7 14:46:22 2009
46c46
< (--) using VT number 7
---
> (++) using VT number 1
320c320
< (EE) intel(0): max_gtt_map_size: 48103kb.
---
> (EE) intel(0): max_gtt_map_size: 48104kb.
329c329
< (EE) intel(0): max_gtt_map_size: 48103kb.
---
> (EE) intel(0): max_gtt_map_size: 48104kb.
338c338,1273
< (EE) intel(0): failed to set mode: Operation not permitted(EE) intel(0): max_gtt_map_size: 48103kb.
---
> (EE) intel(0): max_gtt_map_size: 48104kb.
> (EE) intel(0): max_gtt_map_size: 48104kb.
> (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
> (**) Option "dpms"
> (**) intel(0): DPMS enabled
> (==) intel(0): Intel XvMC decoder disabled
> (II) intel(0): Set up textured video
> (II) intel(0): direct rendering: DRI2 Enabled
> (--) RandR disabled
> (II) Initializing built-in extension Generic Event Extension
> (II) Initializing built-in extension SHAPE
> (II) Initializing built-in extension MIT-SHM
> (II) Initializing built-in extension XInputExtension
> (II) Initializing built-in extension XTEST
[... goes on for many more lines since the successful log file is much longer than the failed one ...]

Comment 2 Rajaseelan 2009-09-08 16:13:25 UTC
Same thing here. Have a X3100
2.6.29.6-217.2.16.fc11.i686.PAE back in the mean time
Using 
------------
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

Comment 3 Thomas 2009-09-08 19:23:37 UTC
Same on Dell Inspiron 1525:

lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)

Comment 4 Rajaseelan 2009-09-09 15:06:28 UTC
Guys, another Bug similiar to this has been logged.

I think we should close this & assign our votes there.

Bug 521574 - X Failed to Start with kernel-PAE-2.6.30.5-43.fc11.i686 during Boot

Comment 5 Devendra Gupta 2009-09-18 05:46:37 UTC
I also have the same problem in my Dell Inspiron 1525 . It all started after installing fedora 11, I have seen this problem in 32 bit and 64 bit fedora both. You can find the details of my problem in
 http://is.gd/3oKDs ,

 I also have 

intel x3100 graphic accelerator & 00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
Integrated Graphics Controller (rev 0c)

Comment 6 Chuck Ebbert 2009-09-25 15:50:41 UTC

*** This bug has been marked as a duplicate of bug 521574 ***


Note You need to log in before you can comment on or make changes to this bug.