Bug 521605 - systemtap went to interactive mode on ppc64
Summary: systemtap went to interactive mode on ppc64
Keywords:
Status: CLOSED DUPLICATE of bug 521600
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: systemtap
Version: 4.8
Hardware: ppc64
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Frank Ch. Eigler
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-07 08:52 UTC by Caspar Zhang
Modified: 2013-07-03 07:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-07 18:09:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
get_random_int.gen file in 2nd step. (224 bytes, text/plain)
2009-09-07 08:52 UTC, Caspar Zhang
no flags Details

Description Caspar Zhang 2009-09-07 08:52:19 UTC
Created attachment 359968 [details]
get_random_int.gen file in 2nd step.

Description of problem:

When testing bz519692, I executed the script to test:

  SYMVER=/boot/System.map-`uname -r`
  FUNC=`grep get_random_int $SYMVER | awk 'NR==1' | awk '{ print $1 }'`
  sed s#_FUNC_#0x${FUNC}# get_random_int.gen > get_random_int.stp
  stap -vvg -DMAXACTION=20480 get_random_int.stp > get_random_int.dat

but systemtap went into interactive mode and get_random_int.dat couldn't be generated.

Version-Release number of selected component (if applicable):

systemtap-runtime-0.6.2-2.el4_7.ia64.
systemtap-0.6.2-2.el4_7.ia64.
kernel-2.6.9-89.0.11

How reproducible:

100%

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:

console output:

SystemTap translator/driver (version 0.6.2/0.131 built 2009-03-17)
Copyright (C) 2005-2008 Red Hat, Inc. and others
This is free software; see the source for copying conditions.
Created temporary directory "/tmp/stap0fvy8P"
Searched '/usr/share/systemtap/tapset/ppc64/*.stp', found 1
Searched '/usr/share/systemtap/tapset/*.stp', found 37
Pass 1: parsed user script and 38 library script(s) in 310usr/0sys/357real ms.
Pass 2: analyzed script: 1 probe(s), 2 function(s), 1 embed(s), 0 global(s) in 0usr/0sys/12real ms.
Pass 3: translated to C into "/tmp/stap0fvy8P/stap_f353a80a1a5055814f9f0cd1b3790c6a_534.c" in 0usr/0sys/1real ms.
Running make -C "/lib/modules/2.6.9-89.0.11.EL/build" M="/tmp/stap0fvy8P" modules >/dev/null
Pass 4: compiled C into "stap_f353a80a1a5055814f9f0cd1b3790c6a_534.ko" in 1990usr/180sys/3386real ms.
Copying /tmp/stap0fvy8P/stap_f353a80a1a5055814f9f0cd1b3790c6a_534.ko to /root/.systemtap/cache/f3/stap_f353a80a1a5055814f9f0cd1b3790c6a_534.ko
Copying /tmp/stap0fvy8P/stap_f353a80a1a5055814f9f0cd1b3790c6a_534.c to /root/.systemtap/cache/f3/stap_f353a80a1a5055814f9f0cd1b3790c6a_534.c
Pass 5: starting run.
Running /usr/bin/staprun -v -d 4447 /tmp/stap0fvy8P/stap_f353a80a1a5055814f9f0cd1b3790c6a_534.ko
cpu 0x1: Vector: 400 (Instruction Access) at [c0000000ddaf7670]
    pc: 7c0802a6fbc1fff0
    lr: d00000000063ec98: .function_get_random_int+0x80/0xe8 [stap_f353a80a1a5055814f9f0cd1b3790c6a_534]
    sp: c0000000ddaf78f0
   msr: 8000000040009032
  current = 0xc0000000e44622c0
  paca    = 0xc000000000409000
    pid   = 4537, comm = stapio
enter ? for help
1:mon> 

And no get_random_int.dat file generated.

Expected results:

console output:

SystemTap translator/driver (version 0.6.2/0.131 built 2009-03-17)
Copyright (C) 2005-2008 Red Hat, Inc. and others
This is free software; see the source for copying conditions.
Created temporary directory "/tmp/stapBGCmMm"
Searched '/usr/share/systemtap/tapset/i686/*.stp', found 1
Searched '/usr/share/systemtap/tapset/*.stp', found 37
Pass 1: parsed user script and 38 library script(s) in 440usr/10sys/460real ms.
Pass 2: analyzed script: 1 probe(s), 2 function(s), 1 embed(s), 0 global(s) in
0usr/0sys/7real ms.
Pass 3: translated to C into
"/tmp/stapBGCmMm/stap_d6c37f5dcc49ab158c632e8b459c9dfc_512.c" in
0usr/0sys/2real ms.
Running make -C "/lib/modules/2.6.9-89.0.11.ELsmp/build" M="/tmp/stapBGCmMm"
modules >/dev/null
Pass 4: compiled C into "stap_d6c37f5dcc49ab158c632e8b459c9dfc_512.ko" in
2720usr/350sys/3807real ms.
Copying /tmp/stapBGCmMm/stap_d6c37f5dcc49ab158c632e8b459c9dfc_512.ko to
//.systemtap/cache/d6/stap_d6c37f5dcc49ab158c632e8b459c9dfc_512.ko
Copying /tmp/stapBGCmMm/stap_d6c37f5dcc49ab158c632e8b459c9dfc_512.c to
//.systemtap/cache/d6/stap_d6c37f5dcc49ab158c632e8b459c9dfc_512.c
Pass 5: starting run.
Running /usr/bin/staprun -v -d 4966
/tmp/stapBGCmMm/stap_d6c37f5dcc49ab158c632e8b459c9dfc_512.ko
stapio:cleanup_and_exit:216 CLEANUP AND EXIT  closed=0
stapio:cleanup_and_exit:229 closing control channel
Pass 5: run completed in 10usr/250sys/294real ms.
Running rm -rf /tmp/stapBGCmMm

And get_random_int.dat should exist with result datas.

Additional info:

Comment 1 Caspar Zhang 2009-09-07 09:26:26 UTC
type X in the interactive console, kernel panics and prints the following message:

1:mon> X 
Oops: Kernel access of bad area, sig: 11 [#1]
SMP NR_CPUS=64 NUMA PSERIES LPAR 
NIP: 7C0802A6FBC1FFF0 XER: 0000000000000010 LR: D00000000063EC98
REGS: c0000000ddaf7670 TRAP: 0400   Not tainted  (2.6.9-89.0.11.EL)
MSR: 8000000040009032 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 11
TASK: c0000000e44622c0[4537] 'stapio' THREAD: c0000000ddaf4000 CPU: 1
GPR00: 7C0802A6FBC1FFF0 C0000000DDAF78F0 EBC2DD2838600000 C0000000DD4CF000 
GPR04: D000000000641D78 0000000000000000 0000000000000000 0000000000000000 
GPR08: 0000000000000018 C0000000001B38C4 D00000000064BAA8 F8010010F821FF71 
GPR12: 000000000000000A C000000000409000 00000000100EADC0 00000000100EAE30 
GPR16: 00000000FFFFFFFF 00000000FFFFFFFF 0000000000000000 0000000000000000 
GPR20: 0000000000000000 0000000000000000 00000000100C0000 0000000000000000 
GPR24: 00000000100EAA80 0000000010007E08 D000000000641320 0000000000000000 
GPR28: 0000000000000000 C0000000DD4CF018 D000000000652B80 C0000000DD4CF000 
NIP [7c0802a6fbc1fff0] 0x7c0802a6fbc1fff0
LR [d00000000063ec98] .function_get_random_int+0x80/0xe8 [stap_f353a80a1a5055814f9f0cd1b3790c6a_534]
Call Trace:
[c0000000ddaf78f0] [c0000000ddaf7990] 0xc0000000ddaf7990 (unreliable)
[c0000000ddaf7980] [d00000000063ee28] .probe_1113+0x94/0x1ac [stap_f353a80a1a5055814f9f0cd1b3790c6a_534]
[c0000000ddaf7a10] [d00000000063f050] .enter_begin_probe+0x110/0x228 [stap_f353a80a1a5055814f9f0cd1b3790c6a_534]
[c0000000ddaf7aa0] [d00000000063f724] .systemtap_module_init+0x168/0x250 [stap_f353a80a1a5055814f9f0cd1b3790c6a_534]
[c0000000ddaf7b40] [d00000000063f9fc] .probe_start+0x10/0x34 [stap_f353a80a1a5055814f9f0cd1b3790c6a_534]
[c0000000ddaf7bc0] [d00000000063b6f0] ._stp_handle_start+0x48/0xb0 [stap_f353a80a1a5055814f9f0cd1b3790c6a_534]
[c0000000ddaf7c50] [d00000000063aa10] ._stp_ctl_write_cmd+0x158/0x16c [stap_f353a80a1a5055814f9f0cd1b3790c6a_534]
[c0000000ddaf7cf0] [c0000000000c46a4] .vfs_write+0x148/0x1ac
[c0000000ddaf7d90] [c0000000000c47e0] .sys_write+0x4c/0x8c
[c0000000ddaf7e30] [c000000000011280] syscall_exit+0x0/0x18
 <0>Fatal exception: panic in 5 seconds
Kernel panic - not syncing: Fatal exception
 <0>Rebooting in 180 seconds..

Comment 2 Frank Ch. Eigler 2009-09-07 18:09:02 UTC
This is the same issue.

*** This bug has been marked as a duplicate of bug 521600 ***


Note You need to log in before you can comment on or make changes to this bug.