Bug 521616 - bad video mode when no 3d
Summary: bad video mode when no 3d
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-07 09:22 UTC by Jens Petersen
Modified: 2009-09-28 00:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-26 19:44:01 UTC


Attachments (Terms of Use)
virt-manager console screenshot (35.93 KB, image/png)
2009-09-07 09:22 UTC, Jens Petersen
no flags Details

Description Jens Petersen 2009-09-07 09:22:16 UTC
Created attachment 359973 [details]
virt-manager console screenshot

Description of problem:
I am running rawhide in a i686 kvm guest and tried to run gnome-shell.

Version-Release number of selected component (if applicable):
2.27.2-2

How reproducible:
every time

Steps to Reproduce:
1. start rawhide gnome desktop in kvm
2. run "gnome-shell --replace"
  
Actual results:
vertically striped screen

Expected results:
to see gnome shell

Comment 1 Jens Petersen 2009-09-16 06:14:22 UTC
Works better but also see problems with nouveau.

Does it work better on intel? :)

Comment 2 Jens Petersen 2009-09-21 03:01:00 UTC
Ok thanks I worked it out: desktop-effects is the correct
entry point for this and politely informs one that no
3d is available.

gnome-shell works well for me on intel.

Still think it would be nice if gnome-shell (mutter?)
handled the case of no 3d support more gracefully.
I wonder if 2d compositing would ever be sufficient
for basic gnome-shell use though?

Comment 3 Jud Craft 2009-09-25 00:36:12 UTC
Gnome-shell is designed for compositing by default and was the primary driving force for the creation of the Mutter compositing branch of Metacity.  It is highly unlikely there will ever be a "GNOME-Shell for 3D-less systems".

This was a recent thread on GNOME's desktop-devel-list ("is a 3D shell bad?"), where the consensus decision is that GNOME's desktop platform has matured enough to where modern hardware should be expected.  Until 3D hardware virtualization is better, that goes for that too.

Whether you agree is another matter, but there you have it.

http://www.mail-archive.com/desktop-devel-list@gnome.org/msg16892.html

Mutter already depends on OpenGL, so it is probably not going to be refactored to support XComposite as well (see Kwin).

Comment 4 Jud Craft 2009-09-26 01:48:37 UTC
Small correction:

KVM does support virtualization of 3D, on supported cards.  Since nouveau can't do good 3D yet, I guess that doesn't help NVIDIA cards much though.

Comment 5 Kevin Kofler 2009-09-26 16:48:56 UTC
You don't need OpenGL to do compositing. KWin can do it just fine with only XRender, even software XRender (e.g. the vesa driver).

Comment 6 Kevin Kofler 2009-09-26 16:56:57 UTC
Oh, and you also don't need compositing to provide a modern desktop shell, Plasma works just fine (just with less eye candy) if you disable compositing in KWin entirely.

Comment 7 Luya Tshimbalanga 2009-09-26 18:40:05 UTC
In my personal opinion, I am disappointed with the functionality of gnome-shell that only requires 3D and not providing fallback like using XRender. After trying again Plasma on KDE4, I am impressed to see the behavior without 3D. If KDE did, why can't Gnome development?

Comment 8 Jud Craft 2009-09-26 19:35:45 UTC
Qt has much better support for animations and transformations, which allow Plasma to look really darn nice even without 3D.

GTK doesn't have nearly as much flexibility in animation; requiring Clutter helps give GTK cool capabilities it doesn't have, but requires OpenGL.

So yes, for GNOME Shell, you're gonna need 3D.  That's just the way the creators wanted to make it.

Comment 9 Owen Taylor 2009-09-26 19:44:01 UTC
This has been discussed at great length in more appropriate places, but I will quickly note that if you want to work with only software you have to either:

 - Design and implement all your animations and effects twice
Or:
 - Limit yourself to what can be done in software

Composited, alpha-blended animations cannot, in general, be done in software.

(Falling back to hardware accelerated RENDER isn't interesting... RENDER uses the same parts of the hardware as the 3D drivers, and if one can be supported in open source drivers then so can the other.)

Certainly as KDE (and Windows Vista) proved, you can do a reasonable job at providing seemless fallback given enough effort, but we'd rather put our effort into functionality and usability rather than compatibility with old hardware at this point.

P.S. - I'm not aware of any 3D virtualization capabilities in KVM - though maybe it has grown them while I wasn't looking.

Closing the bug.

Comment 10 Jud Craft 2009-09-26 20:32:20 UTC
PS.  I don't use KVM myself, but I asked the question on GNOME's desktop-devel-list and got this response:

http://osdir.com/ml/general/2009-09/msg13492.html

Wherein it is stated that KVM does 3D pretty well, and that Moblin's shell is routinely tested in KVM too.

Comment 11 Kevin Kofler 2009-09-26 20:59:51 UTC
> (Falling back to hardware accelerated RENDER isn't interesting... RENDER uses
> the same parts of the hardware as the 3D drivers, and if one can be supported
> in open source drivers then so can the other.)

Software XRender actually works for KWin effects, software OpenGL breaks for both KWin effects and gnome-shell. My experience is also that software OpenGL, when it works, is much slower than software 2D code like XRender or SDL. Of course, if you can fix and optimize Mesa, everyone will benefit...

> but we'd rather put our effort into functionality and usability rather than
> compatibility with old hardware at this point.

The way it is now, gnome-shell will not work at all on a default Fedora installation for all users with NVidia cards (die NVidia die!), not just old hardware.

Comment 12 Jens Petersen 2009-09-28 00:39:50 UTC
Just to clarify the original intention behind this bug
was really avoiding gnome-shell starting up when 3d is not
available rather than an rfe for 2d support per se.

I was starting gnome-shell from gnome-terminal: I since
discovered that it should start from Desktop Effects
which correctly refuses to start gnome-shell when there
is no 3d available.  So I guess it is ok to leave this closed.
I feel sympathic about 2d but hear what Owen is saying
about the effort vs win - hopefully when gnome3
ships 3d will be even more ubiquitous than now
and/or some 2d workarounds might be available.


Note You need to log in before you can comment on or make changes to this bug.