Bug 521634 - unable to list directory containing []
Summary: unable to list directory containing []
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: proftpd
Version: 11
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-07 11:14 UTC by idak
Modified: 2009-09-24 05:09 UTC (History)
2 users (show)

Fixed In Version: 1.3.2a-5.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 05:09:49 UTC
Type: ---


Attachments (Terms of Use)

Description idak 2009-09-07 11:14:10 UTC
Description of problem:
unable to list directory containing []
(glob chars).
Details are as follows.
http://forums.proftpd.org/smf/index.php/topic,3780.0.html

Version-Release number of selected component (if applicable):
proftpd.i586 1.3.2-2.fc11 

Steps to Reproduce:
1. make directory containing []
2. list this directory with filezilla
(which uses MLSD command instead of LIST command)

Actual results:
3. unable to list directory

Expected results:
3. able to list directory

Additional info:
This problem is already fixed in upstream CVS.
(this is not included in 1.3.2a)
Please check the following commit.
http://proftp.cvs.sourceforge.net/viewvc/proftp/proftpd/modules/mod_facts.c?r1=1.18&r2=1.19

Comment 1 Paul Howarth 2009-09-07 13:42:56 UTC
I've reproduced this and tested a fix of updating mod_facts.c to CVS HEAD. I used CVS HEAD rather than just including this particular fix because it also addresses a number of other issues such as handling paths with spaces.

Comment 2 Fedora Update System 2009-09-07 15:03:20 UTC
proftpd-1.3.2a-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/proftpd-1.3.2a-5.fc11

Comment 3 Fedora Update System 2009-09-09 01:49:40 UTC
proftpd-1.3.2a-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update proftpd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9394

Comment 4 Fedora Update System 2009-09-24 05:09:40 UTC
proftpd-1.3.2a-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.