Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 521648 - openhpid service run with unimplemented feature
Summary: openhpid service run with unimplemented feature
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openhpi
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: InitScriptsProject
TreeView+ depends on / blocked
 
Reported: 2009-09-07 12:46 UTC by Yulia Kopkova
Modified: 2010-03-18 03:25 UTC (History)
3 users (show)

Fixed In Version: openhpi-2.14.1-3.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-18 03:25:53 UTC
Type: ---


Attachments (Terms of Use)

Description Yulia Kopkova 2009-09-07 12:46:44 UTC
Description of problem:
According to https://fedoraproject.org/wiki/FCNewInit/Initscripts openhpid service should return exit code 3 if run with unimplemented feature.

The reason of filling this is "InitScripts LSB compliance project"

Version-Release number of selected component (if applicable):
openhpi-2.14.0-5.fc12.x86_64

How reproducible:
Always

Steps to Reproduce:
1.service openhpid unknown ; echo $?
2.
3.
  
Actual results:
Usage: /etc/init.d/openhpid {start|stop|restart|condrestart|try-restart|status|force-reload}
1

Expected results:
Usage: /etc/init.d/openhpid {start|stop|restart|condrestart|try-restart|status|force-reload}
3


Additional info:

Comment 3 Yulia Kopkova 2009-09-24 13:13:02 UTC
(In reply to comment #0)

> Expected results:
> Usage: /etc/init.d/openhpid
> {start|stop|restart|condrestart|try-restart|status|force-reload}
> 3

Update:

Init script should return usage and exit code "2" for unknown action:

service openhpid unknown ; echo $?

Expected results:
 Usage: /etc/init.d/openhpid
 {start|stop|restart|condrestart|try-restart|status|force-reload}
 2

Comment 4 Bug Zapper 2009-11-16 12:00:58 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Fedora Update System 2010-03-01 10:08:14 UTC
openhpi-2.14.1-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openhpi-2.14.1-3.fc13

Comment 7 Fedora Update System 2010-03-02 01:01:57 UTC
openhpi-2.14.1-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openhpi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-3264

Comment 9 Fedora Update System 2010-03-18 03:25:36 UTC
openhpi-2.14.1-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.