Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 521650 - initscripts for spamassassin daemon is not LSB compliant (service status when program is dead and /var/lock lock file exists)
Summary: initscripts for spamassassin daemon is not LSB compliant (service status when...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: InitScriptsProject
TreeView+ depends on / blocked
 
Reported: 2009-09-07 12:54 UTC by Ales Zelinka
Modified: 2010-01-19 20:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 530957 (view as bug list)
Environment:
Last Closed: 2009-10-20 22:07:26 UTC
Type: ---


Attachments (Terms of Use)

Description Ales Zelinka 2009-09-07 12:54:03 UTC
Description of problem:
According to https://fedoraproject.org/wiki/FCNewInit/Initscripts "service spamassassin
status" should return 2 when program is dead and /var/lock lock file exists.

Spamassassin service return 3 (which indicate stopped program with lock/pid cleaned
up)

Version-Release number of selected component (if applicable):
spamassassin-3.3.0-0.6.alpha2.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1.service spamassassin start
2.killall spamd
3.service spamassassin status ; echo $?
  
Actual results:
spamd is stopped
3

Expected results:
spamd dead but subsys locked
2


Additional info:
The correct exit code + error messages should be returned by "status" function
from /etc/init.d/functions. But it is not used, probably because of the
inconsistency between process names (spamd) and service name (spamassassin) that the "status" function can't handle.

Comment 1 Jason Tibbitts 2009-09-08 21:36:38 UTC
That's just a random page in the wiki.  It has no force as a guideline.  I can't comment on whether the things in there are even remotely good ideas, but don't go quoting random wiki pages as if anything is supposed to obey them.

Comment 2 Kevin Fenzi 2009-09-08 23:09:25 UTC
The real guideline page is https://fedoraproject.org/wiki/Packaging/SysVInitScript 
and the filed bugs do seem to be valid against that page... 

See/continue discussion in the blocking bug for this one?

Comment 3 Warren Togami 2009-10-20 22:07:26 UTC
Fixed in spamassassin-3.3.0


Note You need to log in before you can comment on or make changes to this bug.