Bug 52170 - System does not boot up again after shutting down using the halt option
System does not boot up again after shutting down using the halt option
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 04:55 EDT by Simon Lapraik
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Lapraik 2001-08-21 04:55:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
Whenever I try to boot up my RH7.1 system after shutting it down with the 
halt option, it always gets as far as "Configured Kernel parameters   
[OK]" and then appears to stop/hang

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Shutdown system using the halt option
2. Then attempt to boot RH7.1 again
3. 

	

Actual Results:  It gets as far as "Configured kernel parameters   [OK]" 
and then appears to stop/hang.

Expected Results:  RH7.1 would boot up to X.

Additional info:

I don't see any errors during either shutdown to boot up. When the error 
occurs, I have to turn the machine off, back on, boot up WIN98, start 
Partition Magic 6, and set the Linux partition back to active. Boot Magic 
is installed to the MBR, so LILO was installed in the Linux / partition.

The machine uses an ASUS A7A266 motherboard with an AMD 1.3GHz processor, 
512 MB ram, and 40GB HDD.

The problem does not occur if I do a shutdown with the reboot option from 
within Linux. This is what I currently do to get around the problem and 
simply hit the power off button during the machines POST.
Comment 1 Arjan van de Ven 2001-08-21 05:09:18 EDT
Can you try passing "reboot=b" or "reboot=c" on the kernel commandline (eg in
lilo type "linux reboot=b") on the FIRST boot to see if the changed reboot
behavior that this option causes, fixes this problem ?
Comment 2 Simon Lapraik 2001-08-21 08:37:16 EDT
I am new to Linux, so I hope I have done things correctly!

Using linuxconf, I updated my LILO configuration placing "reboot=b" in the
append section. Once saved, I selected Logout and used the "reboot" option. Once
the system had rebooted and showed the X login panel, I selected System, Halt.
The system shutdown and turned itself off. After a couple of mins, I restarted
the machine and selected to boot Linux from the BootMagic options. Again it got
as far as "Configuring kernel parameters   [OK]" and then stopped.

After booting into WIN98, making the Linux partition active again and rebooted,
I used the same method to set "reboot=c". However the system still did not get
any further.

My current lilo.conf file looks like this...

  boot = /dev/hda4
  map = /boot/map
  delay = 100
  timeout = 50
  prompt
    message = /boot/message
    default = linux
    vga = normal
    read-only
  install=/boot/boot.b
  image = /boot/vmlinuz-2.4.2-2
    label = linux.bak
    append = "hdc=ide-scsi"
    root = /dev/hda4
  image = /boot/vmlinuz-2.4.3-12
    label = linux
    append = "hdc=ide-scsi reboot=c"
    root = /dev/hda4
  other = /dev/hda6
    label = dos
    optional

Thanks.
Simon

Comment 3 Arjan van de Ven 2001-08-21 08:47:11 EDT
After changing the lilo.conf file, you must run (as root) the "lilo" program
to make the changes take effect...
Comment 4 Simon Lapraik 2001-08-21 09:39:38 EDT
Sorry, I thought linuxconf had done the lilo command for me, because after I
made the change to the relevant lilo image, it asked me whether I wanted to
activate the change.

Anyway, I made the changes again, this time running lilo after running
linuxconf. However the system still stops loading after "Configuring kernel
parameters   [OK]".

Simon
Comment 5 Simon Lapraik 2001-09-04 12:13:50 EDT
Are there any other options I can try here, or debugging I can turn on to see if
it gives us a clue as to what is happening?

Thanks,
Simon
Comment 6 Arjan van de Ven 2001-09-04 12:16:10 EDT
reboot=c might work, but if it doesn't, I really suggest a bios upgrade.
Also, could you try booting without dma ("ide=nodma" or with hdparm before
rebooting) to see if the bios gets confused by IDE DMA?
Comment 7 Simon Lapraik 2001-09-17 05:33:17 EDT
I have tried reboot=c and that did not work. My machine is running the latest
BIOS available from the maker of the motherboard (ASUS). I have just tried
"ide=nodma" and that did not make any difference. Everytime I shutdown the
machine with the halt option, when it comes to turning the machine on again, it
gets as far as "Configuring Kernel parameters   [OK]" and then stops. If I just
use shutdown with the reboot option, the machine reboots fine.

Are there any debug options I can turn on to try and find out exactly what is
failing here during the boot process?

Not sure if it will help, but here is the latest copy of my kernel boot log....

Linux version 2.4.3-12 (root@porky.devel.redhat.com) (gcc version 2.96 20000731
(Red Hat Linux 7.1 2.96-85)) #1 Fri Jun 8 15:05:56 EDT 2001
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001ffec000 (usable)
 BIOS-e820: 000000001ffec000 - 000000001ffef000 (ACPI data)
 BIOS-e820: 000000001ffef000 - 000000001ffff000 (reserved)
 BIOS-e820: 000000001ffff000 - 0000000020000000 (ACPI NVS)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
On node 0 totalpages: 131052
zone(0): 4096 pages.
zone(1): 126956 pages.
zone(2): 0 pages.
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Kernel command line: auto BOOT_IMAGE=linux ro root=304
BOOT_FILE=/boot/vmlinuz-2.4.3-12 hdc=ide-scsi ide=nodma
ide_setup: hdc=ide-scsi
ide_setup: ide=nodmaIDE: Prevented DMA
Initializing CPU#0
Detected 1343.147 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 2680.42 BogoMIPS
Memory: 508988k/524208k available (1235k kernel code, 10740k reserved, 94k data,
244k init, 0k highmem)
Dentry-cache hash table entries: 65536 (order: 7, 524288 bytes)
Buffer-cache hash table entries: 32768 (order: 5, 131072 bytes)
Page-cache hash table entries: 131072 (order: 8, 1048576 bytes)
Inode-cache hash table entries: 32768 (order: 6, 262144 bytes)
VFS: Diskquotas version dquot_6.5.0 initialized
CPU: Before vendor init, caps: 0183fbff c1c7fbff 00000000, vendor = 2
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After vendor init, caps: 0183fbff c1c7fbff 00000000 00000000
CPU:     After generic, caps: 0183fbff c1c7fbff 00000000 00000000
CPU:             Common caps: 0183fbff c1c7fbff 00000000 00000000
CPU: AMD Athlon(tm) Processor stepping 04
Enabling fast FPU save and restore... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xf1170, last bus=1
PCI: Using configurationtype 1
PCI: Probing PCI hardware
Unknown bridge resource 0: assuming transparent
PCI: Using IRQ router ALI [10b9/1533] at 00:07.0
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.14)
Starting kswapd v1.8
pty: 2048 Unix98 ptys configured
block: queued sectors max/low 338008kB/206936kB, 1024 slots per queue
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ALI15X3: IDE controller on PCI bus 00 dev 20
PCI: No IRQ known for interrupt pin A of device 00:04.0. Please try using
pci=biosirq.
ALI15X3: chipset revision 196
ALI15X3: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xd400-0xd407, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xd408-0xd40f, BIOS settings: hdc:DMA, hdd:DMA
hda: FUJITSU MPG3409AH E, ATA DISK drive
hdc: CD-W512EB, ATAPI CD/DVD-ROM drive
hdd: DVD-ROM BDV212B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 80063424 sectors (40992 MB) w/2048KiB Cache, CHS=4983/255/63
Partition check:
 hda: hda1 hda2 hda3 < hda5 hda6 hda7 > hda4
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
Serial driver version 5.05a (2001-03-20) with MANY_PORTS MULTIPORT SHARE_IRQ
SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10d
md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md.c: sizeof(mdp_super_t) = 4096
autodetecting RAID arrays
autorun ...
... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 32768)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 244k freed
Adding Swap: 1574328k swap-space (priority -1)
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
PCI: Found IRQ 9 for device 00:02.0
usb-ohci.c: USB OHCI at membase 0xe08d5000, IRQ 9
usb-ohci.c: usb-00:02.0, Acer Laboratories Inc. [ALi] M5237 USB
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 4 ports detected
PCI: Found IRQ 9 for device 00:06.0
usb-ohci.c: USB OHCI at membase 0xe08d7000, IRQ 9
usb-ohci.c: usb-00:06.0, Acer Laboratories Inc. [ALi] M5237 USB (#2)
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
hdd: ATAPI 40X DVD-ROM drive, 512kB Cache
Uniform CD-ROM driver Revision: 3.12
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: TEAC      Model: CD-W512EB         Rev: 2.0B
  Type:   CD-ROM                             ANSI SCSI revision: 02



Comment 8 Bugzilla owner 2004-09-30 11:39:07 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.