Bug 52171 - Warm reboot fails
Summary: Warm reboot fails
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-21 09:32 UTC by George Thomas
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 17:19:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description George Thomas 2001-08-21 09:32:36 UTC
Description of Problem:

Warm reboot on IBM 540 laptop fails.  Gets DMA timeout during IDE 
initialization which seems to be unrecoverable.

Cold reboot on same platform works fine.

Version-Release number of selected component (if applicable):
2.4.7-2 (and 2.4.7-2.5)

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 George Thomas 2001-08-21 09:36:20 UTC
I tried adding 'reboot=b' to the kernel options (as requested) with
no improvement.

Here are the kernel (dmesg) notes during bootup on this hardware:

Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 31
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x1800-0x1807, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x1808-0x180f, BIOS settings: hdc:pio, hdd:pio
hda: IBM-DBCA-206480, ATA DISK drive
hdc: CRN-8241B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 12594960 sectors (6449 MB) w/420KiB Cache, CHS=833/240/63, UDMA(33)
ide-floppy driver 0.97
Partition check:
 hda: hda1 hda2 hda3 < hda5 >


Comment 2 Glen Foster 2001-08-21 20:29:03 UTC
We (Red Hat) should try to fix this before next release.

Comment 3 Arjan van de Ven 2001-08-25 10:42:28 UTC
ok next one: reboot=c
(there's also reboot=h )

Comment 4 Arjan van de Ven 2001-08-25 10:43:55 UTC
(oh and that has to be active _the first boot_, eg the one you will type
"reboot" in)

Comment 5 George Thomas 2001-08-25 11:50:09 UTC
I'm not sure I'm doing this correctly.  Here's [part] of /boot/grub/grub.conf:
  title Red Hat Linux (2.4.7-2.5)
	root (hd0,1)
	kernel /boot/vmlinuz-2.4.7-2.5 ro root=/dev/hda2 reboot=h

Is this correct?

I have tried all three recommendations (reboot=c/r/h)  None of them have 
any real affect on the problem.  Note: reboot=h caused the system to just
stop when I ran reboot.


Comment 6 Arjan van de Ven 2001-08-25 11:57:31 UTC
the grub magic is correct. Hm.
Maybe the bios gets confused by having DMA enabled;
If you try "ide=nodma" on the first boot, and it fixes it, this is indeed the
problem

Comment 7 George Thomas 2001-08-25 12:18:03 UTC
No difference.  It hangs (and eventually times out) while scanning hda for
partitions.

Comment 8 Alan Cox 2003-06-05 17:19:44 UTC
Newer IDE code scratch configures the PIIX4



Note You need to log in before you can comment on or make changes to this bug.