Bug 521722 - wxMaxima does not pass my input to maxima
Summary: wxMaxima does not pass my input to maxima
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wxMaxima
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-07 23:15 UTC by Muayyad Alsadi
Modified: 2009-12-04 23:53 UTC (History)
2 users (show)

Fixed In Version: 0.8.3a-1.fc11.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-04 23:53:01 UTC


Attachments (Terms of Use)

Description Muayyad Alsadi 2009-09-07 23:15:05 UTC
Description of problem:
it does not evaluate my input
but it works when you use the menu

Version-Release number of selected component (if applicable):
maxima-runtime-sbcl-5.18.1-6.fc11.i586
maxima-5.18.1-6.fc11.i586
wxMaxima-0.8.2

How reproducible:
always

Steps to Reproduce:
1. type 1+2; on maxima console
2. use calculus menu to integrate sin(x)
  
Actual results:
does not pass the input for 1+2;
but the menu works

Expected results:
both should work

Additional info:
same problem in wxMaxima-0.8.3 (I built it myself)

Comment 1 Rex Dieter 2009-11-11 17:00:34 UTC
please re-check against wxMaxima-0.8.3a recently pushed to stable updates.

Comment 2 Muayyad Alsadi 2009-11-11 17:29:53 UTC
the problem is still there, I'm using

maxima-runtime-sbcl-5.18.1-6.fc11.i586
maxima-5.18.1-6.fc11.i586
wxMaxima-0.8.3a-1.fc11.i586

Comment 3 Rex Dieter 2009-11-12 03:38:38 UTC
OK, as I can't reproduce this on my f12 box, I'll see about getting an f11 one for some testing.

Comment 4 Rex Dieter 2009-11-12 16:26:19 UTC
Another test to try is to see if a maxima upgrade may help, mind testing out this maxima-5.19 scratch build?

http://koji.fedoraproject.org/koji/taskinfo?taskID=1803600

Comment 5 Muayyad Alsadi 2009-11-13 19:37:11 UTC
thank you that solved the problem.

Comment 6 Fedora Update System 2009-11-14 05:05:10 UTC
wxMaxima-0.8.3a-1.fc11.1,maxima-5.19.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wxMaxima-0.8.3a-1.fc11.1,maxima-5.19.2-1.fc11

Comment 7 Fedora Update System 2009-11-16 07:25:43 UTC
wxMaxima-0.8.3a-1.fc11.1, maxima-5.19.2-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wxMaxima maxima'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-11496

Comment 8 Muayyad Alsadi 2009-11-16 17:58:26 UTC
I'm shocked! it's not working again

I've typed

yum -y --enablerepo=updates-testing update wxMaxima maxima maxima-runtime-sbcl


[root@pc1 ~]# rpm -qa '*[Mm]axima*'
wxMaxima-0.8.3a-1.fc11.1.i586
maxima-5.19.2-1.fc11.i586
maxima-runtime-sbcl-5.19.2-1.fc11.i586

I noticed this on command line

[alsadi@pc1 ~]$ wxmaxima 

** (wxmaxima:9522): WARNING **: IPP request failed with status 1030

** (wxmaxima:9522): WARNING **: IPP request failed with status 1030

I've tried rm ~/.wxMaxima but nothing changed

I've reverted to the version I said it worked in comment #5 and it did not

rpm -qa '*[Mm]axima*'
wxMaxima-0.8.3a-1.fc11.i586
maxima-5.19.2-0.1.fc11.i586
maxima-runtime-sbcl-5.19.2-0.1.fc11.i586

what does wxMaxima use for IPP ?

Comment 9 Rex Dieter 2009-11-16 18:43:14 UTC
the ipp stuff is unrelated

Comment 10 Fedora Update System 2009-11-18 14:06:30 UTC
wxMaxima-0.8.3a-1.fc11.1, maxima-5.19.2-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wxMaxima maxima'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-11496

Comment 11 Fedora Update System 2009-12-04 23:52:50 UTC
wxMaxima-0.8.3a-1.fc11.1, maxima-5.19.2-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.