Bug 521748 - OSError: [Errno 22] Invalid argument: '/var/run/yum.pid'
Summary: OSError: [Errno 22] Invalid argument: '/var/run/yum.pid'
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 06:09 UTC by Michal Nowak
Modified: 2014-01-21 23:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-11 14:36:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Nowak 2009-09-08 06:09:55 UTC
Description of problem:

newman ~ $ sudo yum upgrade --skip-broken
Loaded plugins: dellsysidplugin2, downloadonly, presto, refresh-packagekit, upgrade-helper
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 311, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 168, in main
    base.doLock()
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1209, in doLock
    while not self._lock(lockfile, mypid, 0644):
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1262, in _lock
    if not msg.errno == errno.EEXIST: raise msg
OSError: [Errno 22] Invalid argument: '/var/run/yum.pid'

yum info runs OK.

Version-Release number of selected component (if applicable):

yum-3.2.23-15.fc12.noarch

Additional info:

Was downloading updates but suspended whole machine, then started it again and canceled the download, now I can't update/install/...

newman ~ $ ls -l /var/run/yum.pid
ls: cannot access /var/run/yum.pid: No such file or directory

Comment 1 seth vidal 2009-09-08 19:28:04 UTC
Do you have a /var/run dir at all?

Comment 2 Michal Nowak 2009-09-09 07:44:33 UTC
Oh, yeah, sure I do. The rest of the system was fine. I restarted the box because I've needed yum working, so, the traceback is gone now -- just in case you can see something useful in the bt...

Comment 3 seth vidal 2009-09-09 14:15:59 UTC
I suspect this might be some kind of race - maybe there was another yum-using process running

I'll see if I can catch this exception more nicely.

thanks

Comment 4 Michal Nowak 2009-09-09 14:26:16 UTC
I tried that the day I've spotted the exception several times and tomorrow morning once, then I rebooted.

Comment 5 seth vidal 2009-09-09 19:46:06 UTC
any chance that /var/run is a weird format or has any odd mounting options? Maybe noexec?

Comment 6 seth vidal 2009-09-09 20:30:22 UTC
If you can still make this happen I have a patch I'd love for you to test.

http://lists.baseurl.org/pipermail/yum-devel/2009-September/005847.html

Comment 7 Michal Nowak 2009-09-11 14:12:22 UTC
(In reply to comment #5)
> any chance that /var/run is a weird format or has any odd mounting options?
> Maybe noexec?  

newman F-10 $ sudo ls -l /var/run/ -d
drwxr-xr-x. 39 root root 4096 2009-09-11 16:04 /var/run/

newman F-10 $ sudo file /var/run/ -d
/var/run/: directory

/var is the same volume as /. 

/dev/VolGroup00/LogVolRoot /                       ext4 defaults        1 1

(In reply to comment #6)
> If you can still make this happen I have a patch I'd love for you to test.
> 
> http://lists.baseurl.org/pipermail/yum-devel/2009-September/005847.html  

Sorry. Disappeared after restart.

Comment 8 seth vidal 2009-09-11 14:36:29 UTC
okay. well I'm fairly sure my patch will help the problem for the future.

I'm going to close this upstream.

Comment 9 Michal Nowak 2009-09-11 17:36:06 UTC
OK. Thanks!

Comment 10 Fedora Update System 2009-09-30 01:39:34 UTC
yum-3.2.24-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2009-10-19 16:46:01 UTC
yum-3.2.24-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-3.2.24-2.fc10

Comment 12 Fedora Update System 2009-11-04 12:06:55 UTC
yum-3.2.24-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.