Bug 52179 - Unknown exception while linux is being installed
Unknown exception while linux is being installed
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-08-21 09:22 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-09-10 11:11:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
error log containing the error description (10.35 KB, text/plain)
2001-08-21 09:24 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-08-21 09:22:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Win98; U)

Description of problem:
Unknown exception when the installation components are being copied to the system.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.while installing linux 7.1
2.After disk partitioning
3.While the modules are being copied

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "./gui.py", line 391, in run
    self.icw.run ()
  File "./gui.py", line 879, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "./gui.py", line 500, in nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "./gui.py", line 610, in setScreen
    new_screen = screen.getScreen ()
  File "./iw/rootpartition_gui.py", line 189, in getScreen
    avail = apply(isys.spaceAvailable, rootdev)
  File "./isys.py", line 19, in spaceAvailable
    mount(device, "/mnt/space", fstype = fsystem)
  File "./isys.py", line 120, in mount
    rc = _isys.mount(fstype, device, location, readOnly)
SystemError: (22, 'Invalid argument')
Comment 1 Need Real Name 2001-08-21 09:24:19 EDT
Created attachment 28696 [details]
error log containing the error description
Comment 2 Brent Fox 2001-08-21 14:24:11 EDT
Was hda7 an already existing, formatted FAT filesystem or did you create it in
Disk Druid?
Comment 3 Need Real Name 2001-08-24 06:13:16 EDT
hda7 was an already existing FAT formatted drive.
Comment 4 Brent Fox 2001-08-28 10:25:16 EDT
Well, a workaround is to not set a mount point for the Windows partition in the
installer and instead do it after installation by adding it to the /etc/fstab file.

The bigger question is why the installer crashes while trying to mount the FAT
partition.  We have gotten a number of bugs like this and I've never been able
to reproduce it.  I've done a lot of testing with mounting FAT partitions in the
installer and I haven't been able to reproduce it.  Did you run out of space in
the installer and have to back up and remove some packages and then go forward
Comment 5 Brent Fox 2001-09-10 11:11:12 EDT
Any more info here?
Comment 6 Brent Fox 2001-09-24 12:10:00 EDT
Closing due to inactivity.  Please reopen if you have more information.
Comment 7 Need Real Name 2001-10-22 17:23:55 EDT
I have had lots of problems trying to install Red Hat 7.1.

I tried all the lame solutions that didn't work.  Using an additional driver disk issueing a" Linxu driver" at the install prompt.
Using an additional update disk issueing a "Linux update" at the install prompt.  No deal.  They didn't work because
that wasn't 

Basically, I think many peoples problems with Red Hat  installs can be solved by doing what I did:
(by the way, I discovered this on my own through experiment)

1)  install an older version of Red Hat (I used my old 5.1) and run Disk Druid to partition a swap and a root drive.
     I gave a regular amount of space to the swap and all the remaining space to the root.  It doesn't really matter
    though because when you "Finally" get Red Hat 7.1 to install in the next step you can re-partition then.  As
    we should have been able to in the first place!
2)  after you do this the system will want to re-start.  Let it restart BUT put your 7.1 CD in the drive now so it'll
     go through the install as it should have.


Note You need to log in before you can comment on or make changes to this bug.