Bug 52180 - umount fails - device busy
umount fails - device busy
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 09:44 EDT by Gene Czarcinski
Modified: 2014-03-16 22:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 06:00:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/mounts (440 bytes, text/plain)
2001-08-23 11:46 EDT, Gene Czarcinski
no flags Details
/proc/mounts (440 bytes, text/plain)
2001-08-23 11:46 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2001-08-21 09:44:46 EDT
Description of Problem:
This is complicated and may be kernel, mount, or something else but I am
starting with initscripts.

This occurs on beta hardware system #28 (all scsi disks) as well as another
system with only ide disks.

I have created a rc1 (roswell2) system with multiple partitions (lots of
them).  When I installed rc1, I made /, /usr, and /usr/src all ext3
partitions.  However, I left /home, usr/local, and a bunch of other
partitions mounted on /home all ext2.

During shutdown, I get messages that umount2 FAILED with device busy for
both /home and /usr.  /etc/init.d/halt then trys to umount again.  Most of
the time this succeeds.  However, at least one time this failed also.

I have run some "controlled" experiments:

I switch to single user mode (telinit 1) and make sure everything is down.
 I then manually umount partitions.

I get clean shutdowns if only / and /usr are left mounts.  Other
combinations (including only / and /home) result in failed umounts.

Version-Release number of selected component (if applicable):


How Reproducible:
repeatable

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
umount failed during shutdown

Expected Results:
clean shutdown

Additional Information:
Comment 1 Glen Foster 2001-08-21 16:30:01 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 2 Gene Czarcinski 2001-08-23 07:08:54 EDT
I have become convinced it is something to do with ext3 so I am changing this to
kernel.

The problem seems to occur when there are any other partitions other that / and
/usr mounted.  With /, /usr, and /usr/src all ext3 are mounted, the first umail
of /usr fails but succeeds on the retry.  This has happened for every shutdown I
have tried.

I have added arjanv@redhat.com as a CC since that seems to be the assignee for
new kernel problems.
Comment 3 Arjan van de Ven 2001-08-23 09:03:20 EDT
Could you paste/attach the output of "mount" during a normal session ?
(eg just boot as you normally would)
Comment 4 Gene Czarcinski 2001-08-23 11:42:40 EDT
I am now thinking that I was correct in my first call as being an initscripts
problem.  I believe that /etc/init.d/halt tries to umount /usr before it has
umounted /usr/src.

Also, if you have a partition mounted even lower in a directory tree, it will
really fail:  /usr/src/redhat/SOURCES

I am attaching my /proc/mounts (is this what you want?).

I have changed the Component back to initscripts.

Comment 5 Gene Czarcinski 2001-08-23 11:46:37 EDT
Created attachment 29214 [details]
/proc/mounts
Comment 6 Gene Czarcinski 2001-08-23 11:46:40 EDT
Created attachment 29215 [details]
/proc/mounts
Comment 7 Gene Czarcinski 2001-08-23 11:56:13 EDT
I see the problem in /etc/init.d/halt --

In function "halt_get_remaining", the output of awk needs to be piped to sort -r 

I will try this later
Comment 8 Bill Nottingham 2001-08-24 12:12:33 EDT
Will be added in 6.27-1.

Note You need to log in before you can comment on or make changes to this bug.